15:02:16 <rdieter> #startmeeting kde-sig
15:02:16 <zodbot> Meeting started Tue Sep 4 15:02:16 2012 UTC. The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:21 <rdieter> #meetingname kde-sig
15:02:21 <zodbot> The meeting name has been set to 'kde-sig'
15:02:25 <rdieter> #topic roll call
15:02:30 <rdieter> hola, who's present today?
15:03:19 <Kevin_Kofler> Present.
15:03:20 * rnovacek is here
15:03:59 <rdieter> jreznik, than, ltinkl : ping
15:04:00 <than> present.
15:04:13 * ltinkl is here
15:05:24 * jreznik is here
15:05:25 <rdieter> #info rdieter tdfischer Kevin_Kofler rnovacek than ltinkl present
15:05:31 <tdfischer> howdy
15:05:34 <rdieter> #info jreznik present too
15:05:44 <rdieter> #chair tdfischer Kevin_Kofler rnovacek than ltinkl jreznik
15:05:44 <zodbot> Current chairs: Kevin_Kofler jreznik ltinkl rdieter rnovacek tdfischer than
15:05:50 <rdieter> #topic agenda
15:05:54 <rdieter> what to discuss today
15:05:56 <rdieter> ?
15:06:11 <rdieter> kde-4.9.1 status, f18alpha status
15:06:19 <tdfischer> possibly something about KDE at ohio linux fest too
15:06:19 <jreznik> yep
15:06:33 <tdfischer> now that I think about it, since its close and such
15:07:10 <rdieter> tdfischer: when is it?
15:07:22 <tdfischer> September 28-30
15:07:33 <tdfischer> the last weekend of this month
15:07:43 <rdieter> cool.
15:07:45 <tdfischer> I'm a 2 hour drive and plan on being there and running a KDE BoF
15:08:14 <rdieter> ok, can through that at the end
15:08:17 <rdieter> #topic kde-4.9.1
15:08:25 <rdieter> than: how goes 4.9.1'ing ?
15:09:13 <than> 4.9.1 was already uploaded in git
15:09:38 <than> i hope to get it done today
15:09:45 <than> or tomorrow
15:10:24 <rdieter> I can help some too, have f18-kde, f17-kde koji targets ready once rawhide builds are done
15:10:40 <than> of course, helps are welcome :)
15:10:49 <Kevin_Kofler> Good, so are we going to get that into F17 updates?
15:11:13 <jreznik> 4.9.1 was a target
15:11:39 <Kevin_Kofler> Yep, just checking that we're still on target. :-)
15:11:45 <rnovacek> I'm +1, no issues on F17 with 4.9.0 here
15:11:54 * ltinkl agrees too
15:12:02 <Kevin_Kofler> Yeah, go ahead.
15:12:04 <than> 4.9.1 is good candidate for f17 update
15:12:22 <rnovacek> just a couple of days to check that 4.9.1 won't break anything...
15:13:12 <rdieter> #info than has 4.9.1 imported into git, will try to finish up rawhide builds today
15:13:41 <rdieter> #info will then work on builds for f18-kde f17-kde koji targets
15:14:01 <rdieter> anything else wrt kde-4.9.1 ?
15:14:28 <ltinkl> that's what updates-testing is for :)
15:15:14 <rdieter> #topic f18 alpha, kde issues/blockers
15:15:28 <Kevin_Kofler> ltinkl: +1 :-)
15:15:32 <jreznik> #link http://qa.fedoraproject.org/blockerbugs/current
15:15:36 <rdieter> .bug 853587
15:15:38 <zodbot> rdieter: Bug 853587 Patch for "fix QtScript JIT crash (QTBUG-23871, kde#297661)" applied in qt-4.8.2-5 causes frequent segmentation faults - https://bugzilla.redhat.com/show_bug.cgi?id=853587
15:15:53 <rdieter> ^^ just reverted the problematic patch, qt-4.8.1-6 builds underway
15:16:09 * jreznik reported upstream that the patch causes regressions
15:16:18 <rdieter> jreznik: thanks
15:16:31 <rdieter> jreznik: have any link or reference ?
15:17:17 <jreznik> #link https://bugreports.qt-project.org/browse/QTBUG-23871
15:18:33 <jreznik> let's see if it's really the patch, but seems like
15:18:37 <jreznik> .bug 853985
15:18:40 <zodbot> jreznik: Bug 853985 KDM autologin does not work on Live - https://bugzilla.redhat.com/show_bug.cgi?id=853985
15:19:15 <jreznik> dvratil was working on this - he prepared patch - seems like kdm started before liveuser was created
15:19:25 <rdieter> https://admin.fedoraproject.org/updates/kde-settings-4.9-9.fc18
15:19:38 <ltinkl> yup, dvratil fixed that
15:20:08 <jreznik> or not a patch, but fix :)))
15:20:27 <jreznik> and seems it confirmed my theory :)
15:20:39 <rdieter> hrm, I see prefdm.service on f17 had
15:20:42 <rdieter> After=livesys-late.service rc-local.service systemd-user-sessions.service
15:21:00 <rdieter> should these new dm services all include the same stuff?
15:21:15 <jreznik> ah, so we should probably add also rc-local and systemd-user-sessions?
15:21:34 <rdieter> seems so
15:21:38 <Kevin_Kofler> Ask Lennart. :-)
15:22:21 <rdieter> OK, I'll mention that in bz as another open question.
15:23:01 <jreznik> what's done in rc-local and systemd-user-sessions is now the question
15:24:18 <Kevin_Kofler> rc-local runs /etc/rc.d/rc-local
15:24:18 <jreznik> anything else for this one?
15:24:34 <Kevin_Kofler> What systemd-user-sessions does, I don't know.
15:24:34 <jreznik> Kevin_Kofler: the name says so...
15:24:45 <jreznik> for user-session I'm not sure and would be great to know
15:25:32 <Kevin_Kofler> I guess it initializes a default set of user sessions? But the systemd folks can tell you in any case. :-)
15:25:46 * rdieter added comment to https://bugzilla.redhat.com/show_bug.cgi?id=850775 , hopefully it doesn't get lost in all the (imo) extraneous/offtopic comments going on there
15:26:04 * jreznik is still more inclined to add it there to copy prefdm behavior
15:27:05 <rdieter> jreznik: +1, i'll add after meeting, revert it only if someone says it's a bad idea
15:27:29 <jreznik> rdieter: thanks
15:27:47 <Kevin_Kofler> OK
15:28:03 <jreznik> #action rdieter to adjust kdm dm service
15:28:19 <jreznik> .bug 852403
15:28:23 <zodbot> jreznik: Bug 852403 PolicyKit authentication in Fedora 18 Alpha TC3 results in selinux denial - https://bugzilla.redhat.com/show_bug.cgi?id=852403
15:28:26 * nirik reads up, suspects lightdm needs this same for xfce spin
15:28:33 <jreznik> nirik: yep
15:28:58 <jreznik> nirik: btw. is there autologin feature?
15:29:10 <nirik> yes
15:29:11 <rdieter> nirik: I'll fix lightdm at the same time I'm doing kdm fixes
15:29:16 <nirik> rdieter: thanks.
15:29:28 * nirik guesses he needs to propose the lightdm update as a NTH or something.
15:29:38 <rdieter> nirik: I think it already is
15:29:43 <nirik> oh?
15:29:46 * nirik looks
15:30:04 <rdieter> http://qa.fedoraproject.org/blockerbugs/current it's on the proposed NTH list
15:30:11 <nirik> yep. I see.
15:30:12 <nirik> cool.
15:30:17 <nirik> but it also needs this fix.
15:30:29 <rdieter> yep
15:30:56 <rdieter> and... if I still have time after that, will try to look into the PK/apper issue
15:31:18 <rdieter> .bug 854209
15:31:20 <jreznik> for the kde polkit issue - it was closed as a dupe of this bug, should be fixed
15:31:21 <zodbot> rdieter: Bug 854209 Apper: The remote software origin name was not found - https://bugzilla.redhat.com/show_bug.cgi?id=854209
15:31:44 <rdieter> I may end up poking dannti about that one, but we'll see
15:31:54 <Kevin_Kofler> jreznik: The polkit issue was closed as a dupe of a polkit bug.
15:32:12 <Kevin_Kofler> https://bugzilla.redhat.com/show_bug.cgi?id=852403
15:32:17 <Kevin_Kofler> selinux-policy bug actually.
15:32:25 <Kevin_Kofler> It's on the accepted blocker list.
15:32:29 <jreznik> Kevin_Kofler: yep, that was my comment
15:32:34 <jreznik> it's verified
15:33:37 <rdieter> that seems to be all the kde-related blocker bugs, right?
15:33:46 <rdieter> (so far)
15:34:38 <jreznik> .bug 854168
15:34:41 <zodbot> jreznik: Bug 854168 liveinst doesn't start in KDE booted from USB - https://bugzilla.redhat.com/show_bug.cgi?id=854168
15:34:47 <jreznik> this one is strange
15:35:04 <jreznik> I don't know how it is related to kde but I rechecked it in Gnome and it works better
15:35:47 <jreznik> now it was triaged as parted issue because of my comment, not sure how relevant it is (testing on my old netbook, the only one with windows :D)
15:36:25 <Kevin_Kofler> Look at the backtrace.
15:36:29 <Kevin_Kofler> It crashes in libparted.
15:36:35 <Kevin_Kofler> I don't see how KDE has anything to do with it.
15:37:03 <rdieter> agreed
15:37:17 <jreznik> Kevin_Kofler: I don't understand it too... but for some reason it works on gnome spin
15:37:21 <Kevin_Kofler> /lib64/libc.so.6(+0x7c38e)[0x7f9c8ae5c38e]
15:37:22 <Kevin_Kofler> /lib64/libparted.so.2(+0x27c7a)[0x7f9c78a4fc7a]
15:37:23 <rdieter> in /lib64/libparted.so.2(ped_disk_new+0x58)[0x7f9c78a3a528]
15:37:24 <Kevin_Kofler> /lib64/libparted.so.2(ped_disk_new+0x58)[0x7f9c78a3a528]
15:37:25 <Kevin_Kofler> /usr/lib64/python2.7/site-packages/_pedmodule.so(_ped_Disk_init+0x66)[0x7f9c78c87b56]
15:37:54 <jreznik> that's why I'm completely confused... maybe two unrelated bugs, not sure...
15:38:04 <Kevin_Kofler> Memory corruption going on.
15:38:29 <Kevin_Kofler> "double free or corruption"
15:39:11 <Kevin_Kofler> Valgrind may or may not help. (There's Python involved.)
15:40:03 <tdfischer> I've gotta go for a bit, but my agenda item for ohio linux fest is just to see if anyone else is interested in meeting up, not really planning much of a fedora-kde event or anything intensive
15:40:13 * tdfischer &
15:40:41 <rdieter> tdfischer: ok, sorry we took so long, I guess we should've done that first
15:40:56 <jreznik> rdieter: we can, I think we are done with blockers
15:41:09 <rdieter> ok
15:41:12 <tdfischer> s'ok, I didn't plan on having to give a friend a ride to work
15:41:15 <rdieter> #topic ohio linux fest meet up
15:41:40 <rdieter> is half tempting for me personally, but that's still a heck of a drive
15:42:31 <rdieter> yeah, not practical, 13hours
15:43:12 <rdieter> need to bring that fedora transporter online
15:44:20 <rdieter> anyway, tdfischer said he'll be there, fedora/kde dudes are welcome to join the fun,
15:44:25 <Kevin_Kofler> It's way too far for me in any case. ;-(
15:44:32 <rdieter> http://ohiolinux.org/ , Sep 28-30
15:45:35 <rdieter> yeah, without a transporter or czech/autrian <--> ohio wormhole
15:46:20 <jreznik> wow, the wormhole would be awesome!
15:46:37 <rdieter> would be handy
15:46:53 <rdieter> #topic open dicussion
15:47:01 <rdieter> so anything else for today?
15:47:22 <jreznik> qt 5 beta?
15:47:54 <rdieter> oh yeah, that. it's available, for anyone wanting to jump in and start packaging work
15:48:10 <jreznik> alpha was not very ready
15:48:12 <Kevin_Kofler> For the record, Marble says the Columbus Convention Center is 7421.62 km from my home. ;-(
15:48:20 <jreznik> so probably time to recheck...
15:48:21 <rdieter> http://releases.qt-project.org/qt5.0/beta1/split_sources/
15:49:04 <jreznik> rdieter: that's the question - do we want to split it? is final going to be split only?
15:49:13 <Kevin_Kofler> It would be great to have Qt 5 and KF5 packages so I can work on porting my libplasma feature without compiling everything. ;-)
15:49:17 <rdieter> wish I hadn't already committed to working on x-bazillion things today
15:49:19 <jreznik> btw. there's old dbus in f17...
15:49:41 <Kevin_Kofler> We need a new D-Bus AGAIN? :-(
15:49:42 <jreznik> we need newer dbus
15:49:57 <Kevin_Kofler> Qt 4 all over again.
15:50:02 <rdieter> jreznik: I think splitting is the wisest course
15:50:24 <jreznik> #link https://bugs.freedesktop.org/show_bug.cgi?id=46147
15:50:31 * Kevin_Kofler doesn't like splitting.
15:50:33 <jreznik> but internal server error
15:50:55 <jreznik> Kevin_Kofler: once we do it for kde, and kf5 is going to be about splits...
15:51:24 <ltinkl> kf5 is miles away
15:52:23 <rdieter> anyway, it's there if someone wants to start work on it.
15:52:57 <rdieter> jreznik: I guess the dbus thing means we likely won't be able to provide f17 preview packages, eh?
15:53:30 <jreznik> rdieter: not without dbus update (in kde-sf?)
15:53:45 <rdieter> ok
15:53:54 <rdieter> we'll see
15:53:55 <Kevin_Kofler> Unfortunately, bugs.fd.o isn't responding right now, so I can't look at the issue.
15:54:09 <jreznik> my friend tried to compile it, thiago pointed him to the dbus bug, he pointed me to the conversation :D
15:54:10 <Kevin_Kofler> (Internal Server Error)
15:54:13 <jreznik> Kevin_Kofler: yep
15:54:34 <rdieter> depends on if it's just a backportable bugfix, or new api
15:54:54 <jreznik> indeed
15:55:04 <Kevin_Kofler> In principle everything is backportable. ;-p
15:55:29 <Kevin_Kofler> Now if I come and backport random stuff to dbus, the maintainer might kill me. ^^
15:55:29 <jreznik> :)))
15:55:47 <rdieter> we're about out of time, last chance to speak before i close meeting on a minute or 2
15:56:11 <ltinkl> Kevin_Kofler: your necrolog might read "killed by da bus"
15:57:02 <rdieter> thanks everyone
15:57:04 <rdieter> #endmeeting