15:00:18 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:00:18 <zodbot> Meeting started Tue Jul 30 15:00:18 2013 UTC. The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:23 <Kevin_Kofler> #meetingname kde-sig
15:00:23 <zodbot> The meeting name has been set to 'kde-sig'
15:00:41 <Kevin_Kofler> #topic Role call
15:00:49 <Kevin_Kofler> The usual: Who's present?
15:00:52 * nucleo here
15:00:53 <rdieter> here
15:01:50 <Kevin_Kofler> dvratil, jreznik, than: Ping? Meeting time!
15:01:53 <than> here
15:02:04 <dvratil> here
15:02:20 * ltinkl is here
15:02:23 * jreznik is around
15:02:42 <Kevin_Kofler> #chair nucleo rdieter than dvratil ltinkl jreznik
15:02:42 <zodbot> Current chairs: Kevin_Kofler dvratil jreznik ltinkl nucleo rdieter than
15:02:57 <Kevin_Kofler> #info Kevin_Kofler, nucleo, rdieter, than, dvratil, ltinkl, jreznik present.
15:03:03 <Kevin_Kofler> #topic Agenda
15:03:17 <Kevin_Kofler> So what's there to discuss? nucleo proposed Qt 4.8.5, which makes sense.
15:03:19 <Kevin_Kofler> Anything else?
15:03:41 <than> KDE-4.11 status
15:04:24 <than> postgress regession with qt-4.8.5
15:05:45 <Kevin_Kofler> #topic Qt 4.8.5
15:05:58 <Kevin_Kofler> Let's start with that, and the PostgreSQL regression is part of that IMHO.
15:05:59 <nucleo> maybe arm as primary
15:06:14 <Kevin_Kofler> nucleo: We can't really do anything about that, can we?
15:06:20 <nucleo> can't
15:06:23 <Kevin_Kofler> (It's been forced on us just as on everybody else.)
15:06:47 <rdieter> https://bugreports.qt-project.org/browse/QTBUG-30076
15:06:50 <Kevin_Kofler> That nonsense is going to make all our builds 3 to 1000 times slower. :-(
15:07:11 <rdieter> the qt-postgresql thing, "PostgreSQL driver inserts extra backslashes on PostgreSQL 9.1 and newer"
15:07:26 <dvratil> this regression breaks Akonadi with postgresql
15:07:37 <dvratil> we are not able to append \SEEN flag
15:07:59 <rdieter> should we just just revert commits to the postgresql driver?
15:08:24 <Kevin_Kofler> Indeed, I'd suggest just reverting the offending commit.
15:09:04 <than> +1 if we want to push qt-4.8.5
15:10:09 <rdieter> http://paste.fedoraproject.org/29025/96996137 is the one, I think
15:10:09 <than> dvratil: is it a bug in postgresQL?
15:10:23 <dvratil> they've changed behavior
15:11:08 <dvratil> Warning
15:11:09 <dvratil> This change can break applications that are not expecting it and do their own string escaping according to the old rules.
15:11:15 <dvratil> (from postgreq; changelog)
15:11:45 <rdieter> I can try reverting that commit to our qt packaging.
15:12:00 <Kevin_Kofler> Yes please.
15:12:06 <than> rdieter: great
15:12:08 <ltinkl> the question is, does it break the akonadi database?
15:12:18 <dvratil> but what commit? There was no change in Qt that would cause that
15:12:35 <dvratil> it's change in PostgreSQL behavior that just breaks Qt's SQL driver
15:12:46 <Kevin_Kofler> It's a change in Qt 4.8.5.
15:13:04 <rdieter> dvratil: this one I think, http://paste.fedoraproject.org/29025/96996137
15:13:12 <Kevin_Kofler> Supposedly made to accomodate a change in PostgreSQL, but the thing is, Akonadi works on F19 with 4.8.4 and not with 4.8.5.
15:13:37 <Kevin_Kofler> At least that's what users of Akonadi-PostgreSQL told us.
15:13:38 <rdieter> not sure how best to resolve this, long-term though
15:14:09 <Kevin_Kofler> %if 0%{?fedora} < first version with PostgreSQL ≥ 9.1
15:14:11 <Kevin_Kofler> apply patch
15:14:15 <Kevin_Kofler> %endif
15:14:16 <Kevin_Kofler> ?
15:14:20 <Kevin_Kofler> s/apply/revert/, sorry.
15:14:33 <rdieter> no need, the patch already only changes escaping when used against newer postgresql
15:14:37 <Kevin_Kofler> Not sure what the right way to treat 9.1+ is though.
15:14:46 <Kevin_Kofler> Well, then the patch is just broken. :-)
15:15:20 <rdieter> it's postgresql-9.1+ that changed escaping, this qt commit is supposedly just an adaptation to that change
15:16:13 <rdieter> as I understand things anyway.
15:16:16 <Kevin_Kofler> But it breaks more than it fixes, it seems.
15:16:20 <dvratil> from Akonadi POV, another possible fix is to modify our default DB config to switch the option back to OFF
15:16:50 <dvratil> (because the change is about enabling standard_conforming_strings option by default since 9.1
15:17:06 <dvratil> so if we explicitly disable it in Akonadi config, Akonadi should be happy
15:17:16 <dvratil> not sure about other apps though
15:18:16 <rdieter> imo, short-term anyway, I will revert the commit for < f20, since it is a regression/change-in-behavior of the postgrsql driver if we update qt-4.8.4 => qt-4.8.5
15:19:09 <rdieter> is that agreeable?
15:19:47 <than> rdieter: +1
15:20:09 <dvratil> oki
15:20:11 <rdieter> alternatively, we could just simply unconditionally revert the commit too
15:20:22 <Kevin_Kofler> Assuming what users told us is correct (that things work fine with 4.8.4), +1 to reverting the Qt commit.
15:20:59 <jreznik> +1 revert
15:21:53 * dvratil will try to write a correct patch for the driver
15:22:04 <dvratil> (no guarantees though)
15:22:07 <rdieter> ok
15:25:09 <Kevin_Kofler> #agreed revert the Qt commit for now
15:25:19 <Kevin_Kofler> #action dvratil will try to write a correct patch for the driver
15:25:48 <Kevin_Kofler> And I assume we agree to push Qt 4.8.5 to updates-testing as soon as that's resolved / worked around, right?
15:25:55 <rdieter> agreed
15:26:43 <Kevin_Kofler> Any objections, or can I file an #agreed for that too?
15:27:05 <than> no objection
15:27:32 <rdieter> did anyone have a preference whether to unconditionally revert, or just for < f20 ?
15:27:44 <Kevin_Kofler> #agreed push Qt 4.8.5 as soon as the PostgreSQL regression is resolved / worked around (by reverting the patch)
15:28:05 <Kevin_Kofler> I'd just do it unconditionally.
15:28:52 <rdieter> ok. (I can see arguments for both ways)
15:29:01 <than> yes revert it unconditionally before we have a correct fix in drive
15:30:28 * rdieter committed fix to qt.spec, building now
15:30:55 <Kevin_Kofler> #info rdieter committed a fix (unconditional reversion of the offending patch) to qt.spec, building now
15:31:04 <Kevin_Kofler> I think that's all for this one, let's move on.
15:31:13 <Kevin_Kofler> #topic KDE 4.11 status
15:32:54 <rdieter> 4.10.97 is mostly in rawhide now, except for new package splits
15:33:28 <rdieter> kdenetwork work-in-progress: http://rdieter.fedorapeople.org/rpms/kdenetwork/
15:33:53 <Kevin_Kofler> #info 4.10.97 is mostly in rawhide now, except for new package splits
15:33:59 <rdieter> still todo includes: kdeadmin, kdesdk, kdeutils I think
15:34:07 <Kevin_Kofler> #info kdenetwork work-in-progress
15:34:11 <Kevin_Kofler> #link http://rdieter.fedorapeople.org/rpms/kdenetwork/
15:34:37 <Kevin_Kofler> rdieter: I think you're right.
15:34:43 <Kevin_Kofler> #info still todo includes: kdeadmin, kdesdk, kdeutils
15:38:15 <Kevin_Kofler> The thing is, this is really a blocker for pushing 4.11 anywhere (except Rawhide).
15:38:31 <Kevin_Kofler> We're missing almost half of the SC now.
15:40:29 <than> isn't kdeutils a meta package?
15:41:01 <than> and it's already splitted in 4.10
15:41:20 <rdieter> oh, right, true
15:41:20 <Kevin_Kofler> Must be another one then… There were 4 modules split in 4.11.
15:41:53 <than> kdeadmin, kdesdk, kdenetwork
15:42:13 <than> and the last one?
15:42:13 <Kevin_Kofler> These ones sure, but that's 3, I know there are 4.
15:42:42 <nucleo> kdetoys
15:42:50 <Kevin_Kofler> nucleo: Thanks.
15:42:52 <Kevin_Kofler> #undo
15:42:52 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x1aab9250>
15:42:59 <Kevin_Kofler> #info still todo includes: kdeadmin, kdesdk, kdetoys
15:43:58 <than> rdieter: i will help to add the missing stuffs
15:44:47 <Kevin_Kofler> #action than will help adding the missing stuff
15:44:51 <than> i will start to work on this next week
15:45:06 <rdieter> thanks
15:45:07 <Kevin_Kofler> OK
15:45:14 <Kevin_Kofler> Thanks +1. :-)
15:45:15 <than> rdieter: np :)
15:45:33 <Kevin_Kofler> I think that's all about 4.11.
15:45:37 <Kevin_Kofler> #topic Open discussion
15:45:43 <Kevin_Kofler> Anything else to discuss?
15:46:03 <rdieter> fyi, f17 going eol today. rest in peace. :)
15:46:31 <jsmith> rdieter: :-)
15:47:13 * Kevin_Kofler upgraded to F18 last weekend (despite the extreme heat).
15:47:42 * rdieter worked with dgilmore yesterday to make sure we had the karma for f17 kde-4.10.5 to get pushed stable first
15:48:06 <Kevin_Kofler> Did it get actually pushed though? Last I checked it didn't. :-(
15:48:20 <dgilmore> Kevin_Kofler: push got killed overnight
15:48:31 <dgilmore> its been resumed and will go out soon
15:48:39 * rdieter yays
15:48:40 <Kevin_Kofler> dgilmore: OK, thanks for the update.
15:49:00 <dgilmore> logrotate restarts apache which will kill running pushes
15:50:07 <rdieter> naughty logrotate
15:50:49 <Kevin_Kofler> (For those non-Europeans in here, when I mean "extreme heat", I mean "above 100°F" kind of extreme. :-) )
15:52:19 <dgilmore> Kevin_Kofler: about 35c is getting hot
15:52:25 <dgilmore> above
15:52:39 <dgilmore> its only the US that uses F
15:53:21 <Kevin_Kofler> We had up to 38-39°C in most of Austria.
15:54:09 <Kevin_Kofler> Still over 30°C in the night when I was forced to the the Fedora upgrade due to impending EOL. But hey, I'm not complaining, it's not really feasible to support releases for ages when one releases every 6 months.
15:54:23 <Kevin_Kofler> s/to the the/to do the/
15:55:36 <Kevin_Kofler> When we're starting to talk about the weather, it's a sign that we're running out of discussion topics. :-) So…
15:55:41 <Kevin_Kofler> #endmeeting