15:14:33 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:14:33 <zodbot> Meeting started Tue Jan 14 15:14:33 2014 UTC. The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:14:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:14:37 <Kevin_Kofler> #meetingname kde-sig
15:14:37 <zodbot> The meeting name has been set to 'kde-sig'
15:14:45 <Kevin_Kofler> #topic Role call
15:14:50 <Kevin_Kofler> Who's present (other than myself)?
15:15:01 * jgrulich is present
15:15:16 <rdieter> here
15:15:21 <mbriza> present
15:16:48 <Kevin_Kofler> #chair jgrulich rdieter mbriza
15:16:48 <zodbot> Current chairs: Kevin_Kofler jgrulich mbriza rdieter
15:17:13 <Kevin_Kofler> dvratil, jreznik_, than: Ping?
15:17:19 <dvratil> heya
15:19:33 <Kevin_Kofler> #chair dvratil
15:19:33 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich mbriza rdieter
15:19:45 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, rdieter, mbriza, dvratil present.
15:19:49 <Kevin_Kofler> #topic Agenda
15:20:11 <Kevin_Kofler> So we haven't had any meeting for a long time now, surely there are things we should discuss.
15:20:27 <dvratil> Progress update: KF5 repo
15:20:30 <danofsatx> Sorry I'm late
15:20:50 <Kevin_Kofler> danofsatx: No problem, we're still discussing what to discuss. :-)
15:20:56 <danofsatx> I see that ;)
15:21:05 <Kevin_Kofler> F21 planning is probably also a thing to get started on.
15:22:47 <Kevin_Kofler> #topic KF5 repo progress update
15:22:50 <Kevin_Kofler> dvratil: Your turn!
15:23:26 <dvratil> We have all 4 tiers compiled, we have plasma-framework compiled and I'm just finishing build of plasma2
15:24:15 <dvratil> siddhart al;ready has some scripts to setup environment to look to /opt/kf5 first, so that one can really log into Plasma2 without having to "bootstrap" through regular desktop session
15:24:58 <dvratil> next step is that I want to make all the packages co-installable with KDE4, so that we can move from /opt/kf5 prefix to /usr
15:25:08 <Kevin_Kofler> OK
15:25:15 <Kevin_Kofler> According to upstream:
15:25:23 <Kevin_Kofler> * the workspaces are not expected to be coinstallable :-(
15:25:48 <dvratil> I know, I meant the frameworks only
15:25:50 <Kevin_Kofler> * for the libraries, there are library name conflicts being resolved for attica and polkit-qt-1
15:26:08 <dvratil> finally, ltinkl suggested that when this is done, and if it's done in time, we could propose KF5 to as a Feature for F21
15:26:21 <Kevin_Kofler> * and then executables like makekdewidgets etc. also still conflict (in some cases, in Fedora, they actually conflict with kdelibs3 rather than kdelibs because we already renamed the kdelibs 4 ones :-) )
15:26:34 <Kevin_Kofler> Upstream is working on fixing the conflicts in the frameworks.
15:26:46 <Kevin_Kofler> They probably welcome help though, as long as it's coordinated.
15:27:14 <Kevin_Kofler> KF5 as a F21 feature would be great.
15:27:15 <dvratil> I'd like to work with upstream to make the frameworks coinstallable by default, without distro patches. If that fails, we can always do mv makekdewidgets{,5}
15:27:55 <Kevin_Kofler> That'd rather need a CMake-file patch like in kdelibs 4, because you also need to tell CMake to look for the correct binaries, a mv is not enough.
15:28:05 <Kevin_Kofler> (See how I did it in kdelibs 4.)
15:28:22 <Kevin_Kofler> But really, it should be patched upstream, they already said they'll accept patches for that in KF5.
15:29:03 * jreznik_ is around, rereading backlog
15:29:48 * than is present
15:30:43 <dvratil> that's all from me I guess :) I'll send an email and write a blog once we have the entire KF5/Plasma2 stack ready for "public" use
15:31:02 <Kevin_Kofler> #action dvratil will send an email and write a blog once we have the entire KF5/Plasma2 stack ready for "public" use.
15:31:09 <Kevin_Kofler> Great!
15:31:14 <jreznik> for polkit-qt-1 we're upstream, so I expect mbriza or someone else from the team is taking care of it, right?
15:31:42 <jreznik> with delayed F21, it makes sense to have it as Change proposal even it would be pretty tight
15:31:50 <Kevin_Kofler> I only know the discussions that were cross-posted to kde-packager and release-team@kde.
15:32:11 <mbriza> well, not really, there were some preparation patches merged by drf but that's it
15:32:36 <rdieter> polkit-qt could probably be fixed similar to how attica/phonon was handled
15:33:05 * dvratil can help, already done some Qt4->5 porting
15:33:42 <mbriza> ah, they weren't? uhmm, where did i see it?
15:33:44 * jreznik is not a good upstream anymore
15:34:32 <rdieter> speaking of this stuff, I don't recall seeing any objections to the idea to move qt4 headers to /usr/include/qt4 (for f21+)
15:34:49 <rdieter> so will proably move forward with that soon
15:35:07 <rdieter> (If I had been smart, would've made that change prior to 4.12.1 import)
15:39:32 <Kevin_Kofler> #info Qt 4 headers are moving to /usr/include/qt4 in F21+.
15:39:41 <Kevin_Kofler> #topic F21 planning
15:39:51 <Kevin_Kofler> So that brings us to the next topic: planning for Fedora 21.
15:40:23 <Kevin_Kofler> One thing we already more or less agreed on #fedora-kde is that we want to target 4.13 for F21.
15:40:48 <dvratil> as I already mentioned, I want to have KF5 as a F21 Feature if I manage to make it coinstallable on time
15:41:16 <mbriza> so, as for me, i started working on sddm again... the authentication library currently is about 2.5k LoC and it started passing basic tests today so i'll be possibly able to push it somewhere by the end of the week
15:42:10 <Kevin_Kofler> #link http://techbase.kde.org/Schedules/KDE4/4.13_Release_Schedule
15:42:34 <than> 12 Wednesday, April 16, 2014: KDE SC 4.13 Release
15:43:12 <Kevin_Kofler> That's definitely before F21.
15:43:18 <Kevin_Kofler> Not sure if that schedule is accurate though.
15:43:22 <rdieter> mbriza: yay
15:43:58 <Kevin_Kofler> But I think it is, yes.
15:44:39 <than> i haven't found f21 schedule
15:44:42 <rdieter> Kevin_Kofler: yes, once a schedule is published on techbase, upstream is pretty good at following it
15:44:43 <Kevin_Kofler> With F21 not before August, 4.13 is definitely the way to go, maybe even 4.14 if they do such short cycles. But right now, 4.13 it is.
15:45:20 <Kevin_Kofler> rdieter: I was just surprised at the short cycle. I had read the July 8 date before, but that's already .3! .0 already in April, wow.
15:45:34 <than> Kevin_Kofler: 4.14 maybe as updated for f21
15:45:58 <Kevin_Kofler> So I think there are no objections to targeting 4.13 for F21, seeing the schedules.
15:46:08 <than> i don't see problem
15:46:56 <Kevin_Kofler> Nobody yelling. ;-) So:
15:46:58 <Kevin_Kofler> #agreed We will target 4.13 for F21.
15:47:18 <Kevin_Kofler> (For 4.14+, we'll see once they decide when or even whether ;-) to release it.)
15:48:30 <Kevin_Kofler> #action mbriza is working on the authentication library for SDDM.
15:49:05 <Kevin_Kofler> Other stuff for F21? Do we know already how we fit in the Fedora.Next inferno?
15:49:59 <Kevin_Kofler> I surely hope we can still release our spin, I wouldn't be surprised if we lost release-blocking status again though (bringing us back to the crappy second-class-citizen status we had until F12 or so). :-(
15:50:08 <rdieter> we should ping ltinkl when next we see him, he's on the workstation WG (no?)
15:50:19 <mbriza> he is
15:50:36 <Kevin_Kofler> (where they'd happily release F12 with broken sound in KDE, that was NOT fun, especially because it was a PITA to fix the mess in an update)
15:52:15 <Kevin_Kofler> The lack of a KDE Product is really unacceptable. :-(
15:52:49 <Kevin_Kofler> I don't see why established Spins weren't promoted to Products instead of inventing 3 new ones out of the blue.
15:53:07 <Kevin_Kofler> (and likewise, established SIGs to Workgroups)
15:53:52 <Kevin_Kofler> FESCo/FPB demeritocracy at work.
15:55:07 <Kevin_Kofler> #topic Open Discussion
15:55:23 <Kevin_Kofler> So I think we can't say any more about F21 with what we know now.
15:55:35 <Kevin_Kofler> Anything else to say?
15:55:45 <sgallagh> Kevin_Kofler: I'd personally like to see a Fedora KDE product as well.
15:55:46 <Kevin_Kofler> I can give one FYI:
15:56:22 <sgallagh> I was holding out hope that the "Workstation" product would manage to arrange things such that the original Freedesktop vision could actually occur there, but it looks like that won't really happen.
15:57:01 <Kevin_Kofler> #action Kevin_Kofler is pushing updates to qt3, qt (4) and qt5-qtbase for F19, F20 and Rawhide with a fixed CVE-2013-4549 fix (larger entity character limit, see QTBUG-35459).
15:57:17 <Kevin_Kofler> sgallagh: Just no way.
15:57:25 <Kevin_Kofler> GNOME and KDE really need separate spins/products.
15:57:43 <Kevin_Kofler> The GNOME folks don't want a shared spin, and to be honest, I don't think we really want that either.
15:57:44 <sgallagh> Kevin_Kofler: Please open a FESCo ticket for discussion at the meeting tomorrow
15:57:49 <sgallagh> (Agenda hasn't gone out yet)
15:57:56 <Kevin_Kofler> There are just too many practical issues.
15:58:11 <Kevin_Kofler> Starting from "duplicate" apps.
15:58:36 <Kevin_Kofler> Every desktop environment also has its own set of applications.
15:59:16 <Kevin_Kofler> They'd pollute each others menu, unless we start abusing OnlyShowIn/NotShowIn again, which then annoys those people who do want to use the other app for whatever reason.
15:59:46 <rdieter> I dont mind the menu pollution, as long as apps refrain from (ab)using GenericName
15:59:57 <Kevin_Kofler> For the record, I'm stronly opposed to Only/NotShowIn abuse.
16:00:02 <Kevin_Kofler> *strongly
16:00:27 <Kevin_Kofler> rdieter: Abusing Name for a generic name, you mean.
16:00:32 <Kevin_Kofler> And there I couldn't agree less.
16:00:48 <rdieter> Kevin_Kofler: yes
16:00:59 <Kevin_Kofler> I mean, I agree totally.
16:01:05 <rdieter> evince aka Document Viewer, for example
16:01:08 <sgallagh> +1
16:01:14 <Kevin_Kofler> (that "couldn't" expression is ambiguous)
16:02:12 <Kevin_Kofler> Generic names in Name= suck!
16:02:34 <Kevin_Kofler> Another problem is name conflicts like "System Settings".
16:02:47 <hhorak> Hi!
16:03:07 <Kevin_Kofler> (where the KDE one is the real "System Settings", the GNOME one is really gnome-control-center, but now calls itself "System Settings" in the menu)
16:03:15 <mmaslano> Kevin_Kofler: Hi, should we move to fedora-meeting-1 or are you almost finished?
16:03:24 <rdieter> Kevin_Kofler: ShowOnlyIn makes sense in that particular case
16:03:27 <Kevin_Kofler> I think we're basically done.
16:03:35 <rdieter> just ranting...
16:03:38 <Kevin_Kofler> Can we close the meeting?
16:03:40 <rdieter> let's wrap up
16:04:05 <Kevin_Kofler> OK, see you next week and let's vacate the chan! :-)
16:04:05 <Kevin_Kofler> #endmeeting