15:09:19 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:09:19 <zodbot> Meeting started Tue May 13 15:09:19 2014 UTC. The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:09:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:09:23 <Kevin_Kofler> #meetingname kde-sig
15:09:23 <zodbot> The meeting name has been set to 'kde-sig'
15:09:28 <Kevin_Kofler> #topic Role call
15:09:40 * rdieter waves
15:09:43 * pino|work mooes
15:09:58 <tosky> hi
15:10:08 * Kevin_Kofler is present, of course.
15:10:51 <than> present
15:12:55 <Kevin_Kofler> ltinkl: ping
15:13:03 <Kevin_Kofler> dvratil: ping
15:13:14 <dvratil> here
15:13:16 <dvratil> sorry :)
15:13:19 <Kevin_Kofler> mbriza: ping
15:14:45 <Kevin_Kofler> #chair rdieter pino|work tosky than dvratil
15:14:45 <zodbot> Current chairs: Kevin_Kofler dvratil pino|work rdieter than tosky
15:15:07 <Kevin_Kofler> #info rdieter, pino|work, tosky, Kevin_Kofler, than, dvratil present.
15:15:10 <Kevin_Kofler> #topic Agenda
15:15:28 <mbriza> hi, i'm present... sort of
15:15:33 <Kevin_Kofler> #chair mbriza
15:15:33 <zodbot> Current chairs: Kevin_Kofler dvratil mbriza pino|work rdieter than tosky
15:15:45 <Kevin_Kofler> #info mbriza sort of present. ;-)
15:15:51 <Kevin_Kofler> So, what to discuss today?
15:16:25 <mbriza> i cant attend meetings these few weeks, thesis due coming and then the exam
15:16:54 <rdieter> if nothing else, since f19/f20 lifetimes are extended, start discussion to consider another wave of kde-4.x+1 updates for each
15:17:09 <Kevin_Kofler> mbriza: Good luck!
15:17:33 <Kevin_Kofler> rdieter: Right.
15:17:52 <tosky> oh, also f19?
15:18:09 <Kevin_Kofler> For F19, it'd be a bit weird to do 4.12 now though, and going to 4.13 directly also…
15:18:26 <Kevin_Kofler> 4.11 is getting really old, of course.
15:18:28 <rdieter> f19 should be on the table for discussion at least, but f20 should probably take the focus
15:18:38 <rdieter> .bug 1090615
15:18:42 <zodbot> rdieter: Bug 1090615 kde-4.13 Tracking bug - https://bugzilla.redhat.com/1090615
15:18:47 <rdieter> current kde-4.13 blocker'y items
15:19:13 <rdieter> should probably file one about making sure nepomuk->baloo transition is smooth
15:19:39 <rdieter> (sorry, i guess we're still gathering agenda topics, didn't mean to actually start talking about it yet)
15:19:48 <Kevin_Kofler> Yeah.
15:20:10 <Kevin_Kofler> Should we put the GStreamer 1 migration up too, for an update?
15:20:17 <mbriza> thanks :)
15:21:20 <Kevin_Kofler> I guess we can start with 4.13. :-)
15:21:23 <Kevin_Kofler> #topic 4.13 status update
15:21:47 <Kevin_Kofler> #info There's a tracking bug for 4.13.
15:21:51 <Kevin_Kofler> #link https://bugzilla.redhat.com/1090615
15:22:12 <rdieter> only current blocker is plasma-mobile FTBFS against kde-4.13
15:22:22 <Kevin_Kofler> rdieter: Shouldn't the kcm_baloo_advanced or how it's called on that tracker too?
15:22:25 <rdieter> though we could just say we don't care
15:22:35 <Kevin_Kofler> *be on
15:22:44 <rdieter> Kevin_Kofler: right, per my prior comment about ensuring smooth transition from nepomuk
15:23:11 <Kevin_Kofler> IMHO, the poor configurability of Baloo out of the box is a clear regression.
15:23:17 <dvratil> I don't think upstream is going to care about plasma-mobile, so I would just drop it and say "abandoned upstream" (until Plasma.Next is out)
15:23:22 <rdieter> using the more traditional kcm_baloo_adv would easy the transition
15:23:27 <Kevin_Kofler> Even with the advanced KCM, it's still not perfect because there's no flag in the code to disable mail indexing if desired.
15:23:40 <Kevin_Kofler> But it's better than the poor default UI.
15:23:48 <rdieter> dvratil: <nod>, too bad since lots of stuff has support for "plasma active", now needs to be disabled basically
15:23:52 <Kevin_Kofler> dvratil: IMHO, we should try to at least make it BUILD.
15:24:15 <Kevin_Kofler> I don't care how well it runs, but it should compile and ideally not crash on startup. :-)
15:24:16 * danofsatx-work is late
15:24:19 <danofsatx-work> but I'm here
15:24:21 <rdieter> not that we ever cared much about -mobile, we didn't ship it by default
15:24:59 <rdieter> so if neither we nor upstream cares much for it, then the decision is pretty simple, imho
15:26:13 * rdieter repoqueries: plasma-mediacenter, startactive, okular-active , are the only items affected
15:26:20 <rdieter> besides plasma-mobile itself, of course
15:26:43 <Kevin_Kofler> I can have a look at getting it to compile, I can't really test it though.
15:27:30 <Kevin_Kofler> From the error, it seems to want some Nepomuk ontologies that are not shipped anymore by kactivities.
15:27:49 <danofsatx-work> on second thought, I'm not here - my ESX host is dead in the water, I need to go resuscitate it :(
15:27:57 <Kevin_Kofler> So either we patch the relevant stuff out from plasma-mobile, or we patch the kao.trig file in, or we ship some kactivities-compat or something.
15:28:10 <dvratil> Kevin_Kofler, so it's generally because plasma-mobile depends on Nepomuk?
15:28:28 <Kevin_Kofler> components/metadatamodel wants the kao.trig ontology.
15:29:15 <Kevin_Kofler> Anyway, this just shows how broken it was from upstream to make this Baloo change in 4.x.
15:29:23 <Kevin_Kofler> It's an incompatible change, it should have been done for KF5 only.
15:29:32 <Kevin_Kofler> That would have been the right time, and we're almost there anyway.
15:29:40 <Kevin_Kofler> It was totally stupid to rush this into 4.13 for no reason.
15:30:18 <Kevin_Kofler> I'd have understood if there WASN'T a major new version planned any time soon, but NOW? This is just retarded.
15:30:49 <rdieter> I welcome it, for better or worse. it actually works nice now
15:31:00 <rdieter> though, ideally the old api shouldn't have been broken either
15:31:37 <rdieter> but like I said, we can easily just say we don't really consider it a blocker
15:31:52 <Kevin_Kofler> And IMHO we can't.
15:32:05 <Kevin_Kofler> Breaking deps in released Fedora versions is a very bad idea.
15:32:09 <tosky> are there any statistics about the usage?
15:32:13 <rdieter> it doesn't break deps ,stictly
15:32:29 <rdieter> plasma-mobile builds exist, it's just all new builds fail
15:32:38 <Kevin_Kofler> Uhm, isn't there a review request for the new Baloo advanced KCM yet?!
15:32:43 <Kevin_Kofler> I can't find any on kde-reviews.
15:32:44 <rdieter> Kevin_Kofler: no
15:32:57 <Kevin_Kofler> rdieter: Can you please submit it? :-)
15:33:05 <Kevin_Kofler> You have it packaged, haven't you?
15:33:16 <rdieter> yes, in kde-unstable currently for testing/feedback
15:33:39 <rdieter> was hoping some upstream collaboration would happen
15:33:41 <Kevin_Kofler> Or should we do what I suggested and just patch it into baloo instead of the lame KCM?
15:33:58 <Kevin_Kofler> (IMHO, that's the best solution for our users.)
15:34:02 <rdieter> so you want to fork the fork?
15:34:43 <Kevin_Kofler> I think it'd be just minimal changes to what the fork ships.
15:34:55 <Kevin_Kofler> Basically, just diff original fork and then remove the renaming parts.
15:35:07 <Kevin_Kofler> (a bit of extra work to undo file renames, I guess)
15:35:12 <Kevin_Kofler> Should be scriptable.
15:35:27 <rdieter> I'm ok with hacking it into baloo pkg somehow
15:35:30 <rdieter> ok
15:35:45 <rdieter> but would rather ship the standard kcm too, just hide it
15:35:45 <Kevin_Kofler> That said, I need to check the code to see exactly what it'd entail.
15:36:11 <Kevin_Kofler> Of course, the "cleaner" solution would be to just package it separately.
15:36:23 <Kevin_Kofler> But in that case, we need a review request ASAP. :-)
15:36:30 <rdieter> ideally this is only a (very) temporary package
15:37:10 <Kevin_Kofler> I don't think it will be, though, unfortunately.
15:37:38 <Kevin_Kofler> vhanda is very set on his "design", for the kind of reasons GNOME developers usually give for "simplifying" their UI.
15:38:11 <rdieter> not sure where you got that from, my impression is that he's very open to feedback, especially in the form of code
15:38:22 <rdieter> (like what we have here)
15:38:45 <Kevin_Kofler> Haven't you seen his blog post where he explained his "improvements"?
15:38:51 <rdieter> I saw it
15:39:42 <rdieter> unfortunately, not many folks gave feedback during the design stages (ie, not many folks run pre-alpha stuff), so when the feedback came it was a bit too late
15:39:57 <Kevin_Kofler> And I pointed out very soon that we need those extra settings that are now in the advanced KCM, he only tried to explain away the need for those options.
15:40:16 <Kevin_Kofler> http://vhanda.in/blog/2014/04/desktop-search-configuration/
15:40:20 <rdieter> he only explained the reasoning behide the design, nothing more nothing less
15:40:24 <Kevin_Kofler> (the infamous blog post)
15:40:53 <Kevin_Kofler> (but he also told me "it's not needed" earlier on IRC when I complained)
15:40:59 <rdieter> whatever, do we really need to waste meeting time on this? :)
15:41:27 <Kevin_Kofler> At some point, he said he'd reconsider to make me stop complaining, but then a few days later posted that blog post.
15:41:52 <rdieter> fwiw, I also said having a whitelist is a very important pre-requisite
15:42:01 <Kevin_Kofler> Well, my point is that kcm_baloo_adv is probably going to be a long-term thing, not a short-term one.
15:42:15 <rdieter> you're welcome to that opinion, I do not share it
15:42:16 <Kevin_Kofler> rdieter: Right, and he tried to explain that away, too.
15:42:24 <Kevin_Kofler> (the whitelist thing)
15:42:38 <rdieter> but doesn't matter anyway all that much
15:42:55 <rdieter> we agree it's needed, and I think we can agree it should go in baloo packaging somewhere/somehow
15:43:01 <rdieter> the rest is just bike-shedding
15:43:25 <rdieter> (largely)
15:43:26 <Kevin_Kofler> Do we also agree that it's a blocker for 4.13? Because IMHO, it is.
15:43:29 <rdieter> I do
15:43:42 <rdieter> anyone else disagree or have an opinion otherwise?
15:45:08 <tosky> the advanced blocker kcm as blocker? I would say it's needed
15:46:04 <Kevin_Kofler> #agreed We will consider getting the advanced Baloo KCM packaged as a blocker for 4.13 (i.e. not ship 4.13 to stable releases of Fedora without that).
15:46:07 <rdieter> tosky: correct
15:46:16 <rdieter> (or rather, do *something* about it at least)
15:47:02 <rdieter> Kevin_Kofler: I'm still waffling whether to package it separately or munge into baloo
15:47:18 <Kevin_Kofler> I'm also somewhat torn on it.
15:47:35 <rdieter> consider me leaning toward separate for now, having mulled it over a few times already
15:47:41 <rdieter> I'll submit for review after meeting
15:47:57 <Kevin_Kofler> If you really want to ship both, then IMHO it's better to do it separately. Merging the packages only makes sense if we want to replace the bad KCM outright (as I propose).
15:48:10 <rdieter> makes sense
15:48:32 <Kevin_Kofler> (Then we could also use the .desktop file from the original for the advanced one, and "hacks" like that.)
15:49:44 <Kevin_Kofler> #agreed We will probably not block 4.13 on the plasma-mobile FTBFS because upstream is not actively supporting it at this time.
15:49:57 <Kevin_Kofler> #action Kevin_Kofler to look into getting plasma-mobile to compile.
15:50:12 <Kevin_Kofler> (Those are summing up what we said earlier, for the summary. :-) )
15:51:48 <Kevin_Kofler> Hmmm… http://plasma-active.org/ says they have Plasma Active 4 now, aren't we still stuck at version 2 (which is the "latest" according to the KDE wiki)?
15:52:15 <Kevin_Kofler> Or what version do we have packaged now?
15:52:28 <Kevin_Kofler> A major version upgrade might be required to fix our issues.
15:52:33 <Kevin_Kofler> Our packages are very old.
15:52:39 <Kevin_Kofler> Of course that ancient version is not maintained anymore.
15:53:34 <rdieter> i checked git repo , it was still broken
15:53:46 <rdieter> unless they moved where it's hosted
15:54:06 <Kevin_Kofler> That's "wonderful". :-/
15:54:21 <Kevin_Kofler> Also fun: There is no link to the tarballs anywhere that I can find.
15:54:41 <Kevin_Kofler> They only promote primarily their prebuilt images and secondarily the Kubuntu and openSUSE builds.
15:54:45 <rdieter> yeah, what's labeled as PA4, is actually a collection of stuff of varying versions themselves
15:54:49 <Kevin_Kofler> The tarballs are hidden somewhere.
15:55:04 <Kevin_Kofler> (if the packages don't build it straight from git to begin with)
15:55:16 <rdieter> ie, I think plasma-mobile-0.4 what we have corresponds with the latest
15:55:30 <Kevin_Kofler> 0.4 sounds like version 4 alright.
15:55:52 <Kevin_Kofler> So then we're up to date, if that's old, then they need to make a newer release.
15:55:53 <rdieter> http://download.kde.org/stable/active/4.0/src/
15:55:57 <rdieter> nvm, 0.5 is the latest
15:56:17 <rdieter> but pretty sure that is still broken in the same way
15:56:49 <Kevin_Kofler> I can look into fixing the build (especially if it's still broken in the latest upstream), but I'd rather that somebody actually interested in mobile stuff takes care of the version upgrade.
15:57:07 <rdieter> yup
15:57:53 * Kevin_Kofler looks at projects.kde.org git.
15:59:35 <Kevin_Kofler> There's indeed some Nepomuk stuff in there: https://projects.kde.org/projects/extragear/base/plasma-mobile/repository/revisions/master/show/components/metadatamodel/library and it hasn't been touched since 2013.
16:00:27 <Kevin_Kofler> Hmmm, wait, there's an active-development branch, let me see what, if anything, is in there. (It might be discontinued, who knows?)
16:01:03 <Kevin_Kofler> There's also a frameworks branch, which I assume is the KF5 port.
16:01:29 <Kevin_Kofler> active-development is dead indeed, last touched 2011.
16:01:37 <rdieter> silly me, I only looked in master/
16:02:06 <Kevin_Kofler> Even frameworks still has the Nepomuk stuff!
16:02:13 <Kevin_Kofler> WTF?!
16:03:22 <Kevin_Kofler> I guess just commenting out line 1 here: https://projects.kde.org/projects/extragear/base/plasma-mobile/repository/revisions/master/entry/components/CMakeLists.txt will make plasma-mobile build.
16:03:30 <Kevin_Kofler> (It drops the plugin that wants Nepomuk.)
16:03:46 <Kevin_Kofler> Whether it'd break something and what it'd break, I don't know.
16:04:13 <Kevin_Kofler> Might have to comment out some of the QML code, too.
16:06:18 <rdieter> I guess we should wrap the meeting up
16:06:56 <Kevin_Kofler> #topic Open discussion
16:07:01 <Kevin_Kofler> Anything else? Do we have any updates on GStreamer 1 stuff?
16:07:20 <Kevin_Kofler> My RFE to get kipi-plugins ported to QtGStreamer 1 got no response at all. :-(
16:07:34 <Kevin_Kofler> We may have to disable that VideoSlideshow plugin.
16:09:18 <rdieter> personally, haven't had any time to start working on any of it, but a huge thank you for documenting everything
16:09:25 <Kevin_Kofler> OK
16:09:31 <Kevin_Kofler> So, nothing else? Closing the meeting in 60 seconds.
16:10:45 <Kevin_Kofler> #endmeeting