15:11:26 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:11:26 <zodbot> Meeting started Tue Jan 20 15:11:26 2015 UTC. The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:11:31 <Kevin_Kofler> #meetingname kde-sig
15:11:31 <zodbot> The meeting name has been set to 'kde-sig'
15:11:35 <Kevin_Kofler> #topic Roll call
15:11:40 * Kevin_Kofler is present, who else?
15:12:08 <pino|work> o/
15:12:13 <jgrulich> hello
15:12:24 <rdieter> here (a little)
15:12:55 <heliocastro> o/
15:12:59 <donniezazen> hello
15:13:59 <tosky> hi
15:14:45 <Kevin_Kofler> jreznik: Ping? You want to discuss the change page, don't you? :-)
15:15:36 <Kevin_Kofler> than: Ping?
15:15:56 <Kevin_Kofler> #chair pino|work jgrulich rdieter heliocastro donniezazen tosky jreznik than
15:15:56 <zodbot> Current chairs: Kevin_Kofler donniezazen heliocastro jgrulich jreznik pino|work rdieter than tosky
15:16:05 * jreznik is here, sorry - scrollbar :)
15:16:12 <Kevin_Kofler> #topic Agenda
15:16:24 <Kevin_Kofler> We have the Plasma 5 change page to discuss, anything else?
15:16:29 <jreznik> change page
15:16:33 <Kevin_Kofler> If not, let's just dedicate the whole meeting to the change page.
15:16:51 * rdieter can give status update on kde-apps-4.12.1 for f20/f21
15:16:59 <rdieter> er, kde-apps-14.12.1
15:17:04 <Kevin_Kofler> We will definitely start with the change page, because that's the most urgent matter (the deadline is today).
15:17:23 <Kevin_Kofler> rdieter: OK
15:17:42 <Kevin_Kofler> #topic Plasma 5 Change page
15:17:56 <Kevin_Kofler> #link https://fedoraproject.org/wiki/Changes/Plasma_5
15:18:21 <Kevin_Kofler> #info The deadline for system-wide changes is today.
15:19:37 <Kevin_Kofler> (Self-contained ones will also be only accepted later if they're REALLY self-contained.)
15:19:43 <rdieter> looks good to me
15:21:43 <Kevin_Kofler> The change page says this: "Note that Plasma 5 only includes the actual shell, decorations, icons and a few applications coupled with workspace (e.g. KWin, System Settings, KSysGuard). It does not include "regular" applications like Dolphin, Okular, Konqueror, etc. which are part of KDE Applications product and released independently of Plasma 5." which is correct, but it does not say that we are also upgrading the
15:21:45 <Kevin_Kofler> applications where possible.
15:22:30 <rdieter> sure, but I'd argue that it out-of-scope (stictly speaking)
15:22:42 <rdieter> that said, mentioning it wouldn't hurt either
15:23:03 <than> present
15:23:07 <Kevin_Kofler> The page looks OK to be submitted, in any case.
15:23:58 <Kevin_Kofler> IMHO, let's move it to "ready for wrangler" as is.
15:24:04 <heliocastro> +1
15:24:20 <rdieter> +1
15:24:27 <jgrulich> +1
15:24:43 <than> +1
15:25:02 <tosky> +1 (for what my opinion is worth on this step :)
15:25:20 <Kevin_Kofler> OK, any objections to the proposal or can I file it as agreed?
15:26:14 <jgrulich> Kevin_Kofler: you probably want to just fix the link to info about you and add your email
15:27:09 <Kevin_Kofler> Fixing that right now.
15:29:29 <Kevin_Kofler> Fixed.
15:29:41 <Kevin_Kofler> #agreed The change page is ready for the wrangler.
15:29:46 <Kevin_Kofler> Should I change the category?
15:30:52 <jgrulich> yes, dvratil won't be able to do it
15:32:58 <Kevin_Kofler> Done.
15:33:01 <jreznik> thanks
15:33:14 <Kevin_Kofler> #info The change page was moved to Category:ChangeReadyForWrangler accordingly.
15:33:22 <jreznik> it looks good, maybe I'd stress a bit more it's doable withing F22 schedule but ok
15:33:29 <Kevin_Kofler> #topic Applications 14.12.1 status update
15:33:48 <Kevin_Kofler> rdieter: Your turn.
15:34:04 <rdieter> quick update, I'm working my way through the list of pkgs, I'd say about 2/3's done
15:34:15 <rdieter> there's one new pkg we need reviewed asap
15:34:39 <rdieter> .bug 1183235
15:34:41 <zodbot> rdieter: Bug 1183235 Review Request: kdeedu-data - Shared icons, artwork and data files for educational applications - https://bugzilla.redhat.com/1183235
15:34:54 <rdieter> it's a new dep for some kdeedu stuff, split out from libkdeedu
15:35:19 <rdieter> while on the topic,
15:35:22 <rdieter> .bug 1125952 -
15:35:24 <rdieter> .bug 1125952
15:35:24 <zodbot> rdieter: Bug 1125952 Review Request: artikulate - Improve your pronunciation by listening to native speakers - https://bugzilla.redhat.com/1125952 -
15:35:27 <zodbot> rdieter: Bug 1125952 Review Request: artikulate - Improve your pronunciation by listening to native speakers - https://bugzilla.redhat.com/1125952
15:35:36 <Kevin_Kofler> We still don't have that through review?!
15:35:58 <rdieter> a new one in kde-4.13, that has yet to be reviewed, in case someone is feeling extra charitable doing reviews
15:36:16 <rdieter> well, sorry, that one is blocking on me, sorry
15:36:23 <rdieter> have I mentioned I'm sorry?
15:36:40 * Kevin_Kofler checks the status.
15:37:16 <rdieter> rawhide I think will need a new 'kde-applications' metapackage, to provide a way to query/set what version of kde-applications is used
15:37:47 <rdieter> since the versioning is not consistent anymore. kdelibs/kdepimlibs/kdepim/kdepim-runtime are still 4.14.x, most others are 14.12.x
15:37:54 <danofsatx> sorry, still not used to new time.
15:37:56 <Kevin_Kofler> rdieter: Right, this is waiting for action from you, and also the review you agreed to swap with is still open. :-)
15:38:07 <rdieter> and there is no way to query that at runtime, afaict
15:38:15 <Kevin_Kofler> danofsatx: Technically, the meeting is at the old time, it's everyone ELSE who changed. :-p
15:38:18 <heliocastro> rdieter: Maybe we can do meta packages tied to kde meta packages ?
15:38:23 <rdieter> unlike kdelibs, kde4-config --version
15:38:31 <danofsatx> s/new time/my new time
15:38:39 <danofsatx> that better? ;)
15:39:02 <rdieter> heliocastro: can you give an example?
15:39:16 <heliocastro> We have frameworks
15:39:19 <heliocastro> extragear
15:39:27 <rdieter> my idea was to simply create an empty kde-applications pkg that provided a single %{kde_applications_version} macro
15:39:30 <heliocastro> kde-applications
15:39:51 <rdieter> ok, we do already have a 'kf5' pkg
15:39:53 <Kevin_Kofler> Another open question is, how do we deal with the KF5-based stuff? Should we try to push that to F21? F20?
15:40:13 <heliocastro> Create a pool for users ?
15:40:24 <rdieter> Kevin_Kofler: I'd argue no
15:40:40 <rdieter> for one reason: the kf5 stuff isn't ready (the packaging isn't)
15:40:54 <Kevin_Kofler> IMHO, if yes, we need to also push the plasma-oxygen SRPM (i.e. the Qt 5 Oxygen style) that I prepared AND drag it in through Requires.
15:41:11 <Kevin_Kofler> If no, we'll still want the Qt 5 Oxygen style, but dragging it in is less essential.
15:41:17 <rdieter> Kevin_Kofler: yes, plasma-oxygen needs to come to f20/f21
15:41:21 <Kevin_Kofler> (though it'd help third-party Qt 5 apps)
15:41:23 <rdieter> but that's a separate issue
15:41:29 <heliocastro> Creating a users pool It gives us some perception to how users wnat it or not, and at same time gives us some credibility that we are concerned on what fedora kde users want.
15:41:34 <Kevin_Kofler> There's a dependency there.
15:41:50 <Kevin_Kofler> If we push the KF5-based apps without having the styling right, users will yell at us, and rightfully so.
15:42:08 <rdieter> Kevin_Kofler: that's premature, as mentioned, they're not even in rawhide yet
15:42:09 <Kevin_Kofler> If we push them with the styling sorted out, they might not even notice. :-p
15:42:34 <Kevin_Kofler> (unless they use a non-Oxygen theme, like my Quarticurve :-( but I'm not going to consider that a blocker)
15:42:47 <rdieter> and there's some new kf5 packages included too, which I haven't looked at closely yet
15:43:17 * pino|work suggests https://qt.gitorious.org/qt/qtstyleplugins prettyplease
15:44:23 <rdieter> pino|work: another nice-to-have yes
15:44:25 <Kevin_Kofler> My recommendation would be to push an update to kde-workspace that requires the Qt 5 Oxygen style, at least if we are going to ship Qt 5 versions of KDE apps.
15:44:59 <pino|work> released at http://download.qt.io/community_releases/additional_qt_src_pkgs/ , and it might better to pull the latest commit to git (which fixes a FPE in clearlooks)
15:45:02 * rdieter doesn't like pushing qt5 unconditionally
15:45:12 <rdieter> but I suppose most/all f21 users have it already
15:45:50 <Kevin_Kofler> pino|work: Those are just resurrected versions of the styles that got deprecated by upstream Qt and dropped from the official Qt 5 distribution, aren't they?
15:45:59 <Kevin_Kofler> Still, I'm all for shipping classic styles!
15:46:37 <Kevin_Kofler> I can package it if you do the review.
15:46:43 <Kevin_Kofler> (Packaging is more fun than reviewing. :-p )
15:47:28 <pino|work> i'm not knowledgeable enough with rpm packaging to review rpm stuff
15:50:54 <rdieter> Anyway, that's all I've got, thought for transparency... I'd asked yesterday in #fedora-kde of kde-sig members were all ok with my working on kde-apps-14.12.1 updates for f20/f21
15:51:27 <Kevin_Kofler> As I said, I'm fine with it.
15:51:30 <rdieter> for f20, it arguably represents yet-another big-batch of updates that we had not done for previous releases
15:51:49 <Kevin_Kofler> l10n is going to suffer a bit though. :-(
15:51:55 <rdieter> so, here's another chance for anyone to raise comments, concerns, objections
15:52:13 <Kevin_Kofler> Because the new kde-l10n has the translations for all 14.12 stuff including the KF5 parts and you want to push only the KDE 4 ones.
15:52:20 <Kevin_Kofler> I don't know how to best handle this.
15:52:40 <rdieter> <nod> I hadn't seen any translations yet
15:52:40 <Kevin_Kofler> But then again the apps that are still KDE 4 probably did not have major changes, so the old translations should be good enough mostly.
15:53:37 <rdieter> problems *may* arise for the kf5 stuff
15:54:44 <rdieter> let's punt on kde-l10n-14.12.x for f20/f21 for now
15:55:04 <rdieter> until I get that imported into rawhide too, and we understand it a little better
15:55:13 <Kevin_Kofler> Shipping perfectly matched translations would require making a kde-l10n with both the 4.14 and 14.12 sources, replacing the directories from 4.14 with those from the kde4 subdirectories of 14.12 where the individual directory exists.
15:55:44 <Kevin_Kofler> (That's when only shipping the kde4 apps.)
15:55:46 <rdieter> I think some of the kf5 stuff may well be safe to ship
15:56:11 <Kevin_Kofler> Only if we actually ship the KF5 version of the app.
15:56:21 <rdieter> but a couple of very visible/installed-by-default ones, I'm not so sure
15:56:39 <rdieter> namely: konsole, kmix, gwenview
15:56:59 <Kevin_Kofler> When shipping all of 14.12, the kde-l10n packaging should be done entirely from 14.12 tarballs, but needs some updates to the packaging.
15:58:39 <Kevin_Kofler> #topic Open discussion
15:58:42 <Kevin_Kofler> Anything else?
15:59:51 <Kevin_Kofler> Looks like not. :-)
15:59:59 <Kevin_Kofler> So thank you all for coming, bye!
16:00:02 <Kevin_Kofler> #endmeeting