14:01:32 <asamalik_> #startmeeting modularity_wg
14:01:32 <zodbot> Meeting started Tue Jun 13 14:01:32 2017 UTC. The chair is asamalik_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:32 <zodbot> The meeting name has been set to 'modularity_wg'
14:01:58 <asamalik_> Hey everyone!
14:02:07 * ttomecek waves
14:02:07 <asamalik_> .hello asamalik
14:02:22 <zodbot> asamalik_: asamalik 'Adam Samalik' <asamalik@redhat.com>
14:02:27 <jkurik> .hello2
14:02:28 <zodbot> jkurik: Something blew up, please try again
14:02:41 <jkurik> .hello jkurik
14:02:42 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
14:03:38 <asamalik_> I'll be running the meeting today - never done it before, might be fighting with zodbot a bit :)
14:03:57 <asamalik_> #meetingtopic Meeting of the Modularity Working Group (once every two weeks)
14:04:10 <asamalik_> agenda: https://board.net/p/modularity-wg-agendas
14:05:07 <asamalik_> I see that there is nothing in the agenda - does anyone have anything to discuss?
14:05:31 <tflink> .hello tflink
14:05:32 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
14:05:54 <contyk> .hello psabata
14:05:55 <zodbot> contyk: psabata 'Petr Ĺ abata' <psabata@redhat.com>
14:05:59 <asamalik_> #topic Agenda
14:06:09 * jkurik has nothing for today
14:06:46 <ttomecek> contyk, are you guys planning any release notes/demos for Boltron release?
14:06:47 <asamalik_> #info [asamalik]: Boltron update
14:07:19 <asamalik_> #info asamalik: Boltron update
14:07:25 <contyk> ttomecek: haven't really thought of that; we have just content, no exciting features
14:07:44 <contyk> ttomecek: that's for the demos part; release notes might make sense
14:08:44 <ttomecek> contyk, I would love to see a demo of your complete pipeline (e.g. what you had to do in order to add iptables to BRT)
14:08:52 <asamalik_> anything for the agenda?
14:09:21 <ttomecek> but that's just my personal interest, don't take it as a request
14:09:44 <contyk> ttomecek: thanks for the input :)
14:09:57 <asamalik_> ok so let's start with my topic and then open floor
14:10:04 <asamalik_> #topic asamalik: Boltron update
14:10:40 <asamalik_> #link https://docs.pagure.org/modularity/ Modularity documentation page has a new Boltron section tracking the Boltron release
14:11:01 <asamalik_> we have been recently finishing and cleaning up stuff so it's ready for Boltron
14:11:36 <asamalik_> if you click on the link above, you can get to the Boltron page that lists the content we are about to ship and also shows the DNF prototype that everyone can try
14:12:35 <asamalik_> and over the next couple of weeks, we want to make a set of basic demos about Boltron - including a high level overview and some technical details as well
14:12:47 * asamalik_ should probably info stuff...
14:12:52 <asamalik_> any questions?
14:13:08 * contyk clicks
14:13:46 <contyk> ah, PERL
14:13:52 <asamalik_> #info There is a DNF modular prototype everyone can try - please use the link above.
14:13:59 <asamalik_> contyk: ah... so the auto rebuild is broken :/
14:14:13 <asamalik_> I'll take care of that.. or try :)
14:14:19 <contyk> also the names of the modules aren't very consistent, "dhcp-server" vs "DHCP Client" and such
14:14:42 <contyk> also, shouldn't this list include all the modules in the compose?
14:15:07 <asamalik_> contyk: right now, it includes the ones which work.. not all modules in the compose work :/
14:15:14 <asamalik_> so they will be added as we go
14:15:25 <asamalik_> at least that was the idea
14:15:28 <contyk> asamalik_: Base Runtime works, so does shim and dnf :)
14:15:39 <asamalik_> contyk: cool! so let's add it there
14:15:46 <contyk> asamalik_: installer is, it turns out, broken, but we're fixing that now
14:16:37 <asamalik_> contyk: do you want to give an update about that?
14:16:47 <contyk> nothing has really changed
14:16:56 <asamalik_> ok
14:16:57 <contyk> just the problems we're dealing with :)
14:17:02 <asamalik_> right :)
14:17:04 <contyk> but the end result is the same
14:17:17 <contyk> still can't build images in the infra
14:17:37 <tdawson> How does a person tell which module they are installing, if there are more than one listed in "dnf module list" ? (Or is a question like that diverting the meeting?)
14:17:58 <asamalik_> tdawson: right now it defaults to the newest version on the f26 stream
14:18:12 <asamalik_> tdawson: so "dnf install nodejs" will install nodejs-f26
14:18:22 <asamalik_> tdawson: you can also do "dnf install nodejs-8" to install the 8 stream
14:18:54 <tdawson> OK, makes sense.
14:19:05 <contyk> is there a way to force package context or module context?
14:19:21 <contyk> assuming it picks one and switches to the other if it cannot find the first
14:19:50 <asamalik_> contyk: what exactly do you mean by context? do you have a specific example?
14:20:11 <contyk> asamalik_: yes, yours -- you say "dnf install nodejs" installs a module named nodejs, not a package
14:20:39 <contyk> how do I choose to install nodejs package if there are both a module and a package available?
14:20:46 <asamalik_> contyk: ah, right... defaults to modules, probably tries package if there is no module
14:20:53 <asamalik_> contyk: that's something we are still working on
14:21:07 <contyk> ok
14:21:36 <ttomecek> there is a switch: --rpm
14:21:49 <asamalik_> it might turn out that we want to install modules with a prefix similar to groups... so @nodejs or something.. need to do some testing and get feedback
14:22:11 <asamalik_> ttomecek: good point! again, we need to do user testing before we call anything final
14:23:04 <asamalik_> anything else before we move to open floor?
14:23:11 <contyk> yes, I think the prefix would be better
14:23:19 <asamalik_> contyk: personally, me to...
14:23:29 <contyk> we talked about that like a year ago; I was proposing some emojis ;)
14:23:43 <ttomecek> so, how can we provide feedback?
14:23:44 <asamalik_> lol.. exactly, I remember that :)
14:24:21 <asamalik_> ttomecek: that's a good question... right now, there is the issue tracker in the DNF prototype repo... but that's not ideal
14:24:27 <asamalik_> we need to figure that out
14:24:47 <asamalik_> and I think that's coming out with Boltron definitely.. do we want to do it earlier? probably yes..
14:25:17 <asamalik_> ttomecek: do you want an AP to figure that out?
14:25:20 <asamalik_> or should I take it?
14:25:31 <tdawson> asamalik_: Side note ... good job with the docker image. It takes the module release from "what is that really" to "Oh, so that's how it would work." Very quick, easy, allows people to get their hands on it without much fuss.
14:26:10 <asamalik_> tdawson: good to hear! you should thank geppetto who made the image
14:26:27 <tdawson> Will do
14:27:06 <asamalik_> let me take the action then...
14:27:19 <asamalik_> #action asamalik will figure out how we get feedback to the DNF prototype
14:27:27 <asamalik_> did zodbot get that?
14:28:03 <ttomecek> asamalik_, I would actually love if dnf team figured that out ;)
14:28:23 <ttomecek> (since it's feedback to their UX)
14:28:52 <asamalik_> ttomecek: well, kind of... :)
14:29:22 <asamalik_> we are still defining it.. they just implement it
14:29:38 <asamalik_> ok.. anything else? open floor?
14:30:16 <asamalik_> #topic open floor
14:30:29 <ttomecek> asamalik_, okay, let's not talk about that further now :D anyway, thanks for picking up the AP, I hope it should be just enough to create a card for it and plan it for next sprint
14:30:33 <asamalik_> do we have anything more to discuss?
14:31:21 <contyk> guess not
14:31:24 <asamalik_> if not, I'll do 3 2 1 as nils always does before I end this meeting
14:31:26 <asamalik_> 3
14:31:38 <asamalik_> aaaand 2
14:31:43 <contyk> 1
14:31:47 <asamalik_> #endmeeting