09:16:34 <Shu6h3ndu_> #startmeeting check-in_20170106
09:16:34 <zodbot> Meeting started Fri Jan  6 09:16:34 2017 UTC.  The chair is Shu6h3ndu_. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:16:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:16:34 <zodbot> The meeting name has been set to 'check-in_20170106'
09:16:45 <Shu6h3ndu_> #topic anmol's updates
09:16:48 <anmol> Note: I was on leave for second half yesterday owing to my bad health(unbearable head-ache).
09:16:49 <anmol> Summary:
09:16:49 <anmol> Updates:
09:16:49 <anmol> [1] Updated https://github.com/Tendrl/performance_monitoring/pull/2 and https://github.com/Tendrl/alerting/pull/15 with travis fixes
09:16:49 <anmol> [2] Setup vms for UI testing and its installed with monitoring pieces and are running as expected.
09:16:50 <anmol> Request anup to setup tendrl api with required PRs/local code if any required for testing monitoring related apis on it.
09:16:53 <anmol> Note: There were issues in vm infra which took a considerable time off me.
09:16:55 <anmol> I hope the UI team is not blocked as such by the availability of this setup as its only that they want to check the UI with live monitoring data using this setup instead of the mock data.
09:16:58 <anmol> Please correct me if I am wrong.
09:17:00 <anmol> [3] Rebasing https://github.com/Tendrl/node_agent/pull/67 to allow gluster-integration in its latest form to function.
09:17:03 <anmol> This is because my PR on node-agent relies on older common while gluster-integration relies on latest common.
09:17:06 <anmol> [4] Reviewed https://github.com/Tendrl/specifications/pull/94 and requested inputs from @Tendrl/tendrl-core
09:17:09 <anmol> I would like to request @Tendrl/tendrl-core to kindly review the following PRs:
09:17:13 <anmol> * https://github.com/Tendrl/alerting/pull/15
09:17:15 <anmol> * https://github.com/Tendrl/specifications/pull/81
09:17:17 <anmol> * https://github.com/Tendrl/specifications/pull/63
09:17:19 <anmol> * https://github.com/Tendrl/node_agent/pull/67
09:17:21 <anmol> * https://github.com/Tendrl/performance_monitoring/pull/2
09:17:23 <anmol> so that while I rebase the implementation PRs in the above list, I can incorporate the comments on them and test everything together.
09:17:25 <Shu6h3ndu_> #accept anmol updated  https://github.com/Tendrl/performance_monitoring/pull/2 and https://github.com/Tendrl/alerting/pull/15 with travis fixes
09:17:26 <anmol> Just that it accelerates the whole process atleast to a considerable extent.
09:17:28 <anmol> Please find the details about the above @ https://paste.fedoraproject.org/520597/36905781/
09:17:54 <Shu6h3ndu_> #accept anmol working on setup for UI team with monitoring and alerting enabled
09:18:24 <Shu6h3ndu_> #action anup to setup tendrl-api on the server node
09:19:02 <Shu6h3ndu_> #accept anmol working on  rebase for https://github.com/Tendrl/node_agent/pull/67
09:19:47 <Shu6h3ndu_> #action nishanth Shu6h3ndu_ brainfunked k4n0 to review  https://github.com/Tendrl/alerting/pull/15  https://github.com/Tendrl/specifications/pull/81  https://github.com/Tendrl/specifications/pull/63 https://github.com/Tendrl/node_agent/pull/67 https://github.com/Tendrl/performance_monitoring/pull/2
09:19:53 <Shu6h3ndu_> anmol, looks fine?
09:20:12 <anmol> Shu6h3ndu_, yes
09:20:14 <nishanth> anmol, ping
09:20:14 <zodbot> nishanth: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
09:20:22 <anmol> nishanth, pong
09:20:30 <Shu6h3ndu_> #topic dahorak's updates
09:20:44 <nishanth> anmol, did you brokedown the patches into smaller ones?
09:20:47 <dahorak> Mainly working on unrelated tasks.
09:20:59 <dahorak> In the meantime reading/checking some specifications (mainly related to HW inventory).
09:21:16 <Shu6h3ndu_> #accept dahorak working on un-related task
09:21:20 <anmol> nishanth, not yet I'll do it right away if that is blocking the reviews
09:21:28 <Shu6h3ndu_> #accept dahorak reviewing few spec PRs
09:21:42 <Shu6h3ndu_> #topic fbalak's updates
09:21:46 <fbalak> Issue: https://github.com/Tendrl/usmqe-setup/pull/21 - add tendrl-alerting ansible role
09:21:48 <fbalak> Status: good
09:21:50 <nishanth> anmol, please do that if you can, that help to expedite
09:21:58 <anmol> nishanth, sure
09:22:31 <Shu6h3ndu_> #accept  dahorak reviewing few spec PRs
09:22:42 <Shu6h3ndu_> #undo  dahorak reviewing few spec PRs
09:22:42 <zodbot> Removing item from minutes: ACCEPTED by Shu6h3ndu_ at 09:22:31 : dahorak reviewing few spec PRs
09:22:51 <Shu6h3ndu_> #accept fbalak reviewing few spec PRs
09:23:07 <Shu6h3ndu_> #accept fbalak working on  https://github.com/Tendrl/usmqe-setup/pull/21
09:23:28 <Shu6h3ndu_> #topic gowtham's updates
09:23:41 <gowtham> Adding disk details in hardware inventory
09:24:02 <gowtham> spec file: https://github.com/Tendrl/specifications/pull/21 -merged successfully
09:24:28 <gowtham> code-PR: https://github.com/Tendrl/node_agent/pull/64 - all conflict are re solved , need review
09:24:39 <gowtham> Adding Network details in hardware inventory
09:24:51 <Shu6h3ndu_> #accept https://github.com/Tendrl/specifications/pull/21  merged
09:25:09 <Shu6h3ndu_> gowtham, who is pending to review https://github.com/Tendrl/node_agent/pull/64?
09:25:26 <gowtham> spc file: https://github.com/Tendrl/specifications/pull/19 , k4n0  approved , need to approve from nishanth and mrugesh
09:25:51 <gowtham> code-PR: https://github.com/Tendrl/node_agent/pull/79 - all conflict are re solved , need review
09:25:56 <Shu6h3ndu_> #accept  https://github.com/Tendrl/specifications/pull/19 approved by k4n0
09:26:09 <Shu6h3ndu_> #action nishanth brainfunked to review  https://github.com/Tendrl/specifications/pull/19
09:26:22 <gowtham> logging implementation
09:26:49 <Shu6h3ndu_> #action k4n0 to review  https://github.com/Tendrl/node_agent/pull/64 -
09:27:14 <gowtham> https://github.com/Tendrl/specifications/pull/94 - need review and anmol raised some discussion for this , need others suggestion for this
09:27:25 <gowtham> status
09:27:30 <gowtham> status : good
09:27:50 <Shu6h3ndu_> #accept anmol has some comments on https://github.com/Tendrl/specifications/pull/94
09:28:07 <gowtham> not blocked but waiting for logging implementation review
09:28:07 <Shu6h3ndu_> #action Shu6h3ndu_ nishanth k4n0 brainfunked to comment on https://github.com/Tendrl/specifications/pull/94
09:28:40 <Shu6h3ndu_> k4n0, can we go ahead with your updates now or later?
09:29:03 <k4n0> I havent written any code since I am back, reviews is all i have done
09:29:14 <Shu6h3ndu_> k4n0, ok
09:29:24 <Shu6h3ndu_> #topic k4n0's updates
09:29:36 <Shu6h3ndu_> #accept k4n0 mostly reviewing PRs and merging
09:29:46 <Shu6h3ndu_> #topic kaverma's updates
09:29:49 <kaverma> title- import cluster workflow
09:29:49 <kaverma> Spec-PR - https://github.com/Tendrl/specifications/pull/105 (under review .got reviewed by anup only.. i need review by nishanth, shubhendu and mrugesh as well )
09:29:49 <kaverma> Spec-issue - https://github.com/Tendrl/specifications/issues/56
09:29:49 <kaverma> github-issue - https://github.com/Tendrl/tendrl_frontend/issues/63
09:29:49 <kaverma> Progress - waiting for additional api response format for GetNodeList to support for import cluster
09:29:50 <kaverma> Status: Blocked.
09:30:16 <Shu6h3ndu_> #action Shu6h3ndu_ nishanth brainfunked to review  https://github.com/Tendrl/specifications/pull/105
09:30:47 <Shu6h3ndu_> #accept kaverma blocked for inputs of import cluster flow node list with additional cluster data
09:31:02 <Shu6h3ndu_> #action nishanth to provide additional data to kaverma
09:31:15 <Shu6h3ndu_> #topic mbukatov's updates
09:31:30 <mbukatov> #info scheduled quick packaging meeting over bluejeans
09:31:39 <mbukatov> #info closed requirement.txt issues (based on talk with Rohan during mtg)
09:31:44 <mbukatov> #link https://github.com/Tendrl/alerting/issues/18
09:31:52 <mbukatov> #info filed issue related to gluster glossary documentation
09:31:59 <mbukatov> #link https://github.com/gluster/glusterdocs/issues/194
09:32:06 <mbukatov> #action mbukatov file new issue and pull request for tox.ini changes
09:32:10 <Shu6h3ndu_> #accept mbukatov discussed and closed  requirement.txt issues
09:32:23 <mbukatov> #info sent webstr change to review to unblock ltrilety (not public, opensourcing in progress)
09:32:29 <Shu6h3ndu_> #info mbukatov filed issue related to gluster glossary documentation
09:32:48 <Shu6h3ndu_> #action mbukatov file new issue and pull request for tox.ini changes
09:33:11 <Shu6h3ndu_> #topic mkudlej's updates
09:33:34 <Shu6h3ndu_> #accept mbukatov sent webstr change to review to unblock ltrilety (not public, opensourcing in progress)
09:33:42 <mkudlej> still working on https://github.com/Tendrl/usmqe-tests/issues/9
09:33:55 <mkudlej> and other Tendrl unrelated work
09:33:55 <Shu6h3ndu_> #accept mkudlej working on  https://github.com/Tendrl/usmqe-tests/issues/9
09:34:19 <Shu6h3ndu_> #accept mkudlej working on other tendrl un-related work
09:34:29 <Shu6h3ndu_> #topic ndarshan's updates
09:34:29 <mkudlej> also I would like to ask about progress on blockers: https://github.com/Tendrl/tendrl-api/issues/31 https://github.com/Tendrl/tendrl_frontend/issues/79
09:34:40 <mkudlej> and also https://github.com/Tendrl/tendrl-api/issues/24
09:35:06 <mkudlej> Shu6h3ndu_: even if there will be new packages we will not be able to test becuase of these blockers
09:36:01 <Shu6h3ndu_> #accept blockers  https://github.com/Tendrl/tendrl-api/issues/31 https://github.com/Tendrl/tendrl_frontend/issues/79 https://github.com/Tendrl/tendrl-api/issues/24 to be checked and prioritized
09:36:08 <ndarshan> Spec:
09:36:08 <ndarshan> Introduce Flows tied to objects (https://github.com/Tendrl/specifications/issues/34)
09:36:08 <ndarshan> Issues:
09:36:08 <ndarshan> https://github.com/Tendrl/ceph_integration/issues/66
09:36:09 <ndarshan> https://github.com/Tendrl/gluster_integration/issues/95
09:36:09 <ndarshan> https://github.com/Tendrl/common/issues/94
09:36:13 <ndarshan> PRs:
09:36:15 <ndarshan> https://github.com/Tendrl/gluster_integration/pull/96
09:36:17 <ndarshan> https://github.com/Tendrl/ceph_integration/pull/67
09:36:19 <ndarshan> https://github.com/Tendrl/common/pull/95
09:36:21 <ndarshan> Summary:
09:36:23 <ndarshan> All patches wrt to the above spec are and awaiting review.
09:36:25 <ndarshan> Anup and rohan to review the changes,
09:36:27 <ndarshan> API layer may need some changes
09:36:53 <Shu6h3ndu_> #accept ndarshan working on https://github.com/Tendrl/ceph_integration/issues/66 https://github.com/Tendrl/gluster_integration/issues/95 https://github.com/Tendrl/common/issues/94
09:37:36 <Shu6h3ndu_> #action k4n0 anup to review https://github.com/Tendrl/gluster_integration/pull/96 https://github.com/Tendrl/ceph_integration/pull/67 https://github.com/Tendrl/common/pull/95
09:38:05 <Shu6h3ndu_> #action anup to review the PRs for api related changes and impact
09:38:30 <Shu6h3ndu_> ndarshan, looks good?
09:39:21 <Shu6h3ndu_> #topic k4n0's updates
09:40:36 <ndarshan> Shu6h3ndu_, yes
09:40:45 <k4n0> I just gave my update above
09:40:51 <Shu6h3ndu_> #undo
09:40:51 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x4b2d2290>
09:41:17 <Shu6h3ndu_> k4n0 and nishanth in some meeting. we will continue
09:41:22 <Shu6h3ndu_> #topic Shu6h3ndu_'s updates
09:41:50 <Shu6h3ndu_> #accept k4n0 merged https://github.com/Tendrl/common/pull/71 https://github.com/Tendrl/node_agent/pull/84 https://github.com/Tendrl/gluster_integration/pull/94 https://github.com/Tendrl/gluster_integration/pull/79 https://github.com/Tendrl/ceph_integration/pull/63
09:42:13 <Shu6h3ndu_> #accept Shu6h3ndu_ working on review comments for https://github.com/Tendrl/gluster_integration/pull/62
09:42:39 <Shu6h3ndu_> #accept Shu6h3ndu_ pushed code change PRs for https://github.com/Tendrl/specifications/pull/104 yesterday. review under progress
09:42:56 <Shu6h3ndu_> #action nishanth k4n0 to review https://github.com/Tendrl/specifications/pull/104
09:43:12 <Shu6h3ndu_> #action brainfunked to review and close https://github.com/Tendrl/specifications/pull/98
09:43:29 <Shu6h3ndu_> #action nishanth k4n0 anup to review https://github.com/Tendrl/specifications/pull/93
09:44:00 <Shu6h3ndu_> I am not blocked and working on different review comments and reworks
09:44:12 <Shu6h3ndu_> thats all from me
09:45:15 <Shu6h3ndu_> #info looks like QE team wont able to continue testing even if new packages available due to blockers https://github.com/Tendrl/tendrl-api/issues/31 https://github.com/Tendrl/tendrl_frontend/issues/79 https://github.com/Tendrl/tendrl-api/issues/24
09:45:28 <Shu6h3ndu_> anything else we left out?
09:46:11 <Shu6h3ndu_> ok. thanks everyone for joining
09:46:16 <Shu6h3ndu_> #endmeeting