09:14:46 <brainfunked> #startmeeting check-in_20170120
09:14:47 <zodbot> Meeting started Fri Jan 20 09:14:46 2017 UTC.  The chair is brainfunked. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:14:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:14:47 <zodbot> The meeting name has been set to 'check-in_20170120'
09:15:02 <brainfunked> #topic build status
09:15:16 <brainfunked> k4n0, what's the status on the framework changes we'd discussed yesterday evening?
09:15:53 <k4n0> brainfunked, checkpoints?
09:16:03 <brainfunked> k4n0, ?
09:16:22 <k4n0> brainfunked, are you asking about namespaces?
09:16:27 <brainfunked> k4n0, namespacing, definitions, commons etc.
09:17:07 <k4n0> brainfunked, namespacing basics is done, we are in progress with converting all objects via this way
09:17:48 <brainfunked> are ndarshan, nishanth, Shu6h3ndu and anmol all in sync with the changes?
09:17:53 <k4n0> brainfunked, I have not been able to get all your definition ideas adopted to our definitions schema, but the ones required for import are adopted to Tendrl Definitions Schema,
09:18:12 <brainfunked> k4n0, the idea is for those changes to be brought in piece by piece as we develop features
09:18:21 <k4n0> brainfunked, ack
09:18:21 <brainfunked> bring in the changes required for a particular feature only
09:18:54 <k4n0> brainfunked, Commons: there will be additions to commons which will be common namespacing code which already exists in Node agent
09:19:32 <k4n0> Not sure if nishanth Shu6h3ndu are completely up to date, but I did respond to Shu6h3ndu's comments on the namespacing PR
09:19:55 <brainfunked> they'll probably be able to sync up once done with the training today
09:20:12 <k4n0> brainfunked, yea
09:20:13 <brainfunked> k4n0, so what's the exact status on the changes and what still needs to be done?
09:20:55 <k4n0> brainfunked, namespaces needs to be tested for all repos with all objects in those repose
09:21:19 <k4n0> brainfunked, once above is green, we test the generic importcluster flow via the node-agent
09:21:40 <brainfunked> ok, so the changes are complete or still being made?
09:21:45 <k4n0> brainfunked, once that is green, we test the integration child flows which will be invoked by the generic flow
09:22:10 <k4n0> brainfunked, that along with the logging work gowtham has been working on
09:23:17 <k4n0> brainfunked, generic import cluster flow needs to be coded, its basically the current import cluster minus the hard coded integration details. The atoms in this flows are already in place, but as i said, namespaces need to be tested before anything
09:23:59 <brainfunked> k4n0, hold on, generic meaning the base ImportCluster flow that I'd suggested, which would lead to a system specific flow being invoked?
09:24:09 <k4n0> brainfunked, yep
09:24:39 <k4n0> brainfunked, we already have that flow implemented, but as of now it contains integration related details too, which are to be removed
09:24:50 <brainfunked> ok
09:25:08 <brainfunked> so do we have an ETA on the namespace changes being tested?
09:26:45 <k4n0> brainfunked, firstly, all Tendrl objects need to be adopted to the namespaces, ndarshan and me are working on the Node agent objects, will be done adopting those today, Shu6h3ndu and nishanth had to cover the integration objects (ceph, gluster), and anmol was to look at perf an alerting objects
09:26:58 <brainfunked> ack
09:27:31 <anmol> I am Incoporating changes as per https://github.com/Tendrl/node-agent/pull/147/ into https://github.com/Tendrl/performance-monitoring/pull/28 for config object and etcd_orm will try other changes only once this works(I started following the patch only today as I was on PTO yesterday so it took me some time). But looks like there is a new update on https://github.com/Tendrl/node-agent/pull/147/ need to follow it.
09:27:56 <brainfunked> anmol, thanks for the update
09:27:57 <k4n0> anmol, please raise questions on the PR as required
09:28:15 <k4n0> brainfunked, same for you
09:28:22 <anmol> and as discussed yesterday alerting is not a priority for us.. So, I am mainly looking into performance_monitoring related changes
09:28:40 <brainfunked> anmol, yeah, performance monitoring needs to be solid right now
09:28:56 <anmol> brainfunked, ack
09:28:58 <brainfunked> ndarshan, your status on the namespacing related stuff?
09:30:50 <brainfunked> k4n0, btw, logging related question
09:31:15 <k4n0> brainfunked, yes
09:31:23 <brainfunked> k4n0, it seems to me that it would useful to have the Message class and the eventing classes in commons to be used by all the modules
09:31:30 <brainfunked> there are two distinct requirements
09:31:48 <brainfunked> everyone other than the node agent should be able to log well formed messages to the message socket
09:32:07 <brainfunked> node agent then needs to take the messages to the approapriate output channel (etcd/syslog)
09:32:27 <brainfunked> the Message class will always be the same, before posting to the socket and after reading from the socket
09:32:54 <brainfunked> json structure from that class essentially serves as marshaling and unmarshaling
09:33:08 <brainfunked> the eventing class needs to be used by other components to log to the node agent sock
09:33:11 <brainfunked> socket*
09:33:29 <brainfunked> and the logger class will be used by the node agent to actually dump the messages in the appropriate location
09:33:36 <brainfunked> k4n0, gowtham, make sense?
09:33:48 <ndarshan> brainfunked, I have a PR (https://github.com/Tendrl/node-agent/pull/145)to fix the commons issues before the name-spacing patch(with this single node gluster import worked). Today morning I tried to apply my fix PR mentioned before, after pulling Rohans name-space changes resolved conflicts and now trying to run that. Ones it starts successfully will coordinate with rohan to pick up some objects in node_agent for adding to namespace
09:34:07 <gowtham> brainfunked, ya ok
09:34:09 <k4n0> brainfunked, It does, can we get this on the spec? I have implementation doubts
09:34:33 <brainfunked> Message and Logger class relates stuff I'd commented on the spec
09:34:45 <brainfunked> the event class not yet, I'll comment
09:35:01 <brainfunked> gowtham, if you've understood the point, you could update the spec with these details directly
09:35:26 <gowtham> brainfunked, ok sure
09:35:54 <k4n0> brainfunked, for local logs, lets stick to python logging framework, Its gonna take substantial time to get your comments implemented
09:35:59 <brainfunked> ndarshan, ack, I've been keeping an eye on that PR, and it looks fine, but once the commons changes `freeze', let's have a final sync on that PR before we merge it
09:36:16 <k4n0> brainfunked, for operationals and alerts/notifications, the socket makes sense
09:36:25 <brainfunked> k4n0, the logger class can be python standard, no problem
09:36:34 <brainfunked> k4n0, it already allows syslog output
09:36:49 <brainfunked> k4n0, the socket already exists thanks to the alerting code, we've just expanded it's scope
09:36:54 <k4n0> brainfunked, yes, I am just unsure of the integration time
09:37:01 <k4n0> *implementation
09:37:44 <brainfunked> k4n0, ok, let's do it this way, let's finish off the integration without these logging patches being merged right now
09:37:57 <brainfunked> ensure the stability of all the components first
09:38:15 <k4n0> brainfunked, ack
09:38:17 <brainfunked> that gives us a build without the properly formatted logs
09:38:28 <brainfunked> and on the side look to merge the logging changes
09:38:40 <brainfunked> the logging changes won't block any of the existing features being merged
09:38:55 <brainfunked> as it is, those need to be properly stabilised first
09:39:22 <brainfunked> and we need an instance up today
09:40:46 <k4n0> brainfunked, regarding the instance, youll need the instance with the namespaced objects?
09:40:55 <brainfunked> yes of course
09:41:07 <brainfunked> more than me, noopq needs one
09:41:31 <k4n0> brainfunked, thats not doable today looking at the current progress of all objects being namespaced
09:41:55 <k4n0> brainfunked, but the node-agent will be doable as i said
09:41:58 <noopq> k4n0, I need a instance with the latest changes, it could be anything from definitions to changing jobs log lookup path
09:42:28 <brainfunked> k4n0, can we get things merged to master one by one and start pushing the changes to the instance?
09:42:52 <brainfunked> k4n0, it also allows us to test the use case where we're ensuring that the node agent is able to push the changes properly
09:43:05 <k4n0> brainfunked, I am doing that for the node-agent, we cant have some node-agent objects inside a namespace and others without one
09:45:37 <k4n0> brainfunked, id suggest we ask gowtham to test out these node-agent changes parallely and report any issues?
09:46:03 <k4n0> brainfunked, while me and ndarshan ensure all node-agent objects are namespaced
09:56:07 <brainfunked> sorry, had to attend to a delivery
09:56:22 <brainfunked> works for me
09:56:31 <brainfunked> ndarshan, gowtham, works for you guys?
09:57:06 <ndarshan> brainfunked, okay
09:57:16 <gowtham> brainfunked, ok
09:57:23 <brainfunked> ok then
09:58:00 <brainfunked> #action k4n0 and ndarshan to complete the object namespacing changes, push them to the etcd instance and test things out
09:58:50 <brainfunked> #action gowtham to keep working on the logging specification https://github.com/Tendrl/specifications/pull/94/ to make the changes requested from the reviews and ensuer that they align with the commons changes
09:58:50 <k4n0> brb
09:58:59 <brainfunked> noopq, what's your status?
10:04:35 <noopq> brainfunked, I am going to finish the API doc today.
10:04:55 <noopq> and will start with Gowtham's changes from the spec for the task details
10:05:23 <noopq> brainfunked, Also I have asked neha to make some changes to the endpoint names as we had discussed earlier, she said she can do it today.
10:05:30 <brainfunked> great, the spec looks finalised in terms of the message structure and etcd schema etc.
10:05:42 <brainfunked> the implementation details for commons are being finalised, but that shouldn't block you
10:05:55 <brainfunked> ok
10:06:10 <brainfunked> #action noopq to finish the API documentation today
10:06:28 <noopq> brainfunked, Also I am verifying the previous API don't break, like create volume and pools
10:07:37 <brainfunked> #action noopq to sync up the API codebase based on the changes in the logging specification and provide the job updates API details so that the UI could implement support for them
10:08:04 <brainfunked> #action noopq working on ensuring that there are no regressions with APIs that had already been shipped
10:08:18 <brainfunked> neha, ankush, status?
10:09:28 <ankush> I have completed work for "Nested left navigation for tasks menu".
10:09:50 <ankush> Sent the patch for the same https://github.com/Tendrl/dashboard/pull/105
10:10:14 <neha> brainfunked, reviewed https://github.com/Tendrl/specifications/pull/125. working on https://github.com/Tendrl/dashboard/issues/101
10:10:23 <ankush> Waiting on neha and kamlesh review.
10:11:21 <brainfunked> neha, please provide the titles
10:11:46 <neha> Task Progress page for Import cluster functionality.
10:12:22 <neha> Also will start with the url changes of list and import clusters which noopq has suggested
10:13:06 <ankush> Also writing Pool features for BDD, will be completing it by today.
10:14:44 <brainfunked> ankush, can we get the BDD repos upstream today?
10:16:50 <ankush> brainfunked, yes we can. But we have to decide upon whether to put them inside frontend project or to create a separate repo for this.
10:18:46 <brainfunked> ok, let's take that discussion post the check-in
10:19:04 <ankush> brainfunked, ack
10:19:22 <brainfunked> #accept ankush has completed the nested left navigation for tasks, and has sent a pull request
10:19:42 <brainfunked> #action neha and kaverma to review ankush's left navigation for tasks PR https://github.com/Tendrl/dashboard/pull/105
10:22:02 <brainfunked> #action neha is working on the task progress page for import cluster https://github.com/Tendrl/dashboard/issues/101
10:22:10 <brainfunked> #topic testing updates
10:22:27 <brainfunked> fbalak, mkudlej, mbukatov, ltrilety updates please
10:23:03 <mbukatov> fbalak: go 1st, let's follow the alphabethical order
10:23:37 <fbalak> #action fbalak Working on https://github.com/Tendrl/usmqe-tests/issues/20
10:23:38 <fbalak> #action fbalak Blocked by https://github.com/Tendrl/gluster-integration/issues/108 and https://github.com/Tendrl/ceph-integration/issues/78 - with tendrl-common still listed as dependency for new packages, tendrl-commons can not be installed from packages.
10:24:50 <mkudlej> brainfunked: I work on tendrl unrelated tasks
10:25:05 <brainfunked> #info fbalak working on the import cluster test cases https://github.com/Tendrl/usmqe-tests/issues/20 and is blocked by unavailability of updated packages
10:25:26 <mkudlej> brainfunked: sorry, I should step out for while
10:25:29 <brainfunked> #info mkudlej is working on tasks not related to tendrl and has no updates
10:26:39 <mkudlej> brainfunked: are there new packages which we can test, please?
10:27:16 <brainfunked> mkudlej|afk, not yet, codebase changes are being integrated and tested before the packages are built
10:28:59 <mbukatov> #info mbukatov did review of pull request #23 of usmqe-setup, #27 of usmqe-tests
10:29:06 <mbukatov> #link https://github.com/Tendrl/usmqe-setup/pull/23
10:29:13 <ltrilety> I am working on https://github.com/Tendrl/usmqe-tests/issues/12, still waiting on packages
10:29:14 <mbukatov> #link https://github.com/Tendrl/usmqe-tests/pull/27
10:31:00 <brainfunked> #info ltrilety is working on the gluster import scenario tests https://github.com/Tendrl/usmqe-tests/issues/12, awaiting updated packages
10:31:11 <brainfunked> #info mbukatov has reviewed https://github.com/Tendrl/usmqe-setup/pull/23 https://github.com/Tendrl/usmqe-tests/pull/27
10:31:15 <brainfunked> alright, thanks for the updates
10:31:18 <brainfunked> #endmeeting