09:20:01 <brainfunked> #startmeeting check-in_20170207
09:20:01 <zodbot> Meeting started Tue Feb  7 09:20:01 2017 UTC.  The chair is brainfunked. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:20:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:20:01 <zodbot> The meeting name has been set to 'check-in_20170207'
09:20:59 <brainfunked> #info Jira issue ids are being listed. Please ensure that you go through the descriptions on those issues and raise any queries.
09:21:12 <brainfunked> #topic team updates
09:21:57 <brainfunked> #accept Shu6h3ndu has shared the structure of the CRUD flows and the RBD state data with noopq
09:22:16 <brainfunked> #action noopq is working on producing the API structure for the UI team based on the flows and structure shared by Shu6h3ndu
09:22:28 <noopq> brainfunked, I have suggested changes for Shu6h3ndu to convert RBD to Rbd everywhere
09:23:24 <brainfunked> #action Shu6h3ndu to go through jira issues TEN-6 and TEN-143. TEN-223 is for the current implementation cycle of the CRUD flows.
09:23:40 <brainfunked> Shu6h3ndu, do you wish to share any update?
09:24:08 <Shu6h3ndu> brainfunked, nothing much. working on ec profile crud stuff now
09:24:53 <brainfunked> Shu6h3ndu, rbd stuff finished?
09:29:32 <brainfunked> Shu6h3ndu, ping?
09:29:32 <zodbot> brainfunked: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
09:29:52 <noopq> nthomas, is Shu6h3ndu around?
09:30:20 <nthomas> noopq, I am WFH
09:33:21 <Shu6h3ndu> brainfunked, sorry I was talking to Neha
09:33:34 <Shu6h3ndu> I have sent a PR for rbd create/delete and resize yesterday
09:33:57 <brainfunked> #undo
09:33:57 <zodbot> Removing item from minutes: ACTION by brainfunked at 09:23:24 : Shu6h3ndu to go through jira issues TEN-6 and TEN-143. TEN-223 is for the current implementation cycle of the CRUD flows.
09:34:08 <noopq> Shu6h3ndu, can you answer my question?
09:34:37 <Shu6h3ndu> noopq, sure I would rename RBD with Rbd
09:34:55 <noopq> Shu6h3ndu, can you provide a instance when you are done?
09:35:11 <brainfunked> #action kaverma__, nehag, Shu6h3ndu and noopq to go through the UX designs and jira issues for the Create Pool (https://redhat.invisionapp.com/share/2T9LPMEEB, TEN-6, TEN-223) and Create RBD (https://redhat.invisionapp.com/share/EHAC6S0N4, TEN-143) flows and raise any queries
09:35:21 <Shu6h3ndu> noopq, sure. might take sometime but once done I would ping you
09:35:37 <brainfunked> Shu6h3ndu, could you link to the PR please?
09:35:47 <noopq> Shu6h3ndu, sure, the UI folks need to start, we we are counting on you :D
09:36:06 <Shu6h3ndu> brainfunked, https://github.com/Tendrl/ceph-integration/pull/107
09:36:21 <Shu6h3ndu> noopq, will finish faster :)
09:36:27 <brainfunked> #accept Shu6h3ndu has sent a PR for the RBD CRUD flows implementation https://github.com/Tendrl/ceph-integration/pull/107
09:36:29 <noopq> Awesome.
09:37:30 <brainfunked> Shu6h3ndu, could you also link to the pool pr?
09:37:58 <Shu6h3ndu> brainfunked, https://github.com/Tendrl/ceph-integration/pull/104 for pool
09:38:05 <brainfunked> Shu6h3ndu, any pr for the rbd listing?
09:38:26 <Shu6h3ndu> brainfunked,  https://github.com/Tendrl/ceph-integration/pull/107 has code to sync rbds as well
09:38:43 <brainfunked> ack, thanks
09:38:49 <brainfunked> #undo
09:38:49 <zodbot> Removing item from minutes: ACCEPTED by brainfunked at 09:36:27 : Shu6h3ndu has sent a PR for the RBD CRUD flows implementation https://github.com/Tendrl/ceph-integration/pull/107
09:39:54 <brainfunked> #accept Shu6h3ndu has sent PRs for: RBD CRUD flows (https://github.com/Tendrl/ceph-integration/pull/107), pool CRUD flows (https://github.com/Tendrl/ceph-integration/pull/104), RBD listing and state sync (https://github.com/Tendrl/ceph-integration/pull/107).
09:40:30 <brainfunked> #action nthomas to review the ceph crud flows and rbd state PRs: https://github.com/Tendrl/ceph-integration/pull/107 https://github.com/Tendrl/ceph-integration/pull/104
09:41:08 <brainfunked> noopq, any update on the authentication?
09:41:38 <noopq> brainfunked, not started like I said, was fixing the CreateVolume issue and since today morning working with the CRUD changes
09:42:07 <brainfunked> noopq, authentication and alerting configuration are tied and are both required next week, FYI
09:42:07 <noopq> I am hoping to start after I write the tests and publish the docs
09:42:20 <brainfunked> ack
09:42:37 <noopq> brainfunked, won't take long for authorization+authentication
09:44:30 <brainfunked> #action noopq to file a specification for AA. The jira issue TEN-231 was created by me earlier today, needs inputs from Jeff.
09:44:54 <brainfunked> ndarshan, status on gdeploy integration?
09:45:29 <ndarshan> updated the spec with some extra details as suggested by review comments: https://github.com/Tendrl/specifications/pull/129
09:45:29 <ndarshan> Sent Initial WIP code patch for wrapper: https://github.com/Tendrl/gluster-integration/pull/137 ---> I will be breaking this and moving code to respective components by moving general wrapper code into commons, atoms specific to gluster to gluster_integration and high level provisoning atoms to node_agent.
09:46:06 <brainfunked> ndarshan, no, don't move to commons, hold on on that part for now
09:46:31 <brainfunked> ndarshan, just get all the gdeploy stuff wrapped up in python modules that can be loaded and reused anywhere
09:46:55 <brainfunked> ndarshan, I'm working on getting the provisioning spec up today, which will impart clarity on where the wrapper code will go
09:47:07 <brainfunked> ndarshan, the common stuff will be part of the node agent directly
09:47:37 <brainfunked> ndarshan, also, the wrapper will contribute to both the integration and the provisioning namespaces
09:47:44 <brainfunked> the provisioning namespace is what I'm documenting
09:48:26 <ndarshan> brainfunked, okay. The basic wrapper and basic atoms are availabe as part of  https://github.com/Tendrl/gluster-integration/pull/137 . I pushed every thing to gluster_integration due to lack of clarity
09:48:47 <ndarshan> brainfunked, I will change once I see your spec
09:49:42 <brainfunked> ndarshan, the wrapper modules need to be standalone
09:50:02 <brainfunked> ndarshan, we'll need to push them a new repository, which maintains only the python modules for gdeploy integration
09:50:24 <brainfunked> thereafter, a provisioning wrapper in the node agent and the gluster integration codebase, both will load and use these modules as required
09:50:35 <brainfunked> I'll create a new repo right now
09:51:39 <ndarshan> brainfunked, okay.
09:52:25 <brainfunked> #accept ndarshan has sent updates to the gdeploy wrapper spec (https://github.com/Tendrl/specifications/issues/49) at https://github.com/Tendrl/specifications/pull/129 and https://github.com/Tendrl/gluster-integration/pull/137
09:52:44 <brainfunked> #action ndarshan to continue work on the gdeploy wrapper https://github.com/Tendrl/gluster-integration/pull/137
09:52:58 <brainfunked> #action brainfunked to create a new repository to host the gdeploy and ceph-installer wrapper modules
09:53:13 <brainfunked> nthomas, updates on ceph-installer?
09:53:55 <brainfunked> nthomas, nvm, see your pull requests on the issue
09:54:06 <nthomas> brainfunked, pushed the PRs for the same
09:54:07 <nthomas> ok
09:54:14 <nthomas> code PR WIP
09:54:22 <brainfunked> nthomas, as is the case with the gdeploy wrapper, the ceph-installer wrapper needs to be available as standalone python modules that can be loaded wherever required
09:54:34 <brainfunked> #undo
09:54:34 <zodbot> Removing item from minutes: ACTION by brainfunked at 09:52:58 : brainfunked to create a new repository to host the gdeploy and ceph-installer wrapper modules
09:54:45 <brainfunked> #action brainfunked to create a new repository to host the gdeploy wrapper modules
09:55:33 <brainfunked> #accept nthomas has sent updates to the ceph-installer wrapper spec (https://github.com/Tendrl/specifications/issues/48) at https://github.com/Tendrl/specifications/pull/132 https://github.com/Tendrl/node-agent/issues/202 https://github.com/Tendrl/ceph-integration/issues/106
09:55:42 <nthomas> yes, I am writing this as set of plugins, tomorrow, if something other than installer needs to supported
09:55:53 <brainfunked> nthomas, ack, great
09:56:53 <brainfunked> #action nthomas to continue working on the ceph-installer wrapper https://github.com/Tendrl/specifications/issues/48
09:58:01 <brainfunked> tim_, anmol what's the status on the monitoring build?
09:58:21 <anmol> brainfunked, we are still facing issues and are working on it
09:58:33 <brainfunked> any ETA?
09:58:39 <anmol> brainfunked, we are I think close to solution but not yet done
09:58:46 <brainfunked> ok
09:59:27 <brainfunked> #action tim_ and anmol are working on the monitoring builds. There have been some issues with the generated builds, but they're being fixed.
09:59:33 <brainfunked> #topic UI updates
09:59:55 <kaverma__> we went through the create pool/rbd UX mockup in morning and we came up with some doubt. i believe neha talked to shubhendu regarding this.
09:59:55 <kaverma__> Neha can give update on that . and apart from that i worked on conversion of directive to components - https://github.com/Tendrl/dashboard/pull/124 (got merged today)
10:00:55 <kaverma__> Neha^
10:00:59 <brainfunked> did you guys figure out the backend work required and how much time it'll take you to finish it?
10:01:38 <nehag> brainfunked, we have talked to Shu6h3ndu regarding the create pool and RBD flow...and we now know what things we need from API for this functionality
10:01:39 <kaverma__> neha word with shubhendu .. she can update on that ...
10:02:35 <brainfunked> nehag, make sure you document everything on a spec so noopq can be involved as well
10:02:39 <nehag> we will create spec for both flows and will comment there itself
10:02:45 <nehag> yes
10:03:45 <brainfunked> are you guys absolutely clear on the UX designs?
10:03:56 <anbehl> brainfunked, yes
10:04:20 <brainfunked> ok
10:04:21 <nehag> brainfunked, we need a latest setup to test the UI as the setup shared by nthomas does not have the latest changes..
10:04:44 <nehag> as communicated by noopq
10:04:54 <mkudlej> brainfunked: ping, hi, sorry, I should go now. my status is that I've done a lot of reviews, I've done work unrelated to Tendrl and I'm still working on https://github.com/Tendrl/usmqe-tests/issues/9
10:04:58 <Shu6h3ndu> noopq, I have updated the suggested s/RBD/Rbd/g in instance http://10.70.42.223:2379/v2/keys/clusters/64d779e6-491e-4998-a805-1252bbd5a899/
10:05:09 <Shu6h3ndu> noopq, please check once and let me know of things are fine
10:05:20 <mkudlej> nehag: you can use ansible playbooks from usmqe-setup to deploy your environment
10:05:28 <nthomas> nehag, go ahead and upgrade the packages which you felt as old
10:05:51 <brainfunked> #accept kaverma__ nehag and anbehl have indicated that they checked the UX designs for the create pool and create rbd flows (https://redhat.invisionapp.com/share/2T9LPMEEB and https://redhat.invisionapp.com/share/EHAC6S0N4) and have had their queries resolved via conversations with Shu6h3ndu
10:06:28 <brainfunked> #action nehag will be detailing the API requirements to satisfy the pool and rbd create flows in a specification and tag noopq on it
10:06:29 <nehag> nthomas, we dont know which are the old one, noopq will be able to tell us regarding this
10:06:47 <brainfunked> mkudlej|lunch, ack
10:07:05 <noopq> Shu6h3ndu, ok
10:07:16 <brainfunked> nehag, kaverma__ anbehl did you guys finish the technical debt review and have you figured out the effort required to clean it?
10:07:18 <Shu6h3ndu> brainfunked, nthomas, I have question regarding quota feature for pools. do we have this to be done now? I see mock ups around that
10:08:18 <nehag> brainfunked, we will sit after this meeting and will tell you by EOD today
10:08:24 <Shu6h3ndu> brainfunked, nthomas, if not would remove all quota related fields from definitions for now and we can add later when we enabled quota
10:09:52 <brainfunked> #action nehag kaverma__ and anbehl to document the backend changes required by EoD today
10:10:04 <brainfunked> #topic testing updates
10:10:41 <brainfunked> #info mkudlej has done reviews and is working on https://github.com/Tendrl/usmqe-tests/issues/9
10:10:55 <brainfunked> fbalak, ltrilety, any updates?
10:11:26 <fbalak> #action fbalak Working on https://github.com/Tendrl/usmqe-tests/pull/35 (Add volume tests)
10:11:27 <fbalak> #action fbalak Status: good
10:11:59 <ltrilety> #action ltrilety is working on https://github.com/Tendrl/usmqe-tests/issues/16
10:12:27 <brainfunked> ack
10:12:56 <brainfunked> #info fbalak is working on volume create tests https://github.com/Tendrl/usmqe-tests/pull/35
10:13:17 <brainfunked> #info ltrilety is working on cluster list tests https://github.com/Tendrl/usmqe-tests/issues/16
10:13:26 <brainfunked> #endmeeting