#ansible-community: Ansible PR review day

Meeting started by gundalow at 10:01:37 UTC (full logs).

Meeting summary

  1. Test PRs (gundalow, 10:04:45)
    1. https://github.com/ansible/ansible/pull/62014 iam_role : support managing max session duration and deleting the instance profile it creates (gundalow, 10:04:59)
    2. label/pr_day open:35 Closed: 77 (gundalow, 10:06:33)
    3. ACTION: gundalow to follow up AWS discussion with others post-fest (gundalow, 10:29:04)

  2. label/small_patch (gundalow, 10:29:11)
    1. https://github.com/ansible/ansible/pull/62531 docs: really clarify environment (gundalow, 10:30:20)
    2. https://github.com/ansible/ansible/pull/62491 ovirt_host update force doc (gundalow, 10:35:19)
    3. https://github.com/ansible/ansible/pull/62482 Removing hyperized as maintainer (gundalow, 10:39:14)
    4. https://github.com/ansible/ansible/pull/62330 nsupdate: Don't mention the Microsoft DNS server (gundalow, 10:42:20)
    5. https://technet.microsoft.com/en-us/library/cc961412.aspx is about Windows 2000 (gundalow, 10:44:12)
    6. https://github.com/ansible/ansible/pull/61607 lxd_container: enables to set keys not present in existing config (gundalow, 10:48:27)
    7. ACTION: gundalow to look at creating some sort of easy_to_test label as a todo list of things that people can create integration tests for (gundalow, 10:57:40)

  3. Deprecated PRs (gundalow, 10:57:47)
    1. https://github.com/ansible/ansible/pulls?q=is%3Aopen+label%3Adeprecated+is%3Apr (gundalow, 10:57:52)
    2. https://github.com/ansible/ansible/pull/31664 Add module ldap_attrs; deprecate ldap_attr (gundalow, 10:58:09)

  4. needs_repo (gundalow, 11:38:12)
    1. https://github.com/ansible/ansible/pull/57779 I'll ask if this is good to merge as-is, otherise wil be clsoed (gundalow, 11:39:54)
    2. https://github.com/ansible/ansible/pull/54912 (gundalow, 11:41:05)
    3. https://github.com/ansible/ansible/pull/54167 Return MAC address from Supermicro and HP systems (gundalow, 11:42:00)
    4. https://github.com/ansible/ansible/pull/51371 flatpak: Open subprocess in text stream mode (gundalow, 11:44:17)
    5. https://github.com/ansible/ansible/pull/42055 Update aws_api_gateway.py (Xaroth, 11:45:37)
    6. https://github.com/ansible/ansible/pull/41653 add master_ssl_verify_identity to mysql_replication (Xaroth, 11:47:00)
    7. https://github.com/ansible/ansible/pull/40411 Add support for GitHub Enterprise for github_deploy_key (gundalow, 11:50:08)
    8. https://github.com/ansible/ansible/pull/40003 Update cron.py (gundalow, 11:55:04)
    9. https://github.com/ansible/ansible/pull/39715 elb_target_group: only drain all elb targets if targets is an empty list and modify_targets is true (gundalow, 12:04:55)
    10. https://github.com/ansible/ansible/pull/32930 Windows Facts: add WinSystemLocale (gundalow, 12:05:42)
    11. https://github.com/ansible/ansible/pull/32158 iptables: chain creation and deletion (gundalow, 12:09:49)
    12. https://github.com/ansible/ansible/pull/32011 (gundalow, 12:10:00)
    13. https://github.com/ansible/ansible/pull/32011 Fix paramter confusion between directory and passwordstore (gundalow, 12:15:16)
    14. https://github.com/ansible/ansible/pull/28606 haproxy: connect via TCP socket in addition to UNIX socket (gundalow, 12:16:22)
    15. https://github.com/ansible/ansible/pull/28469 WIP: New module: diff (string, file or command output vs string, file or command output) (gundalow, 12:17:21)
    16. https://github.com/ansible/ansible/pull/24582 appears to be a candidate for closure (tremble, 12:20:55)
    17. https://github.com/ansible/ansible/pull/25176 Is really stale, I'm sure shertel wouldn't be offended if you closed it and she still wanted it around. (tremble, 12:22:24)
    18. https://github.com/ansible/ansible/pull/25214 looks to be abandoned (tremble, 12:24:19)
    19. https://github.com/ansible/ansible/pull/25919 - was asked to resolve the conflict a year ago, looks abandoned. (tremble, 12:26:49)
    20. https://github.com/ansible/ansible/pull/26268 - rebase request a year ago, no updates (tremble, 12:29:41)
    21. https://github.com/ansible/ansible/pull/24690 closed (gundalow, 12:33:40)
    22. https://github.com/ansible/ansible/pull/30746 looks dead (tremble, 12:38:33)
    23. https://github.com/ansible/ansible/pull/34022 looks to have been superceeded by #36641 (tremble, 12:45:24)
    24. https://github.com/ansible/ansible/pull/12090 4 years old, no repo, no response from owner in over a year; close it I'd say (Xaroth, 12:51:16)
    25. https://github.com/ansible/ansible/pull/13612 same, over two years no response, close it I'd say (Xaroth, 12:52:11)
    26. https://github.com/ansible/ansible/pull/14109 << Same as above (Xaroth, 12:53:09)
    27. https://github.com/ansible/ansible/pull/14235, https://github.com/ansible/ansible/pull/17989, https://github.com/ansible/ansible/pull/18596, https://github.com/ansible/ansible/pull/19123, https://github.com/ansible/ansible/pull/19695 all the same as the others. (Xaroth, 12:56:38)
    28. https://github.com/ansible/ansible/pull/20189 same as above (Xaroth, 12:59:47)
    29. https://github.com/ansible/ansible/pull/20377 and https://github.com/ansible/ansible/pull/20630 have had recent ( <1y ) activity.. might be an idea to ask for a new maintainer of this issue? (Xaroth, 13:00:14)
    30. https://github.com/ansible/ansible/pull/31427 looks to have been mooted by #43113 (tremble, 13:00:52)
    31. https://github.com/ansible/ansible/pull/20920 was abandoned probably because it was waiting on review, suggest poking and de-assigning it. (Xaroth, 13:02:06)
    32. https://github.com/ansible/ansible/pull/20959 << no response in >1y, I'd say message about re-opening, and closing (Xaroth, 13:03:22)
    33. https://github.com/ansible/ansible/pull/21646 perhaps something to poke will about (Xaroth, 13:05:35)
    34. https://github.com/ansible/ansible/pull/38965 mooted by #47217 ( I think ) (tremble, 13:13:52)
    35. https://github.com/ansible/ansible/pull/37716 changes requested a 15 months ago, no response. (tremble, 13:30:30)
    36. https://github.com/ansible/ansible/pull/37475 changes requested 1 year ago, no response. (tremble, 13:32:59)
    37. https://github.com/ansible/ansible/pull/36035 mooted by https://github.com/ansible/ansible/pull/47217 (tremble, 13:42:21)
    38. We've closed 36 PRs (gundalow, 15:07:39)


Meeting ended at 15:33:25 UTC (full logs).

Action items

  1. gundalow to follow up AWS discussion with others post-fest
  2. gundalow to look at creating some sort of easy_to_test label as a todo list of things that people can create integration tests for


Action items, by person

  1. gundalow
    1. gundalow to follow up AWS discussion with others post-fest
    2. gundalow to look at creating some sort of easy_to_test label as a todo list of things that people can create integration tests for


People present (lines said)

  1. gundalow (130)
  2. Xaroth (42)
  3. tremble (38)
  4. misc (26)
  5. zodbot (9)
  6. robertdebock (8)
  7. shertel (2)
  8. shaps (1)
  9. felixfontein (1)
  10. resmo (1)


Generated by MeetBot 0.1.4.