#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 19:00:24 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (felixfontein, 19:00:25)
  2. Updates (felixfontein, 19:00:59)
    1. Ansible 4.0.0a1 has been released (felixfontein, 19:00:59)
    2. Ansible Contributor Summit 2021.03 playlist https://www.youtube.com/playlist?list=PL0FmYCf7ocraIwuMDD_TceUMneSiy3Hi1 (cybette, 19:02:40)
    3. If you attended Contributors Summit please check your email for a survey link. Feedback is really important to us (gundalow, 19:07:50)

  3. Ansible Engineering Steering Committee (felixfontein, 19:08:09)
    1. From next week on, this meeting will (also) be the official weekly meeting of the Ansible Engineering Steering Committee (felixfontein, 19:08:09)

  4. Inclusion request review day: Wednesday, March 24th (felixfontein, 19:12:49)
    1. AGREED: Inclusion request review day will start 13:00 UTC on Wednesday, March 24th (felixfontein, 19:21:35)

  5. Collection naming (felixfontein, 19:21:47)
    1. https://cloud.redhat.com/ansible/automation-hub/repo/published/redhat/satellite is downstream of foreman.foreman. (tadeboro, 19:29:39)
    2. AGREED: it is desirable that galaxy and AH collection names are identical if possible (felixfontein, 19:35:06)

  6. Collection guidelines: disallow validate-modules:no-log-needed ignore.txt entries (felixfontein, 19:36:55)
    1. https://github.com/ansible-collections/overview/pull/158 (felixfontein, 19:37:00)
    2. https://github.com/ansible-collections/overview/pull/158 | open, created 2021-03-12T06:16:38Z by felixfontein: Collection guidelines: disallow validate-modules:no-log-needed ignore.txt entries (github-linkbot, 19:37:01)
    3. AGREED: gundalow merges the PR (felixfontein, 19:44:37)

  7. Python version requirements: https://github.com/ansible-collections/overview/pull/151 (felixfontein, 19:45:28)
    1. https://github.com/ansible-collections/overview/pull/151 | open, created 2021-01-25T12:48:11Z by Ompragash: New Policy Regarding Python Compatibility for Collections (github-linkbot, 19:45:29)
    2. https://en.wikipedia.org/wiki/DMZ_(computing) (abadger1999, 19:54:07)
    3. AGREED: "In the controller environment, collections MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. Collections SHOULD also support Python v3.5 if all required libraries support this version." (felixfontein, 20:05:32)
    4. AGREED: "In the other environment, collections MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. Collections SHOULD also support Python v2.6 and v3.5 if all required libraries support this version. (felixfontein, 20:05:39)

  8. open floor (felixfontein, 20:06:09)
    1. 'ansible' is now a 'team' (instead of a 'user') on launchpad (felixfontein, 20:07:57)


Meeting ended at 20:14:16 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. felixfontein (127)
  2. jillr (38)
  3. gundalow (37)
  4. acozine (32)
  5. abadger1999 (26)
  6. cyberpear (25)
  7. bcoca (22)
  8. andersson007_ (18)
  9. tadeboro (18)
  10. zodbot (17)
  11. cybette (16)
  12. dericcrago (12)
  13. samccann (11)
  14. geerlingguy (8)
  15. mariolenz (6)
  16. briantist (6)
  17. dmsimard (5)
  18. apple4ever (4)
  19. github-linkbot (2)


Generated by MeetBot 0.1.4.