#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 18:00:08 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (felixfontein, 18:00:08)
    1. Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics (felixfontein, 18:00:13)

  2. Updates (felixfontein, 18:00:25)
    1. Ansible 4.1.0 has been released (felixfontein, 18:00:58)
    2. ansible-core 2.11.2rc1, ansible-base 2.10.11rc1 and ansible 2.9.23rc1 have been released (fixing CVE-2021-3583) (felixfontein, 18:00:58)
    3. Matrix <--> Libera.chat bridge is progressing. we should have some details to share soon (gundalow, 18:04:03)
    4. The Bullhorn 28 is out: https://mailchi.mp/redhat/the-bullhorn-28 (felixfontein, 18:05:25)

  3. Ansible 5.0.0 schedule (felixfontein, 18:06:39)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/21 (felixfontein, 18:06:39)
    2. link to ansible-core 2.12 roadmap around which 5.0 is scheduled: https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/ROADMAP_2_12.rst (dmsimard, 18:08:07)
    3. AnsibleFest Sept 29th and 30th (jillr, 18:13:25)
    4. https://www.ansible.com/ansiblefest (jillr, 18:13:28)
    5. AGREED: plan Ansible 5.0.0 to be released according the schedule https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw#Proposed-Schedule-for-Ansible-50 (felixfontein, 18:18:14)

  4. Deprecation and removal schedule for community.kubernetes (felixfontein, 18:18:52)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/22 (felixfontein, 18:18:53)
    2. https://github.com/ansible-collections/community.kubernetes/pull/425 | closed, created 2021-05-03T06:09:55Z by Akasurde: Redirect everything to kuberentes.core  (github-linkbot, 18:19:50)
    3. AGREED: 1) add a deprecation changelog fragment to the next 4.x.0 release; 2) release community.kubernetes 2.0.0 with deprecated redirects and include it in Ansible 5; 3) remove community.kubernetes from Ansible 6 or later (felixfontein, 18:31:25)

  5. Improve ansible-collections issue templates (ask for collection version) (felixfontein, 18:33:08)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/23 (felixfontein, 18:33:11)

  6. Define personas/user stories/use cases for the community docsite (felixfontein, 18:45:58)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/24 (felixfontein, 18:46:02)
    2. maybe it's best to split the docs by action, rather than by persona? Something like Learn/Participate/Contribute/Develop (samccann, 19:08:19)

  7. open floor (felixfontein, 19:11:17)


Meeting ended at 19:18:12 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. felixfontein (101)
  2. acozine (40)
  3. samccann (35)
  4. andersson007_ (28)
  5. abadger1999 (25)
  6. dmsimard (23)
  7. gundalow (22)
  8. jillr (19)
  9. zodbot (16)
  10. cybette_ (15)
  11. tadeboro (13)
  12. mgraves (7)
  13. cyberpear (5)
  14. aminvakil (5)
  15. dericcrago (3)
  16. bcoca (2)
  17. github-linkbot (1)
  18. briantist (1)


Generated by MeetBot 0.1.4.