#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:32:06 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 14:32:14)
  2. removing rst files from tarballs (acozine, 14:40:43)
    1. ACTION: samccann to followup with abadger on RST files out of the tarballs (samccann, 14:40:50)
    2. ACTION: samccann to again bug abadger to see if we already take anything out of the Ansible package that's part of the collections source (samccann, 14:42:59)
    3. some package tarballs contain everything - e.g. should be an editable body of code if someone wanted to base a patch on it (samccann, 14:45:03)
    4. need to consider that as well as licensing/legal implications of removing docs etc from ansible tarballs (samccann, 14:45:41)
    5. size of tarball may also be slowing down installation times... (samccann, 14:47:38)
    6. cannot use wheel option because ansible-core and thus Ansible have setup.py dynamics. See https://github.com/ansible/ansible/issues/71992#issuecomment-700739135 (samccann, 14:55:22)

  3. docs user survey (acozine, 14:57:07)
    1. draft docs survey for review - https://hackmd.io/JemYBo_8QbqqO9cULo3rJQ (samccann, 15:08:48)

  4. follow up on long-running items (acozine, 15:25:05)
    1. the sphinx extension is now part of antsibull (felixfontein, 15:26:52)
    2. roleargspec PR - https://github.com/ansible/ansible/pull/72120 (samccann, 15:34:45)
    3. https://github.com/ansible/ansible/pull/72120/files#diff-96c4675726c535de24f519c4d5f49737a9fb0d184e166786e02b7033ae8ca0b0 (acozine, 15:37:51)

  5. open floor (acozine, 15:58:57)
    1. looking for docs feedback on c.g changes - (a) announcing a new location for content (https://github.com/ansible-collections/community.general/pull/1303) and (b) removing the old content (https://github.com/ansible-collections/community.general/pull/1304) (samccann, 16:00:51)
    2. anyone can add an agenda item for this meeting by putting a comment on https://github.com/ansible/community/issues/521 (acozine, 16:09:22)
    3. we currently have an additional meeting on Thursdays, starting one hour later than the regular DaWGs meeting, to focus on splitting out the `ansible-core` docs from the `Ansible` (package) docs (acozine, 16:13:14)
    4. the split is necessary because next year we will have two things with version `2.11` - an `ansible` 2.11 package, and an `ansible-core` 2.11 version (acozine, 16:14:39)


Meeting ended at 16:17:08 UTC (full logs).

Action items

  1. samccann to followup with abadger on RST files out of the tarballs
  2. samccann to again bug abadger to see if we already take anything out of the Ansible package that's part of the collections source


Action items, by person

  1. samccann
    1. samccann to followup with abadger on RST files out of the tarballs
    2. samccann to again bug abadger to see if we already take anything out of the Ansible package that's part of the collections source


People present (lines said)

  1. acozine (118)
  2. felixfontein (42)
  3. samccann (38)
  4. dmsimard (16)
  5. gwmngilfen (16)
  6. cyberpear (15)
  7. zodbot (13)
  8. Shrews (13)
  9. gundalow (11)
  10. sivel (7)
  11. tadeboro (7)
  12. lmodemal (6)
  13. tremble (3)
  14. dericcrago (2)
  15. alongchamps (1)


Generated by MeetBot 0.1.4.