#fedora-blocker-review: F25-blocker-review

Meeting started by adamw at 16:00:09 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:10)
    1. http://las.gnome.org/ (adamw, 16:02:46)

  2. Introduction (adamw, 16:02:55)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:02:56)
    2. We'll be following the process outlined at: (adamw, 16:02:56)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:02:56)
    4. The bugs up for review today are available at: (adamw, 16:02:58)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:03:00)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:03:07)
    7. https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria (adamw, 16:03:08)
    8. https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria (adamw, 16:03:08)
    9. https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria (adamw, 16:03:08)
    10. pschindl to secretarialize (adamw, 16:04:15)
    11. 4 Proposed Blockers (adamw, 16:04:49)
    12. 4 Accepted Blockers (adamw, 16:04:49)
    13. 1 Proposed Freeze Exceptions (adamw, 16:04:49)
    14. 1 Accepted Freeze Exceptions (adamw, 16:04:51)
    15. 8 Proposed Blockers (Final) (adamw, 16:05:04)
    16. starting with Beta proposed blockers (adamw, 16:05:34)
    17. 4 Proposed Blockers (adamw, 16:05:35)
    18. 4 Accepted Blockers (adamw, 16:05:35)
    19. 1 Proposed Freeze Exceptions (adamw, 16:05:35)
    20. 1 Accepted Freeze Exceptions (adamw, 16:05:36)

  3. (1372868) F25 Alpha-2 Installer Fails if DVD-ROM is on Silicon Image 3114 SATA Controller (adamw, 16:05:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1372868 (adamw, 16:05:44)
    2. Proposed Blocker, anaconda, NEW (adamw, 16:05:44)
    3. AGREED: 1372868 - RejectedBlocker (Beta) - this does not seem to affect much hardware, and there is a workaround available (adamw, 16:08:21)

  4. (1373169) Can't login again after logout. (adamw, 16:08:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1373169 (adamw, 16:08:34)
    2. Proposed Blocker, gnome-session, NEW (adamw, 16:08:34)
    3. AGREED: 1373169 - AcceptedBlocker (Beta) - this constitutes a violation of "Shutting down, logging out and rebooting must work using standard console commands and the mechanisms offered (if any) by all release-blocking desktops." - 'work' is defined as "Logging out must return the user to the environment from which they logged in, working as expected.", and if you can't log in again, it's not 'working as expected' (adamw, 16:15:49)

  5. (1372962) SELinux is preventing mount from 'unlink' accesses on the file utab. (adamw, 16:16:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1372962 (adamw, 16:16:01)
    2. Proposed Blocker, selinux-policy, ON_QA (adamw, 16:16:01)
    3. AGREED: 1372962 - AcceptedBlocker (Beta) - violates "Automatic mounting of removable media on insertion must work in release-blocking desktops." (adamw, 16:19:18)

  6. (1374670) KDE desktop freezes on login (adamw, 16:19:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1374670 (adamw, 16:19:35)
    2. Proposed Blocker, selinux-policy, VERIFIED (adamw, 16:19:35)
    3. AGREED: 1374670 - AcceptedBlocker (Beta) - this is an effective violation of all desktop-related Alpha and Beta criteria (as it takes ~5 minutes to do anything at all) (adamw, 16:24:24)
    4. moving to the proposed Beta freeze exception (adamw, 16:24:56)

  7. (1375721) [abrt] initial-setup: common.py:356:_mark_screen_visited:AttributeError: 'NoneType' object has no attribute 'mark_screen_visited' (adamw, 16:25:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1375721 (adamw, 16:25:04)
    2. Proposed Freeze Exceptions, initial-setup, NEW (adamw, 16:25:04)
    3. AGREED: 1375721 - AcceptedFreezeException (Beta) - inability to create a user in i-s is clearly a serious problem that cannot be fixed in an update. if this bug turns out to affect ARM it will likely be upgraded to a blocker, but for now we grant it an FE at least. (adamw, 16:32:48)
    4. we'll switch to final blockers now, and coremodule will take over (adamw, 16:32:58)

  8. (1375712) [abrt] anaconda: TypeError: __new__() takes 3 positional arguments but 5 were given (coremodule, 16:33:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1375712 (coremodule, 16:34:02)
    2. Proposed Blocker, anaconda, POST (coremodule, 16:34:11)
    3. AGREED: 1375712 - tentative AcceptedBlocker - If the affected software hits stable repos, this will violate "The installer must be able to detect (if possible) and install to supported network-attached storage devices." for SCSi and therefore be a blocker. Punting for the moment. (coremodule, 16:52:13)

  9. (1366775) /usr/libexec/gnome-settings-daemon is hammering CPU after login tring to connect to local printing service (coremodule, 16:53:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1366775 (coremodule, 16:53:13)
    2. Proposed Blocker, cups, NEW (coremodule, 16:53:18)
    3. Moving on to the next bug, we will return to 1366775 after some testing (coremodule, 16:58:29)

  10. (1375504) VM screen is often black after boot in gnome-boxes (coremodule, 16:58:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1375504 (coremodule, 16:58:42)
    2. Proposed Blocker, gnome-boxes, NEW (coremodule, 16:58:46)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1374028 (kparal, 17:00:35)
    4. AGREED: 1375504 - AcceptedBlocker (Final) - Violates the following Blocker criteria: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." We will see if there is any backlash from the maintainer after classification and go from there. (coremodule, 17:21:04)
    5. Moving to 1266484 as it's directly related to this bug. (coremodule, 17:21:22)

  11. (1266484) spice + fedora wayland VM + spice-vdagent + resize-guest == flickering display (coremodule, 17:21:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1266484 (coremodule, 17:21:35)
    2. Proposed Blocker, xorg-x11-drv-qxl, NEW (coremodule, 17:21:40)
    3. AGREED: 1266484 - punt (delay decision) - Currently F25 uses X11 in Boxes, but should the switch to Wayland be made in the future, this will inhibit the user from launching applications. If Wayland is confirmed, we will classify this bug as an AcceptedBlocker, but until then we will wait on any decision. (coremodule, 17:33:44)
    4. Back to 136675 to finalize on the details... (coremodule, 17:34:17)

  12. (1366775) /usr/libexec/gnome-settings-daemon is hammering CPU after login tring to connect to local printing service (coremodule, 17:34:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1366775 (coremodule, 17:34:27)
    2. Proposed Blocker, cups, NEW (coremodule, 17:34:27)
    3. AGREED: 1366775 - punt (delay decision) - Based on information gathered during the meeting, it seems like there is a possibility of multiple bugs here. Until we can confirm that this is one single bug, we are delaying the classification of this as a blocker. (coremodule, 17:43:31)

  13. (1372300) GDM does not use the keyboard layout which is selected (coremodule, 17:43:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1372300 (coremodule, 17:43:40)
    2. Proposed Blocker, mutter, NEW (coremodule, 17:43:41)
    3. AGREED: 1372300 - punt (delay decision) - We currently cannot find an appropriate criteria to block on, however this bug makes multilingual use of F25 unusable. We will delay the classification of this as a blocker until the criteria can be amended, we receive new info on this bug, or the bug is fixed. (coremodule, 18:02:17)

  14. (1377313) mutter 3.21.92-1.fc25 prevents libreoffice from opening existing files (coremodule, 18:02:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1377313 (coremodule, 18:02:32)
    2. Proposed Blocker, mutter, MODIFIED (coremodule, 18:02:33)
    3. AGREED: 1377313 - AcceptedBlocker (Final) - The decision was made to nominate this as a Final blocker: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." (coremodule, 18:09:45)

  15. (1370222) KDE doesn't start if hostname changes during boot due to network (infamous xauth issue) (coremodule, 18:09:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1370222 (coremodule, 18:09:54)
    2. Proposed Blocker, sddm, NEW (coremodule, 18:09:54)
    3. AGREED: 1370222 - AcceptedBlocker (Final) - The decision was made to nominate this as a Final blocker: "Release-blocking live images must boot to the expected boot menu, and then to a desktop or to a login prompt where it is clear how to log in to a desktop." (coremodule, 18:14:44)

  16. (1375156) SELinux cripples storaged (coremodule, 18:14:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1375156 (coremodule, 18:14:51)
    2. Proposed Blocker, selinux-policy, VERIFIED (coremodule, 18:14:51)
    3. https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#System_services (kparal, 18:18:43)
    4. AGREED: 1375156 - AcceptedBlocker (Final) - The decision was made to nominate this as a Final blocker: "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present. (coremodule, 18:24:41)
    5. Open Floor (coremodule, 18:25:11)
    6. Next meeting time - 16:00 UTC on 2016-09-26 (coremodule, 18:25:34)


Meeting ended at 18:27:11 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. kparal (199)
  2. coremodule (148)
  3. cmurf (126)
  4. adamw (124)
  5. pschindl (38)
  6. zodbot (11)
  7. satellit (7)
  8. pwhalen (6)
  9. nb (4)
  10. dgilmore (2)


Generated by MeetBot 0.1.4.