#fedora-blocker-review: F26-blocker-review

Meeting started by adamw at 17:02:37 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 17:02:41)
  2. Introduction (adamw, 17:05:15)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 17:05:15)
    2. We'll be following the process outlined at: (adamw, 17:05:15)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 17:05:15)
    4. The bugs up for review today are available at: (adamw, 17:05:17)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 17:05:21)
    6. The criteria for release blocking bugs can be found at: (adamw, 17:05:23)
    7. https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria (adamw, 17:05:25)
    8. https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria (adamw, 17:05:27)
    9. https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria (adamw, 17:05:29)
    10. 2 Proposed Blockers (Alpha) (adamw, 17:05:33)
    11. 2 Proposed Freeze Exceptions (Alpha) (adamw, 17:05:38)
    12. 3 Proposed Blockers (Final) (adamw, 17:05:50)
    13. coremodule will secretarialize (adamw, 17:06:32)
    14. Fedora 26 will enter Alpha Freeze at midnight UTC (sgallagh, 17:06:37)

  3. (1429132) blivet.safe_dbus.DBusCallError: Failed to call Introspect method on /org/freedesktop/UDisks2/Manager with None arguments: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UDisks2 was not provided by any .service files (adamw, 17:06:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1429132 (adamw, 17:06:54)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:06:54)
    3. AGREED: 1429132 - RejectedBlocker AcceptedFreezeException (Alpha) - we suspect this is a missing package on the lxqt spin, which is non-blocking, so not a blocker - but if that's the cause, we approve a freeze exception to add the missing package to the spin (adamw, 17:12:48)

  4. (1426850) Re-enable ARMv7 builds on all releases (adamw, 17:13:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1426850 (adamw, 17:13:10)
    2. Proposed Blocker, firefox, ASSIGNED (adamw, 17:13:10)
    3. this bug has now been fixed, pwhalen will close it (adamw, 17:16:33)
    4. moving onto Alpha freeze exceptions (adamw, 17:16:50)

  5. (1426796) Regression: kernel doesn't boot on qemu on either ppc64 or ppc64le (adamw, 17:16:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1426796 (adamw, 17:16:57)
    2. Proposed Freeze Exceptions, kernel, NEW (adamw, 17:16:57)
    3. AGREED: 1426796 - AcceptedFreezeException (Alpha) - this is clearly a severe issue and would be a blocker for a blocking arch, so accepted as an FE for non-blocking ppc64(le) arches (adamw, 17:20:29)

  6. (1419980) SELinux is preventing abrt-dump-journ from 'execute' accesses on the file /usr/bin/lz4. (adamw, 17:20:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1419980 (adamw, 17:20:36)
    2. Proposed Freeze Exceptions, selinux-policy, ON_QA (adamw, 17:20:36)
    3. AGREED: 1419980 - AcceptedFreezeException (Alpha) - this prevents a significant accepted Change from working in the Workstation live environment (adamw, 17:26:04)
    4. moving on to proposed Final blockers (adamw, 17:26:22)

  7. (1405539) changing the default keyboard layout changes also disk decryption in plymouth, but only after kernel update, long after (adamw, 17:26:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1405539 (adamw, 17:26:34)
    2. Proposed Blocker, plymouth, NEW (adamw, 17:26:34)
    3. we have asked g11n teams for their thoughts on this and are waiting for feedback (adamw, 17:28:16)
    4. AGREED: 1405539 - ƥüňť - we still don't have any additional info here, we'll wait one more week for thoughts from g11n folks before making up our minds (adamw, 17:36:58)

  8. (1411360) SELinux is preventing (ostnamed) from 'mounton' accesses on the file /proc/mtrr. (adamw, 17:38:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1411360 (adamw, 17:38:18)
    2. Proposed Blocker, selinux-policy, ASSIGNED (adamw, 17:38:19)
    3. AGREED: 1411360 - AcceptedBlocker (Final) AcceptedFreezeException (Alpha) - this clearly violates "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop", and is sufficiently annoying and widespread to also be an Alpha freeze exception (adamw, 17:44:03)

  9. (1427392) SELinux is preventing (-localed) from mounton access on the file /proc/mtrr. (adamw, 17:44:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1427392 (adamw, 17:44:08)
    2. Proposed Blocker, selinux-policy, NEW (adamw, 17:44:09)
    3. AGREED: 1427392 - AcceptedBlocker (Final) AcceptedFreezeException (Alpha) - as per #1411360 this is a clear violation of the 'no AVCs during install / first boot' criterion, and is worth fixing in Alpha too due to visibility (adamw, 17:50:16)
    4. moving on to a review of accepted Alpha blockers (adamw, 17:51:13)

  10. (1420520) All ARM disk image composes fail in Rawhide (adamw, 17:51:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1420520 (adamw, 17:51:16)
    2. Accepted Blocker, distribution, NEW (adamw, 17:51:16)
    3. this seemed to be resolved for a few weeks, but disk images have once again stopped appearing for F26 since branching (adamw, 17:52:53)
    4. nirik believes a new pungi version may help (adamw, 17:53:06)
    5. releng is looking into this one, we'll check back next week (adamw, 17:55:55)

  11. (1410523) gi.overrides.BlockDev.LVMError: Failed to call the 'LvCreate' method on the '/com/redhat/lvmdbus1/Vg/1' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Vg', "Exit code 3, stderr = --size may not ... (adamw, 17:56:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1410523 (adamw, 17:56:03)
    2. Accepted Blocker, python-blivet, NEW (adamw, 17:56:03)
    3. ACTION: adamw to check with anaconda folks that this is in hand (adamw, 17:59:25)

  12. (1422634) selinux prevents kernel modules from loading (adamw, 18:00:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1422634 (adamw, 18:00:32)
    2. Accepted Blocker, selinux-policy, ON_QA (adamw, 18:00:33)
    3. this is expected to be fixed in the next selinux-policy build, but builds have been failing; SELinux team is working on getting a successful build (adamw, 18:02:03)

  13. Open floor (adamw, 18:03:07)


Meeting ended at 18:06:44 UTC (full logs).

Action items

  1. adamw to check with anaconda folks that this is in hand


Action items, by person

  1. adamw
    1. adamw to check with anaconda folks that this is in hand


People present (lines said)

  1. adamw (143)
  2. Kohane (31)
  3. pwhalen (23)
  4. kparal (20)
  5. roshi (19)
  6. sgallagh (14)
  7. garretraziel (13)
  8. nirik (9)
  9. zodbot (7)
  10. sgallagh_ (3)
  11. pschindl_wfh (2)
  12. coremodule (2)
  13. satellit (1)
  14. mclasen (1)


Generated by MeetBot 0.1.4.