#fedora-blocker-review: F26-blocker-review

Meeting started by roshi at 16:07:09 UTC (full logs).

Meeting summary

  1. Roll Call (roshi, 16:07:09)
  2. Introduction (roshi, 16:08:50)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (roshi, 16:08:51)
    2. We'll be following the process outlined at: (roshi, 16:08:54)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (roshi, 16:08:57)
    4. The bugs up for review today are available at: (roshi, 16:08:59)
    5. http://qa.fedoraproject.org/blockerbugs/current (roshi, 16:09:02)
    6. The criteria for release blocking bugs can be found at: (roshi, 16:09:04)
    7. https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria (roshi, 16:09:07)
    8. https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria (roshi, 16:09:10)
    9. https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria (roshi, 16:09:13)
    10. 3 Proposed Blockers (roshi, 16:09:21)
    11. 1 Accepted Blockers (roshi, 16:09:21)
    12. 0 Accepted 0-day Blockers (roshi, 16:09:21)
    13. 0 Accepted Previous Release Blockers (roshi, 16:09:23)
    14. 6 Proposed Freeze Exceptions (roshi, 16:09:25)
    15. 5 Accepted Freeze Exceptions (roshi, 16:09:28)

  3. (1430250) bind-pkcs11 keeps failing to connect to LDAP server during FreeIPA server deployment on current Rawhide (roshi, 16:09:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1430250 (roshi, 16:09:43)
    2. Proposed Blocker, 389-ds, NEW (roshi, 16:09:45)
    3. will come back around to this later in the meeting (roshi, 16:14:28)

  4. (1430043) VMs with virtio-scsi devices often crash during boot with traceback running through scsi code since kernel-4.11.0-0.rc1.git0.1.fc27 (roshi, 16:14:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1430043 (roshi, 16:14:32)
    2. Proposed Blocker, kernel, NEW (roshi, 16:14:34)
    3. AGREED: - RejectedBlocker AcceptedFreezeException - RHBZ#1430043 - This isn't conisdered serious enough to block release because it only seems to affect VMs booted with a SCSI virtio device and other methods work. We would consider a patch to fix this before release provided it's tested and focused on just this issue. (roshi, 16:25:33)

  5. (1430406) opendnssec: broken ldns dependency prevents from installing freeipa-server-dns (roshi, 16:25:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1430406 (roshi, 16:25:50)
    2. Proposed Blocker, opendnssec, NEW (roshi, 16:25:52)
    3. AGREED: - AcceptedBlocker - RHBZ#1430406 - This is a clear violation of the following Alpha critrion: "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried." (roshi, 16:28:18)

  6. (1430250) bind-pkcs11 keeps failing to connect to LDAP server during FreeIPA server deployment on current Rawhide (roshi, 16:30:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1430250 (roshi, 16:30:34)
    2. Proposed Blocker, 389-ds, NEW (roshi, 16:30:36)
    3. AGREED: - AcceptedBlocker - RHBZ#1430250 - This bug is accepted as an Alpha blocker due to the severity of the breakage and lack of an workaround - voilating the following Alpha criterion: "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed..." (roshi, 16:43:00)

  7. (1429988) ValueError: New size must be between minimal (4 MiB) and maximum (0 B) size. (roshi, 16:47:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1429988 (roshi, 16:47:33)
    2. Proposed Freeze Exceptions, blivet-gui, MODIFIED (roshi, 16:47:35)
    3. AGREED: - AcceptedFreezeException - RHBZ#1429988 - We'd consider letting a fix for this in during freeze. (roshi, 16:57:09)

  8. (1430247) FreeIPA server deployment runs ipa-custodia on Python 3, should use Python 2 (roshi, 16:57:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1430247 (roshi, 16:57:24)
    2. Proposed Freeze Exceptions, freeipa, NEW (roshi, 16:57:27)
    3. AGREED: - AcceptedFreezeException - RHBZ#1430247 - It'd be really good to get a fix in for this before Alpha release. Please update the bug if this issue is more severe than we currently suspect. (roshi, 17:04:07)

  9. (1423793) js: FTBFS in rawhide (roshi, 17:04:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1423793 (roshi, 17:04:27)
    2. Proposed Freeze Exceptions, js, ON_QA (roshi, 17:04:27)
    3. AGREED: - AcceptedFreezeException - RHBZ#1423793 - It would be great to get support for aarch64. (roshi, 17:07:39)

  10. (1428559) Rawhide Workstation live installer is suddenly orange (roshi, 17:07:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1428559 (roshi, 17:07:54)
    2. Proposed Freeze Exceptions, mutter, ON_QA (roshi, 17:07:57)
    3. AGREED: - AcceptedFreezeException - RHBZ#1428559 - We really should ensure that the colorscheme of the installer matches the Fedora brand. (roshi, 17:10:51)

  11. (1404918) Proposal: force C.UTF-8 when Python 3 is run under the C locale (roshi, 17:11:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1404918 (roshi, 17:11:03)
    2. Proposed Freeze Exceptions, python3, ASSIGNED (roshi, 17:11:06)
    3. FESCo has declared this an FE, so we'll update the bug to reflect that (roshi, 17:11:40)

  12. (1431400) ostrees are not building in f26 (roshi, 17:12:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1431400 (roshi, 17:12:08)
    2. Proposed Freeze Exceptions, rpm-ostree, MODIFIED (roshi, 17:12:08)
    3. AGREED: - AcceptedFreezeException - RHBZ#1431400 - We should pull in a fix so that Atomic ostree's get build properly for Fedora Atomic. (roshi, 17:18:25)

  13. Review of accepted blockers and FE's for Alpha (roshi, 17:20:49)
  14. (1422634) selinux prevents kernel modules from loading (roshi, 17:20:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1422634 (roshi, 17:20:58)
    2. Accepted Blocker, selinux-policy, ON_QA (roshi, 17:20:58)
    3. looks like we have a fix for this and should be ready for Go/No-Go decision on Thursday (20170316) (roshi, 17:25:49)

  15. (1430920) gnome-software graphical updates fail, pk-offline-update: no trigger, exiting (roshi, 17:26:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1430920 (roshi, 17:26:31)
    2. Proposed Blocker, PackageKit, NEW (roshi, 17:26:33)
    3. AGREED: - AcceptedBlocker - RHBZ#1430920 - This is a clear violation of the following criterion: "The installed system must be able to download and install updates with the default graphical package manager in all release-blocking desktops." (roshi, 17:31:48)

  16. (1405539) changing the default keyboard layout changes also disk decryption in plymouth, but only after kernel update, long after (roshi, 17:32:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1405539 (roshi, 17:32:23)
    2. Proposed Blocker, plymouth, NEW (roshi, 17:32:25)
    3. AGREED: - RejectedBlocker - RHBZ#1405539 - While this is a severe bug we'd love to have a fix for, the problem has existed for multiple releases and is exceptionally non-trivial to fix. (roshi, 17:44:11)

  17. Open Floor (roshi, 17:44:17)


Meeting ended at 17:52:46 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. roshi (203)
  2. adamw (94)
  3. sgallagh (32)
  4. pwhalen (23)
  5. Southern_Gentlem (22)
  6. dustymabe (21)
  7. pschindl_wfh (10)
  8. mkolman_ (10)
  9. zodbot (8)
  10. kparal (4)
  11. sfix (2)
  12. cmurf (2)


Generated by MeetBot 0.1.4.