#fedora-blocker-review: F27-blocker-review

Meeting started by adamw at 16:01:19 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:20)
  2. Introduction (adamw, 16:08:15)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:08:15)
    2. We'll be following the process outlined at: (adamw, 16:08:16)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:08:16)
    4. The bugs up for review today are available at: (adamw, 16:08:17)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:08:19)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:08:21)
    7. https://fedoraproject.org/wiki/Fedora_27_Alpha_Release_Criteria (adamw, 16:08:25)
    8. https://fedoraproject.org/wiki/Fedora_27_Beta_Release_Criteria (adamw, 16:08:27)
    9. https://fedoraproject.org/wiki/Fedora_27_Final_Release_Criteria (adamw, 16:08:29)
    10. For the Fedora 27 cycle there is no Alpha release; the first milestone is Beta. Alpha criteria are all in effect for Beta, until we change the criteria layout on the wiki. (adamw, 16:09:00)
    11. 8 Proposed Blockers (Beta), 5 Proposed Blockers (Final) (adamw, 16:09:50)
    12. 3 Accepted Blockers (Beta), 1 Accepted Blocker (Final) (adamw, 16:10:07)
    13. kparal will secretarialize (adamw, 16:14:59)
    14. starting with the proposed Beta blockers (adamw, 16:15:12)

  3. (1439411) AttributeError: 'LUKS' object has no attribute 'hasKey' (adamw, 16:15:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1439411 (adamw, 16:15:19)
    2. Proposed Blocker, anaconda, MODIFIED (adamw, 16:15:19)
    3. current openQA test results indicate this is fixed, we will close it (adamw, 16:18:29)

  4. (1470552) Kickstarted Fedora 26 installation always uses public repositorys (adamw, 16:19:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1470552 (adamw, 16:19:10)
    2. Proposed Blocker, anaconda, MODIFIED (adamw, 16:19:10)
    3. AGREED: 1470552 - RejectedBlocker (Beta) - this doesn't seem like a clear enough violation to block the Beta on. We considered it might be appropriate as a Final blocker, but decided not to make a decision on that as the fix is imminent in any case (adamw, 16:24:45)

  5. (1477916) Workstation boot.iso is 1.8 GB, seems to be ostree iso (adamw, 16:24:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1477916 (adamw, 16:24:54)
    2. Proposed Blocker, distribution, NEW (adamw, 16:24:54)
    3. AGREED: 1477916 - punt (delay decision) - there was a general feeling in favour of this being a blocker, but it does not clearly violate any existing criteria. we're delaying the decision until there are more folks to help come up with a plan, including release engineering (adamw, 16:52:30)

  6. (1483159) Server deployment still sets up Firefox extension, this is no longer necessary and broken on F27+ (adamw, 16:52:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1483159 (adamw, 16:52:45)
    2. Proposed Blocker, freeipa, NEW (adamw, 16:52:45)
    3. AGREED: 1483159 - AcceptedBlocker (Beta) - breaks deployment of FreeIPA servers, clear violation of Alpha criterion "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started..." for the domain controller role (adamw, 16:56:56)

  7. (1479825) Install of Fedora 27 Rawhide 20170804.n.1 Workstation live image fails with the following error - boot loader install failed (adamw, 16:57:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1479825 (adamw, 16:57:05)
    2. Proposed Blocker, grub2, MODIFIED (adamw, 16:57:05)
    3. AGREED: 1479825 - AcceptedBlocker (Beta) - this seems to cause all BIOS live installs to fail, which is a clear violation of several "must be able to complete an installation" Alpha criteria for the Workstation and KDE live images (adamw, 17:01:40)

  8. (1464556) [abrt] PackageKit: pk_backend_refresh_cache_thread(): packagekitd killed by signal 11 (adamw, 17:02:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1464556 (adamw, 17:02:03)
    2. Proposed Blocker, PackageKit, ASSIGNED (adamw, 17:02:03)
    3. 1464556 - it looks like this is resolved already; indeed latest openQA test did not run into the crash (though it failed due to a needle mismatch). we will close this as a duplicate of the resolved bug (adamw, 17:08:27)

  9. (1480929) SELinux is preventing journalctl from 'map' accesses on the file /var/log/journal/e0215049b3ad4b45be988a3894bb0931/system@000555eff2a070fa-00d74fe76412519e.journal~. (adamw, 17:09:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1480929 (adamw, 17:09:36)
    2. Proposed Blocker, selinux-policy, POST (adamw, 17:09:37)
    3. 1480929 - testing indicates that selinux-policy 3.13.1-272 resolves this denial, so we will close this bug as fixed (adamw, 17:15:05)

  10. (1483170) 'map' denial for comm 'ns-slapd' path '/run/dirsrv/slapd-DOMAIN-LOCAL.stats' (breaks FreeIPA deployment) (adamw, 17:16:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1483170 (adamw, 17:16:51)
    2. Proposed Blocker, selinux-policy-targeted, NEW (adamw, 17:16:51)
    3. AGREED: 1483170 - AcceptedBlocker (Beta) - breaks deployment of FreeIPA servers, clear violation of Alpha criterion "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started..." for the domain controller role (adamw, 17:21:00)
    4. that's all the proposed Beta blockers, moving onto proposed Final blockers (adamw, 17:21:44)
    5. all 5 proposed Final blockers are SELinux denials encountered during boot of several release-blocking package sets (adamw, 17:23:49)
    6. to speed things up, we will vote on them as a block (adamw, 17:23:57)
    7. AGREED: 1451377 1451379 1451381 1451385 1459081 - all AcceptedBlocker (Final) - clear violations of Final criterion "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop." (adamw, 17:28:14)
    8. https://bugzilla.redhat.com/show_bug.cgi?id=1438495 was just marked as an accepted blocker by Dennis back in April, i will ping him about that one (adamw, 17:29:37)

  11. Open floor (adamw, 17:33:32)


Meeting ended at 19:24:12 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (174)
  2. kparal (66)
  3. roshi (35)
  4. pschindl_ (9)
  5. zodbot (6)
  6. mboddu (4)
  7. nirik (1)
  8. satellit (1)


Generated by MeetBot 0.1.4.