#fedora-blocker-review: F27-blocker-review

Meeting started by adamw at 16:01:33 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:33)
  2. Introduction (adamw, 16:09:37)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:09:37)
    2. We'll be following the process outlined at: (adamw, 16:09:38)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:09:39)
    4. The bugs up for review today are available at: (adamw, 16:09:39)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:09:43)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:09:45)
    7. https://fedoraproject.org/wiki/Fedora_27_Alpha_Release_Criteria (adamw, 16:09:47)
    8. https://fedoraproject.org/wiki/Fedora_27_Beta_Release_Criteria (adamw, 16:09:49)
    9. https://fedoraproject.org/wiki/Fedora_27_Final_Release_Criteria (adamw, 16:09:51)
    10. for Beta we have: (adamw, 16:13:44)
    11. 9 Proposed Blockers (adamw, 16:13:46)
    12. 4 Accepted Blockers (adamw, 16:13:46)
    13. 7 Proposed Freeze Exceptions (adamw, 16:13:52)
    14. for Final we have: (adamw, 16:13:55)
    15. 3 Proposed Blockers (adamw, 16:14:03)
    16. 7 Accepted Blockers (adamw, 16:14:03)
    17. kparal to secretarialize (adamw, 16:18:07)

  3. (1489144) UEFI installs crash during bootloader installation: "TypeError: must be str, not method" (adamw, 16:18:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1489144 (adamw, 16:18:32)
    2. Proposed Blocker, anaconda, VERIFIED (adamw, 16:18:33)
    3. AGREED: 1489144 - AcceptedBlocker (Beta) - clearly violates several "must be able to complete an install" criteria, in the case of a UEFI install (adamw, 16:24:30)

  4. (1477916) Workstation boot.iso is 1.8 GB, seems to be ostree iso (adamw, 16:24:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1477916 (adamw, 16:24:40)
    2. Proposed Blocker, distribution, NEW (adamw, 16:24:40)
    3. https://pagure.io/pungi-fedora/pull-request/347 was merged 3 days ago (adamw, 16:25:49)
    4. AGREED: 1477916 - drop nomination - the Workstation ostree installer image has never been built in an F27 compose; until it is, this bug cannot happen to one. So we're dropping the nomination for now, but will immediately re-nominate it if the bug does start affecting F27 composes (adamw, 16:34:10)

  5. (1489164) Fedora 27 Beta backgrounds must be different from Fedora 26 (adamw, 16:34:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1489164 (adamw, 16:34:19)
    2. Proposed Blocker, distribution, NEW (adamw, 16:34:19)
    3. AGREED: 1489164 - AcceptedBlocker (Beta) - clearly violates Alpha criterion "The default desktop background must be different from that of the last two stable releases." (adamw, 16:36:48)

  6. (1456293) [abrt] gnome-shell: js::GCMethods<JSObject*>::needsPostBarrier(): gnome-shell killed by signal 11 (adamw, 16:37:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1456293 (adamw, 16:37:17)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:37:17)
    3. AGREED: 1456293 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - this is bad if you hit it, but the FAF numbers and upstream bug analysis indicate not many people do actually hit it; thus the breadth of impact isn't significant enough for this to block the Beta. We'll accept a fix if it's targeted and arrives in good time for testing (adamw, 16:44:10)

  7. (1490072) Program terminated with signal SIGSEGV, Segmentation fault. #0 0x00007f16279aa68f in _cogl_boxed_value_set_x () from /usr/lib64/mutter/libmutter-cogl-1.so (adamw, 16:44:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1490072 (adamw, 16:44:23)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:44:23)
    3. AGREED: 1490072 - punt (delay decision) - we don't have quite enough information on how common this crash is to make a decision yet; we'd like to ask folks to test launching VMs in virt-manager on F27 and see if this affects many people (adamw, 16:55:17)

  8. (1490287) dnf system-upgrade fails due to grub2/grub2-tools (adamw, 16:55:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1490287 (adamw, 16:55:45)
    2. Proposed Blocker, grub2, NEW (adamw, 16:55:46)
    3. https://koji.fedoraproject.org/koji/buildinfo?buildID=967139 fixes this (adamw, 16:58:59)
    4. AGREED: 1490287 - AcceptedBlocker (Beta) - even if you can upgrade with --allowerasing, grub2-pc will not be installed after upgrade, violating the "The upgraded system must include all packages that would be present on the system after a default installation from install media" clause of the upgrade criterion (adamw, 17:09:44)

  9. (1475570) Rescue mode fails while trying to access LVM volumes from existing install (adamw, 17:09:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1475570 (adamw, 17:09:55)
    2. Proposed Blocker, lvm2, NEW (adamw, 17:09:55)
    3. AGREED: 1475570 - AcceptedBlocker (Beta) - seems a clear violation of "The rescue mode of the installer must start successfully and be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations" (adamw, 17:20:07)

  10. (1489862) There is FW Raid set, but there is no /dev/md* device (adamw, 17:21:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1489862 (adamw, 17:21:25)
    2. Proposed Blocker, selinux-policy, MODIFIED (adamw, 17:21:25)
    3. AGREED: 1489862 - AcceptedFreezeException (Beta), punt (delay decision) on blocker status - it's not 100% clear yet if the SELinux denials are the only problem here, so we will delay the blocker vote until we have confirmation on that. however, we think it at least makes sense to grant the SELinux fixes a freeze exception immediately (adamw, 17:33:03)

  11. (1488707) [abrt] tracker: g_str_hash(): tracker-extract killed by signal 11 (adamw, 17:34:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1488707 (adamw, 17:34:24)
    2. Proposed Blocker, tracker, NEW (adamw, 17:34:24)
    3. AGREED: 1488707 - RejectedBlocker (Beta) - for now, there is no indication this affects anyone besides Mikhail. We'd need information indicating this bug will hit a somewhat wider range of folks to accept it as a blocker (adamw, 17:48:01)
    4. AGREED: 1488707 - punt (delay decision) on FreezeException status - we don't have enough information on the cause, prevalence or fix for this yet to make an FE determination (adamw, 17:51:55)
    5. moving onto proposed Beta freeze exceptions (adamw, 17:52:35)

  12. (1489124) Downgrade to version 6 for Fedora 27 (adamw, 17:52:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1489124 (adamw, 17:52:39)
    2. Proposed Freeze Exceptions, ImageMagick, ON_QA (adamw, 17:52:39)
    3. AGREED: 1489124 - AcceptedFreezeException (Beta) - this is required to fulfil a FESCo decision (https://pagure.io/fesco/issue/1766) (adamw, 17:59:39)

  13. (1489285) abrt-action-find-bodhi-update failed when reporting a bug on xfce (adamw, 17:59:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1489285 (adamw, 17:59:53)
    2. Proposed Freeze Exceptions, abrt, MODIFIED (adamw, 17:59:53)
    3. AGREED: 1489285 - AcceptedFreezeException (Beta) - this is clearly desirable functionality and affects live images (so cannot be fully fixed with an update) (adamw, 18:06:11)

  14. (1456293) [abrt] gnome-shell: js::GCMethods<JSObject*>::needsPostBarrier(): gnome-shell killed by signal 11 (adamw, 18:06:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1456293 (adamw, 18:06:37)
    2. Proposed Freeze Exceptions, gnome-shell, NEW (adamw, 18:06:37)
    3. we already made this accepted FE earlier (adamw, 18:07:12)

  15. (1489184) ipa-dnskeysyncd fails in a loop in Fedora 27 ("pyasn1.error.PyAsn1Error: Uninitialized ASN.1 value ("__str__" attribute looked up)") (adamw, 18:07:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1489184 (adamw, 18:07:44)
    2. Proposed Freeze Exceptions, python-ldap, NEW (adamw, 18:07:44)
    3. AGREED: 1489184 - AcceptedFreezeException - this is a significant bug in a component shipped on the server DVD; it doesn't violate release criteria but it'd be good to have it fixed (adamw, 18:14:41)

  16. (1489604) AArch64 installations fail to boot using shimaa64.efi - 'Error reported: Unsupported' (adamw, 18:14:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1489604 (adamw, 18:14:51)
    2. Proposed Freeze Exceptions, shim-signed, NEW (adamw, 18:14:51)
    3. AGREED: 1489604 - AcceptedFreezeException (Beta) - this breaks UEFI installs on aarch64, a non-release-blocking arch; obviously can't be fixed with an update, so clearly worth an FE (adamw, 18:17:06)
    4. moving onto proposed final blockers (adamw, 18:19:10)

  17. (1490351) New version of gjs is available: 1.49.92 (adamw, 18:19:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1490351 (adamw, 18:19:40)
    2. Proposed Blocker, gjs, NEW (adamw, 18:19:40)
    3. AGREED: 1490351 - RejectedBlocker (Final) - this bug is simply about the availability of a new version, that is not a reasonable candidate for blocker status. We will ask reporters to nominate actual functional bugs that are fixed by the new version as blockers, and we'll evaluate those on their merits (adamw, 18:32:53)

  18. (1146232) no VM networking; 'default' network in the VM conflicts with 'default' network on the host (adamw, 18:33:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1146232 (adamw, 18:33:01)
    2. Proposed Blocker, libvirt, ASSIGNED (adamw, 18:33:01)
    3. AGREED: 1146232 - RejectedBlocker (Final), #1164492 - AcceptedBlocker (Final) - we think the problem here constitutes a blocker, but as with previous releases, we will make #1164492 the blocker as we may fix it with a short-term workaround rather than a real fix (again) (adamw, 18:57:27)

  19. (1485021) rawhide .treeinfo is missing [images-xen] section. (adamw, 18:57:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1485021 (adamw, 18:57:35)
    2. Proposed Blocker, pungi, NEW (adamw, 18:57:35)
    3. AGREED: 1485021 - RejectedBlocker (Final) - this is specific to i686, which is no longer a release-blocking arch. (adamw, 19:04:46)
    4. accepted blockers don't really need looking at, I'm tracking those (adamw, 19:05:17)

  20. Open floor (adamw, 19:05:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1484086 (kalev, 19:06:53)
    2. kalev's 1484086 looks like a good FE candidate, but we'll delay voting on it till there's a clear fix proposal (adamw, 19:17:31)


Meeting ended at 19:24:35 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (347)
  2. kparal (145)
  3. kalev (74)
  4. jkurik (32)
  5. pwhalen (29)
  6. Amita (11)
  7. zodbot (7)
  8. mkolman (4)
  9. nb (2)


Generated by MeetBot 0.1.4.