#fedora-blocker-review: F27-blocker-review

Meeting started by pschindl at 16:00:23 UTC (full logs).

Meeting summary

  1. Roll Call (pschindl, 16:00:27)
  2. Introduction (pschindl, 16:04:49)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (pschindl, 16:05:01)
    2. We'll be following the process outlined at: (pschindl, 16:05:03)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (pschindl, 16:05:05)
    4. The bugs up for review today are available at: (pschindl, 16:05:19)
    5. http://qa.fedoraproject.org/blockerbugs/current (pschindl, 16:05:21)
    6. The criteria for release blocking bugs can be found at: (pschindl, 16:05:23)
    7. https://fedoraproject.org/wiki/Fedora_27_Alpha_Release_Criteria (pschindl, 16:05:25)
    8. https://fedoraproject.org/wiki/Fedora_27_Beta_Release_Criteria (pschindl, 16:05:31)
    9. https://fedoraproject.org/wiki/Fedora_27_Final_Release_Criteria (pschindl, 16:05:34)
    10. 4 Proposed Blockers (pschindl, 16:06:21)
    11. 9 Accepted Blockers (pschindl, 16:06:23)
    12. 0 Accepted 0-day Blockers (pschindl, 16:06:25)
    13. 0 Accepted Previous Release Blockers (pschindl, 16:06:30)
    14. 9 Proposed Freeze Exceptions (pschindl, 16:06:32)
    15. 4 Accepted Freeze Exceptions (pschindl, 16:06:34)

  3. (1477916) Workstation boot.iso is 1.8 GB, seems to be ostree iso (pschindl, 16:07:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1477916 (pschindl, 16:07:20)
    2. Proposed Blocker, distribution, MODIFIED (pschindl, 16:07:22)
    3. https://kojipkgs.fedoraproject.org/compose/branched/latest-Fedora-27/compose/Workstation/x86_64/os/images/ (jkurik, 16:10:01)
    4. AGREED: - 1477916 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) AcceptedBlocker (Final) - People can easily end up installing ostree edition instead of standard edition by accident, which breaks user expectations of how installation works (pschindl, 16:16:05)

  4. (1490832) dnf system-upgrade: dnf.exceptions.MarkingError: no package matched (pschindl, 16:16:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1490832 (pschindl, 16:16:45)
    2. Proposed Blocker, dnf-plugins-extras, NEW (pschindl, 16:16:47)
    3. AGREED: - 1490832 - AcceptedBlocker (beta) - This bug violates the beta criterion: "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed." (pschindl, 16:22:46)

  5. (1492036) system-upgrade tried to connect to online mirrors during upgrade (pschindl, 16:23:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1492036 (pschindl, 16:23:09)
    2. Proposed Blocker, dnf-plugin-system-upgrade, NEW (pschindl, 16:23:11)
    3. AGREED: - 1492036 - punt - There is just single person who reproduced this and bug 1490832 prevents us to test it. So we will wait until that one is solved and investigate (pschindl, 16:31:03)

  6. (1491053) Firefox reports insecure TLS configuration when visiting FreeIPA web UI after standard server deployment (pschindl, 16:31:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1491053 (pschindl, 16:31:25)
    2. Proposed Blocker, freeipa, ASSIGNED (pschindl, 16:31:27)
    3. AGREED: - 1491053 - RejectedBlocker (beta) AcceptedFreezeException (beta) AcceptedBlocker (final) - There should be an easy workaround - just allow the invalid cert in Firefox. For final we'll block because this bug violates the criterion: "The FreeIPA configuration web UI must be available and allow at least basic configuration of user accounts and permissions " (pschindl, 16:52:37)

  7. (1491045) AArch64 install fails with 'The package 'grub2' is required for this installation.' (pschindl, 16:55:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1491045 (pschindl, 16:55:10)
    2. Proposed Freeze Exceptions, anaconda, NEW (pschindl, 16:55:12)
    3. AGREED: - 1491049 - AcceptedFreezeException - This bug violates the criterion "When using a dedicated installer image, the installer must be able to complete an installation" for AArch64 architecture. (pschindl, 16:58:49)

  8. (1490505) cloud-init fails when calling `xfs_growfs /dev/mapper/atomicos-root` on Fedora Atomic Host (pschindl, 16:59:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1490505 (pschindl, 16:59:17)
    2. Proposed Freeze Exceptions, cloud-init, NEW (pschindl, 16:59:19)
    3. AGREED: - 1490505 - AcceptedFreezeException - This seems to be small change which will fix cloud-init for xfs filesystems (pschindl, 17:06:06)

  9. (1492282) Include GNOME 3.26.0 in Fedora 27 Beta (pschindl, 17:06:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1492282 (pschindl, 17:06:31)
    2. Proposed Freeze Exceptions, distribution, NEW (pschindl, 17:06:33)
    3. AGREED: - 1492282 - AcceptedFreezeException - The beta requirements for gnome aren't big and there aren't any regressions right now. (pschindl, 17:12:59)

  10. (1462381) Systems with qxl/SPICE and graphical boot enabled fail to boot with kernel 4.12 (pschindl, 17:13:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1462381 (pschindl, 17:13:13)
    2. Proposed Freeze Exceptions, kernel, ASSIGNED (pschindl, 17:13:15)
    3. AGREED: - 1462381 - AcceptedFreezeException - Because all default VMs are affected, it would be great to have this solved in Beta. (pschindl, 17:21:06)

  11. (1491316) akonadi: Plugin pvio_socket could not be loaded: not initialized (pschindl, 17:21:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1491316 (pschindl, 17:21:21)
    2. Proposed Freeze Exceptions, kf5-akonadi-server, NEW (pschindl, 17:21:23)
    3. AGREED: - 1491316 - AcceptedFreezeException punt (final blocker) - This bug seems to be important for KDE spin functionality but we need more information for making this final blocker. (pschindl, 17:30:53)

  12. (1492197) grub2-tools* are missing from the boot.iso (pschindl, 17:31:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1492197 (pschindl, 17:31:20)
    2. Proposed Freeze Exceptions, lorax, NEW (pschindl, 17:31:22)
    3. AGREED: - 1492197 - AcceptedFreezeException - This is small change which could help some people and shouldn't affect installation. (pschindl, 17:40:29)

  13. (1490632) Service tries to start but fails in qemu VM (pschindl, 17:40:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1490632 (pschindl, 17:40:40)
    2. Proposed Freeze Exceptions, rng-tools, NEW (pschindl, 17:40:42)
    3. AGREED: - 1490632 - AcceptedFreezeException - It's good thing to not have failing services on vms (pschindl, 17:46:47)

  14. (1490668) Fedora-SoaS-Live-x86_64-27-20170911.n.0.iso does not login to liveuser (pschindl, 17:47:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1490668 (pschindl, 17:47:09)
    2. Proposed Freeze Exceptions, selinux-policy, MODIFIED (pschindl, 17:47:11)
    3. AGREED: - 1490668 - AcceptedFreezeException - This bug would be a blocker, because SoaS is secondary DE it is accepted as FE (pschindl, 17:53:26)

  15. (1488707) tracker-extract crashes when processing virtual elements (pschindl, 17:53:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1488707 (pschindl, 17:53:42)
    2. Proposed Freeze Exceptions, tracker-miners, NEW (pschindl, 17:53:44)
    3. AGREED: - 1488707 - AcceptedFreezeException - The fix seems to be small and shouldn't affect system much (pschindl, 17:58:39)

  16. (1491333) kickstart installations using autopart fail with 'Kickstart insufficient' (pschindl, 18:02:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1491333 (pschindl, 18:02:08)
    2. Accepted Blocker, anaconda, MODIFIED (pschindl, 18:02:10)
    3. build is already in updates-testing and needs karma and testing (pschindl, 18:03:48)

  17. (1489164) Fedora 27 Beta backgrounds must be different from Fedora 26 (pschindl, 18:04:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1489164 (pschindl, 18:04:02)
    2. Accepted Blocker, distribution, NEW (pschindl, 18:04:04)
    3. New wallpapers should be on place, we have to test it (especially KDE). (pschindl, 18:06:35)

  18. (1490762) Ipa-server-install update dse.ldif with wrong SELinux context (pschindl, 18:06:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1490762 (pschindl, 18:06:57)
    2. Accepted Blocker, freeipa, ON_QA (pschindl, 18:06:59)
    3. There is update which should solve this bug. Needs testing (pschindl, 18:08:14)

  19. (1491056) FreeIPA enrolment via kickstart fails (pschindl, 18:08:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1491056 (pschindl, 18:08:29)
    2. Accepted Blocker, freeipa, ON_QA (pschindl, 18:08:31)
    3. There is update which should solve this bug. Needs testing. (pschindl, 18:09:18)
    4. ACTION: pschindl and sumantrom[m] to test freeipa updates (pschindl, 18:10:49)

  20. (1487305) Raspberry Pi 3: run-initial-setup hangs (pschindl, 18:11:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1487305 (pschindl, 18:11:06)
    2. Accepted Blocker, kernel, ON_QA (pschindl, 18:11:08)
    3. ACTION: pschindl and sumantrom[m] to test fix for 1487305 (pschindl, 18:12:24)
    4. There is a fix and needs testing (pschindl, 18:12:44)

  21. (1475570) Rescue mode fails while trying to access LVM volumes from existing install (pschindl, 18:12:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1475570 (pschindl, 18:12:56)
    2. Accepted Blocker, lvm2, NEW (pschindl, 18:12:58)
    3. ACTION: lbrabec to ask lvm and/or anaconda team what's the status of this bug (pschindl, 18:19:44)
    4. nothing changed yet, lbrabec will poke lvm team about this (pschindl, 18:20:36)

  22. (1490072) Program terminated with signal SIGSEGV, Segmentation fault. #0 0x00007f16279aa68f in _cogl_boxed_value_set_x () from /usr/lib64/mutter/libmutter-cogl-1.so (pschindl, 18:20:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1490072 (pschindl, 18:20:48)
    2. Accepted Blocker, mutter, ON_QA (pschindl, 18:20:50)
    3. there is update. Needs testing (pschindl, 18:21:59)

  23. (1170803) calls e2fsck on all ext volumes, provides no status indicator, and hangs indefinitely if e2fsck doesn't exit (pschindl, 18:22:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1170803 (pschindl, 18:22:15)
    2. Accepted Blocker, python-blivet, ON_QA (pschindl, 18:22:17)
    3. There is a fix, but we have to find someone with affected system to test the update (pschindl, 18:24:19)

  24. (1491508) FreeIPA server deployment fails with SELinux in enforcing mode, despite no obvious denials (pschindl, 18:24:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1491508 (pschindl, 18:24:39)
    2. Accepted Blocker, selinux-policy, MODIFIED (pschindl, 18:24:41)
    3. There seems to be another denials so this should go back to assigned (pschindl, 18:37:06)

  25. Open floor (pschindl, 18:37:18)


Meeting ended at 18:41:33 UTC (full logs).

Action items

  1. pschindl and sumantrom[m] to test freeipa updates
  2. pschindl and sumantrom[m] to test fix for 1487305
  3. lbrabec to ask lvm and/or anaconda team what's the status of this bug


Action items, by person

  1. pschindl
    1. pschindl and sumantrom[m] to test freeipa updates
    2. pschindl and sumantrom[m] to test fix for 1487305
  2. sumantrom[m]
    1. pschindl and sumantrom[m] to test freeipa updates
    2. pschindl and sumantrom[m] to test fix for 1487305


People present (lines said)

  1. pschindl (190)
  2. kparal (127)
  3. jkurik (51)
  4. sumantrom[m] (45)
  5. kalev (33)
  6. frantisekz (33)
  7. dominicpg (20)
  8. zodbot (10)
  9. tflink (1)


Generated by MeetBot 0.1.4.