#fedora-blocker-review: F35-blocker-review

Meeting started by adamw at 16:00:31 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:32)
  2. Introduction (adamw, 16:10:31)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:10:49)
    2. We'll be following the process outlined at: (adamw, 16:10:50)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:10:50)
    4. The bugs up for review today are available at: (adamw, 16:10:52)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:10:57)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:11:02)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:11:06)
    8. https://fedoraproject.org/wiki/Fedora_35_Beta_Release_Criteria (adamw, 16:11:11)
    9. https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria (adamw, 16:11:16)
    10. for Beta, we have: (adamw, 16:11:24)
    11. 1 Proposed Blockers (adamw, 16:11:33)
    12. 3 Accepted Blockers (adamw, 16:11:40)
    13. 1 Proposed Freeze Exceptions (adamw, 16:11:45)
    14. 6 Accepted Freeze Exceptions (adamw, 16:11:46)
    15. for Final, we have: (adamw, 16:11:58)
    16. 6 Proposed Blockers (adamw, 16:12:01)
    17. 2 Accepted Blockers (adamw, 16:12:04)
    18. 1 Accepted Freeze Exceptions (adamw, 16:12:07)
    19. coremodule will secretarialize (adamw, 16:12:19)

  3. Proposed Beta blocker (adamw, 16:13:04)
  4. (2005625) Very slow to proceed past password page in initial setup (adamw, 16:13:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2005625 (adamw, 16:13:19)
    2. https://pagure.io/fedora-qa/blocker-review/issue/463 (adamw, 16:13:24)
    3. Proposed Blocker, gnome-initial-setup, NEW (adamw, 16:13:31)
    4. Ticket vote: BetaBlocker (+0,0,-4) (-kparal, -frantisekz, -bcotton, -geraldosimiao) (adamw, 16:13:32)
    5. Ticket vote: FinalBlocker (+4,0,-0) (+kparal, +frantisekz, +bcotton, +geraldosimiao) (adamw, 16:13:34)
    6. Ticket vote: BetaFreezeException (+4,0,-0) (+kparal, +frantisekz, +bcotton, +geraldosimiao) (adamw, 16:13:38)
    7. AGREED: 2005625 - RejectedBlocker (Beta) AcceptedBlocker (Final) AcceptedFreezeException (Beta) - this is accepted as a Final blocker as a conditional violation of criterion "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system." We don't think it's bad enough to block Beta, but it is bad enough to warrant a freeze exception (adamw, 16:26:08)

  5. Proposed Final blockers (adamw, 16:27:02)
    1. 2005625 was the only proposed Beta FE and we covered it, so moving onto Final. (adamw, 16:27:16)

  6. (2004565) The default keyring is created with an unknown password, can't be unlocked (adamw, 16:29:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2004565 (adamw, 16:29:06)
    2. https://pagure.io/fedora-qa/blocker-review/issue/460 (adamw, 16:29:09)
    3. Proposed Blocker, gnome-initial-setup, NEW (adamw, 16:29:15)
    4. Ticket vote: FinalBlocker (+3,0,-0) (+kparal, +geraldosimiao, +catanzaro) (adamw, 16:29:18)
    5. AGREED: 2004565 - AcceptedBlocker (Final) - we believe this has the same cause as 2005625, but there's no harm in accepting it separately in case it doesn't. accepted as a violation of "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test." (adamw, 16:36:22)

  7. (1950669) [abrt] gnome-settings-daemon: get_current_screen_saver_status(): gsd-usb-protection killed by SIGSEGV (adamw, 16:36:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1950669 (adamw, 16:36:50)
    2. https://pagure.io/fedora-qa/blocker-review/issue/412 (adamw, 16:37:03)
    3. Proposed Blocker, gnome-settings-daemon, NEW (adamw, 16:37:03)
    4. AGREED: 1950669 - RejectedBlocker (Final) - we believe at this point other bugs have been fixed such that this crash will not usually be encountered, and so there is no need for it to be a blocker or FE issue. (adamw, 16:46:53)

  8. (2004604) a removed package looks still installed in gnome-software, can't be installed again until reboot (adamw, 16:47:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2004604 (adamw, 16:47:08)
    2. https://pagure.io/fedora-qa/blocker-review/issue/457 (adamw, 16:47:13)
    3. Proposed Blocker, gnome-software, NEW (adamw, 16:47:19)
    4. Ticket vote: FinalBlocker (+3,1,-0) (+kparal, +catanzaro, +geraldosimiao, sgallagh) (adamw, 16:47:27)
    5. AGREED: 2004604 - AcceptedBlocker (Final) - this is accepted as a conditional violation of "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops", in the case of trying to reinstall a previously removed package (adamw, 16:54:49)

  9. (2005343) System repositories can be disabled by clicking on the row (adamw, 16:55:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2005343 (adamw, 16:55:04)
    2. https://pagure.io/fedora-qa/blocker-review/issue/461 (adamw, 16:55:16)
    3. Proposed Blocker, gnome-software, NEW (adamw, 16:55:17)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+geraldosimiao) (adamw, 16:55:20)
    5. AGREED: 2005343 - RejectedBlocker (Final) - this seems like an unfortunate behaviour and it'd be good to fix it, but it's not really serious enough to violate the "basic functionality" criterion or any others (adamw, 17:02:41)

  10. (1995439) cannot run F34 or F33 toolboxes in F35 or C9S: Error: invalid entry point PID of container (adamw, 17:02:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1995439 (adamw, 17:02:59)
    2. https://pagure.io/fedora-qa/blocker-review/issue/447 (adamw, 17:02:59)
    3. Proposed Blocker, toolbox, NEW (adamw, 17:03:05)
    4. Ticket vote: FinalBlocker (+0,0,-2) (-kparal, -geraldosimiao) (adamw, 17:03:16)
    5. AGREED: 1995439 - RejectedBlocker (Final) - this does not violate any criteria. it's significant primarily for user-facing ostree builds, and none of those are prelease-blocking yet. (adamw, 17:13:42)

  11. Accepted Beta Blockers (adamw, 17:14:06)
    1. a reminder - we are checking status here, not voting (unless we decide to re-vote one) (adamw, 17:14:19)

  12. (1999321) DNS often stops resolving properly after FreeIPA server upgrade to Fedora 35 or 36 (adamw, 17:14:41)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1999321 (adamw, 17:14:46)
    2. https://pagure.io/fedora-qa/blocker-review/issue/419 (adamw, 17:15:04)
    3. Accepted Blocker, freeipa, NEW (adamw, 17:15:05)
    4. we are currently working to try and establish the parameters of this issue, and whether it is specific to fedora infra's network environment. (adamw, 17:17:38)

  13. (2000756) error: ../../grub-core/loader/arm64/linux.c:326:Invalid PE optional header magic. (adamw, 17:19:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2000756 (adamw, 17:19:34)
    2. https://pagure.io/fedora-qa/blocker-review/issue/464 (adamw, 17:19:38)
    3. Accepted Blocker, grub2, ON_QA (adamw, 17:19:45)
    4. fix for this is in the queue, so shouldn't be any problems there (adamw, 17:19:52)

  14. (1989726) [abrt] gnome-shell: cogl_texture_get_gl_texture(): gnome-shell killed by SIGSEGV (adamw, 17:20:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1989726 (adamw, 17:20:33)
    2. https://pagure.io/fedora-qa/blocker-review/issue/399 (adamw, 17:20:38)
    3. Accepted Blocker, mesa, NEW (adamw, 17:20:41)
    4. from discussion in the bug, Karol (who's taking care of it) says there's potentially a way to address it but it's not trivial. I gave him the timeframe we're working with in https://bugzilla.redhat.com/show_bug.cgi?id=1989726#c40 (adamw, 17:21:38)

  15. Open floor (adamw, 17:23:19)
    1. please check https://openqa.fedoraproject.org/testcase_stats/35/ for tests at Basic or Beta milestone that have not been run recently and help run them! (adamw, 17:24:59)


Meeting ended at 17:30:48 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (169)
  2. bcotton (28)
  3. frantisekz (21)
  4. geraldosimiao (17)
  5. pwhalen (17)
  6. zodbot (16)
  7. coremodule (6)


Generated by MeetBot 0.3.