#fedora-blocker-review: F37-blocker-review

Meeting started by adamw at 16:00:47 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:48)
  2. Introduction (adamw, 16:07:29)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:33)
    2. We'll be following the process outlined at: (adamw, 16:07:33)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:07:33)
    4. The bugs up for review today are available at: (adamw, 16:07:56)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:07:57)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:07:57)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:07:57)
    8. https://fedoraproject.org/wiki/Fedora_37_Beta_Release_Criteria (adamw, 16:07:57)
    9. https://fedoraproject.org/wiki/Fedora_37_Final_Release_Criteria (adamw, 16:07:57)
    10. for Beta, we have: (adamw, 16:08:00)
    11. 2 Proposed Blockers (adamw, 16:08:01)
    12. 3 Proposed Freeze Exceptions (adamw, 16:08:18)
    13. 10 Accepted Freeze Exceptions (adamw, 16:08:18)
    14. for Final, we have: (adamw, 16:08:19)
    15. 3 Proposed Blockers (adamw, 16:08:19)
    16. 10 Accepted Blockers (adamw, 16:08:21)
    17. coremodule will secretarialize (adamw, 16:11:20)

  3. Proposed Beta blockers (adamw, 16:11:36)
  4. (2119305) Kernel panics during boot when laptop connected to a usb-c dock. (adamw, 16:11:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2119305 (adamw, 16:11:41)
    2. https://pagure.io/fedora-qa/blocker-review/issue/886 (adamw, 16:11:42)
    3. Proposed Blocker, kernel, NEW (adamw, 16:11:46)
    4. Ticket vote: BetaBlocker (+0,0,-4) (-chrismurphy, -gui1ty, -geraldosimiao, -sgallagh) (adamw, 16:11:48)
    5. Ticket vote: FinalBlocker (+2,1,-0) (+chrismurphy, +geraldosimiao, gui1ty) (adamw, 16:11:50)
    6. Ticket vote: BetaFreezeException (+3,0,-0) (+chrismurphy, +gui1ty, +geraldosimiao) (adamw, 16:11:50)
    7. AGREED: 2119305 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - feedback indicates this is quite hardware-specific so not broad enough to block Beta release, but worth granting an FE as it's a bad bug if you are affected and can probably affect live environments (adamw, 16:21:27)

  5. (2124127) Regression booting Fedora on rockchip devices installed on PCIe NVME drives (adamw, 16:21:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2124127 (adamw, 16:21:37)
    2. https://pagure.io/fedora-qa/blocker-review/issue/894 (adamw, 16:21:39)
    3. Proposed Blocker, uboot-tools, MODIFIED (adamw, 16:21:41)
    4. Ticket vote: BetaBlocker (+3,0,-0) (+adamwill, +pwhalen, +bcotton) (adamw, 16:21:44)
    5. AGREED: 2124127 - AcceptedBlocker (Beta) - this seems like a clear violation of Basic criterion "All release-blocking images must boot in their supported configurations...Supported ARM platforms are those listed by the ARM team", since pbrobinson says this affects devices on the supported list (adamw, 16:29:45)

  6. proposed Beta FEs (adamw, 16:30:05)
  7. (2124097) anaconda help does not launch on KDE live images since 2118832 fix landed (adamw, 16:30:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2124097 (adamw, 16:30:14)
    2. https://pagure.io/fedora-qa/blocker-review/issue/892 (adamw, 16:30:16)
    3. Proposed Freeze Exceptions, anaconda, POST (adamw, 16:30:19)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+gui1ty) (adamw, 16:30:24)
    5. Ticket vote: BetaFreezeException (+1,0,-0) (+gui1ty) (adamw, 16:30:26)
    6. AGREED: 2124097 - AcceptedFreezeException (Beta) AcceptedBlocker (Final) - this is accepted as a Final blocker as a violation of Final criterion "Any element in the installer interface(s) which is clearly intended to display 'help' text must do so correctly when activated", and as a Beta FE as a highly-visible issue that can't be fixed with an update (adamw, 16:38:54)

  8. (2120238) F37FailsToInstall: python3-ast-monitor (adamw, 16:39:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2120238 (adamw, 16:39:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/893 (adamw, 16:39:25)
    3. Proposed Freeze Exceptions, python-ast-monitor, MODIFIED (adamw, 16:39:29)
    4. AGREED: 2120238 - AcceptedFreezeException (Beta) - accepted as we usually accept FTIs to keep the repos clean and aid the upgrade path (adamw, 16:42:22)

  9. (2113774) zypper: FTBFS in Fedora rawhide/f37 (adamw, 16:42:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2113774 (adamw, 16:42:47)
    2. https://pagure.io/fedora-qa/blocker-review/issue/889 (adamw, 16:42:48)
    3. Proposed Freeze Exceptions, zypper, MODIFIED (adamw, 16:42:49)
    4. Ticket vote: BetaFreezeException (+2,1,-0) (+chrismurphy, +adamwill, gui1ty) (adamw, 16:42:49)
    5. AGREED: 2113774 - AcceptedFreezeException (Beta) - this is accepted on similar grounds as the previous bug, assuming there is some FTI issue here and not just FTBFS. adam will try to clarify before pushing stable (adamw, 17:02:49)

  10. Proposed Final blockers (adamw, 17:05:35)
  11. (2124305) The retrace server does not support Fedora 37. (adamw, 17:05:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2124305 (adamw, 17:05:46)
    2. https://pagure.io/fedora-qa/blocker-review/issue/895 (adamw, 17:05:49)
    3. Proposed Blocker, abrt, NEW (adamw, 17:05:53)
    4. Ticket vote: BetaBlocker (+1,0,-0) (+lruzicka) (adamw, 17:05:55)
    5. Ticket vote: FinalBlocker (+1,0,-0) (+lruzicka) (adamw, 17:05:56)
    6. AGREED: 2124305 - RejectedBlocker (Final) - this does not violate any of the criteria, and we have previously rejected similar bugs as blockers. No FE status is considered because the fix will be outside of the distribution (adamw, 17:20:48)

  12. (2123274) [abrt] totem: nouveau_pushbuf_data(): totem killed by SIGABRT (adamw, 17:21:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2123274 (adamw, 17:21:15)
    2. https://pagure.io/fedora-qa/blocker-review/issue/883 (adamw, 17:21:15)
    3. Proposed Blocker, xorg-x11-drv-nouveau, NEW (adamw, 17:21:15)
    4. Ticket vote: FinalBlocker (+4,0,-0) (+bcotton, +adamwill, +kevin, +lruzicka) (adamw, 17:21:16)
    5. Ticket vote: BetaFreezeException (+5,0,-0) (+bcotton, +adamwill, +kevin, +lruzicka, +zbyszek) (adamw, 17:21:19)
    6. AGREED: 2123274 - AcceptedBlocker (Final) - this is accepted as a conditional violation of the "basic functionality test" criterion, the condition being that you have affected hardware (adamw, 17:29:57)


Meeting ended at 17:45:06 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (141)
  2. cmurf (36)
  3. Penguinpee (33)
  4. lruzicka (29)
  5. geraldosimiao (25)
  6. kparal (24)
  7. bcotton (20)
  8. zodbot (17)
  9. Eighth_Doctor (5)
  10. travier (3)
  11. davdunc[m (3)
  12. osezer[m] (3)
  13. coremodule (2)
  14. sgallagh (2)
  15. jonathanspw (1)


Generated by MeetBot 0.4.