#fedora-blocker-review: F39-blocker-review

Meeting started by adamw at 16:00:18 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:19)
  2. Introduction (adamw, 16:04:01)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:04:01)
    2. We'll be following the process outlined at: (adamw, 16:04:01)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:04:01)
    4. The bugs up for review today are available at: (adamw, 16:04:03)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:04:05)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:04:07)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:04:09)
    8. https://fedoraproject.org/wiki/Fedora_39_Beta_Release_Criteria (adamw, 16:04:11)
    9. https://fedoraproject.org/wiki/Fedora_39_Final_Release_Criteria (adamw, 16:04:13)
    10. for Beta, we have: (adamw, 16:04:18)
    11. 4 Proposed Blockers (adamw, 16:04:19)
    12. 2 Accepted Blockers (adamw, 16:04:19)
    13. 3 Proposed Freeze Exceptions (adamw, 16:04:23)
    14. 22 Accepted Freeze Exceptions (adamw, 16:04:23)
    15. for Final, we have: (adamw, 16:04:27)
    16. 5 Proposed Blockers (adamw, 16:04:41)
    17. coremodule will secretarialize (adamw, 16:06:38)

  3. proposed Beta blockers (adamw, 16:07:16)
  4. (2237878) Anaconda webUI can't handle two btrfs volumes with the same name, writes into a different partition than indicated (adamw, 16:07:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2237878 (adamw, 16:07:30)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1295 (adamw, 16:07:31)
    3. Proposed Blocker, anaconda, NEW (adamw, 16:07:31)
    4. Ticket vote: BetaBlocker (+5,0,-1) (+kparal, +adamwill, +geraldosimiao, +frantisekz, +lruzicka, -lnie) (adamw, 16:07:31)
    5. Ticket vote: BetaFreezeException (+1,0,-0) (+lnie) (adamw, 16:07:33)
    6. AGREED: 2237878 - AcceptedBlocker (Beta) - this is accepted as a violation of "the installer must be able to: ... Assign mount points to existing storage volumes" on webUI. while the triggering condition is not super common, the potential consequences are catastrophic enough that we believe it should block release (adamw, 16:25:47)

  5. (2238292) blivet-gui on Workstation Live doesn't show existing btrfs subvolumes (adamw, 16:27:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2238292 (adamw, 16:27:12)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1298 (adamw, 16:27:12)
    3. Proposed Blocker, blivet-gui, NEW (adamw, 16:27:12)
    4. Ticket vote: BetaBlocker (+3,0,-1) (+kparal, +geraldosimiao, +lruzicka, -frantisekz) (adamw, 16:27:12)
    5. AGREED: 2238292 - AcceptedBlocker (Beta) - this is accepted as a violation of "the installer must be able to: Correctly interpret, and modify as described below, any disk ... containing ... btrfs volumes" (adamw, 16:32:02)

  6. (2232838) Some NVME controllers fail to initialize with kernel 6.4.11 or later (nvme0: controller is down; will reset: CSTS:0xffffffff, PCI_STATUS=0xffff) (adamw, 16:32:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2232838 (adamw, 16:32:16)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1291 (adamw, 16:32:16)
    3. Proposed Blocker, kernel, NEW (adamw, 16:32:16)
    4. https://bugzilla.kernel.org/show_bug.cgi?id=217802#c18 (humaton, 16:35:56)
    5. https://linux-hardware.org/index.php?id=pci:10ec-525a-17aa-222e (humaton, 16:39:51)
    6. AGREED: 2232838 - AcceptedBlocker (Beta) - this is accepted as a violation of "The installer must be able to complete an installation to a single disk" and/or "A system installed with a release-blocking desktop must boot to a log in screen" on affected systems (whichever point it fails at) (adamw, 16:45:03)

  7. (2237375) blivet-gui creates different volumes with the same name, confusing anaconda webUI (adamw, 16:45:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2237375 (adamw, 16:45:27)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1260 (adamw, 16:45:27)
    3. Proposed Blocker, python-blivet, ASSIGNED (adamw, 16:45:27)
    4. Ticket vote: BetaBlocker (+1,0,-2) (+lnie, -kparal, -frantisekz) (adamw, 16:45:27)
    5. Ticket vote: BetaFreezeException (+4,0,-0) (+kparal, +adamwill, +geraldosimiao, +frantisekz) (adamw, 16:45:30)
    6. AGREED: 2237375 - RejectedBlocker (Beta), AcceptedFreezeException (Beta) - we agreed it makes more sense to block on 2237878 than on this (i.e. make the installer handle multiple volumes with the same label). but creating them is still a bad idea and should be fixed if possible, so we grant this an FE (adamw, 16:53:48)

  8. Proposed Beta freeze exceptions (adamw, 16:53:56)
  9. (2236156) [webui] "Use Free Space..." option is not always visible/hidden (adamw, 16:54:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2236156 (adamw, 16:54:08)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1300 (adamw, 16:54:08)
    3. Proposed Freeze Exceptions, anaconda, MODIFIED (adamw, 16:54:08)
    4. Ticket vote: BetaFreezeException (+1,0,-0) (+kparal) (adamw, 16:54:08)
    5. AGREED: 2236156 - AcceptedFreezeException (Beta) - this is a fairly findable UI issue in the installer that cannot be fixed with an update, since we have a fix for it and the fix is fairly targeted it makes sense to include it (adamw, 16:59:53)
    6. 2237658 will be skipped as it's already at -3 in ticket voting (adamw, 17:00:21)

  10. (2237707) Update Python to 3.12.0rc2 (adamw, 17:00:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2237707 (adamw, 17:00:27)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1287 (adamw, 17:00:28)
    3. Proposed Freeze Exceptions, python3.12, ON_QA (adamw, 17:00:28)
    4. Ticket vote: BetaFreezeException (+3,0,-3) (+zbyszek, +frantisekz, +geraldosimiao, -adamwill, -kparal, -lruzicka) (adamw, 17:00:28)
    5. AGREED: 2237707 - punt (delay decision) - we have a split vote here, cannot accept or reject. We will punt this; if a clear consensus emerges in ticket voting it can be accepted or rejected (adamw, 17:09:16)

  11. Proposed Final blockers (adamw, 17:09:45)
    1. 2237878 was accepted as Beta blocker, so no need to consider it here (adamw, 17:10:00)

  12. (2238282) Can't refocus blivet-gui, anaconda crashes on trying to launch it again (adamw, 17:10:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2238282 (adamw, 17:10:08)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1297 (adamw, 17:10:09)
    3. Proposed Blocker, anaconda, NEW (adamw, 17:10:09)
    4. Ticket vote: FinalBlocker (+2,0,-0) (+kparal, +lruzicka) (adamw, 17:10:09)
    5. Ticket vote: BetaFreezeException (+4,0,-0) (+kparal, +frantisekz, +lruzicka, +lnie) (adamw, 17:10:09)

  13. quick 2232838 cameo by jforbes (adamw, 17:16:10)
  14. (2238282) Can't refocus blivet-gui, anaconda crashes on trying to launch it again (adamw, 17:16:25)
    1. AGREED: 2238282 - AcceptedBlocker (Final) - this is accepted as a conditional violation of all the disk management criteria, in the case you manage to trigger this by clicking outside of the blivet-gui window (adamw, 17:16:34)

  15. quick 2232838 cameo by jforbes (adamw, 17:16:41)
    1. jforbes says a revert of the offending commit for 2232838 should be possible and he will work on it today (adamw, 17:17:32)

  16. (2236343) When adding a US layout for a non-ASCII-capable layout, put US first in the list, but ensure the KEYMAP setting in vconsole.conf is the native layout (adamw, 17:17:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2236343 (adamw, 17:17:59)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1240 (adamw, 17:17:59)
    3. Proposed Blocker, gnome-initial-setup, ON_QA (adamw, 17:17:59)
    4. AGREED: 2236343 - punt (delay decision) - we need to confirm adam's theory about this affecting the console layout of the installed system before we can confirm whether it's a blocker, adam will test that today (adamw, 17:21:58)
    5. 2232838 is already accepted as Beta blocker, no need to consider it here (adamw, 17:22:21)

  17. (2187858) sddm-wayland-plasma does not respect keyboard layout variant (adamw, 17:22:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2187858 (adamw, 17:22:28)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1158 (adamw, 17:22:28)
    3. Proposed Blocker, sddm, NEW (adamw, 17:22:28)
    4. Ticket vote: BetaBlocker (+1,0,-1) (+geraldosimiao, -catanzaro) (adamw, 17:22:28)
    5. Ticket vote: FinalBlocker (+3,0,-0) (+geraldosimiao, +nielsenb, +catanzaro) (adamw, 17:22:30)
    6. AGREED: 2187858 - punt (delay decision) - adam did a simple test here, but it would probably be good for more folks to test more slightly different setups to see if we can identify any remaining issues (adamw, 17:28:06)

  18. Proposed Beta blockers redux (adamw, 17:28:25)
  19. (2237986) Fedora 39 fails to boot on qemu VM using OVMF_CODE_4M.secboot.qcow2 firmware (adamw, 17:29:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2237986 (adamw, 17:29:11)
    2. Proposed Blocker, libvirt, MODIFIED (adamw, 17:29:27)
    3. https://pagure.io/fedora-qa/blocker-review/issue/1294 (adamw, 17:30:02)
    4. AGREED: 2237986 - RejectedBlocker (Beta) - we don't believe GNOME Boxes offers the affected configuration, and anyone running into it with any other tool should have updates available at the time, so it's fine for this to go as a regular update (adamw, 17:36:16)
    5. let's skip accepted blocker review as folks are leaving and I also have to, will look at them outside the meeting (adamw, 17:36:34)

  20. Open floor (adamw, 17:36:37)


Meeting ended at 17:40:18 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (227)
  2. humaton (45)
  3. kparal (45)
  4. Son_Goku (34)
  5. geraldosimiao (33)
  6. sgallagh (26)
  7. lruzicka (20)
  8. zodbot (18)
  9. frantisekz (15)
  10. coremodule (8)
  11. travier (2)
  12. aoife (2)
  13. jforbes (2)


Generated by MeetBot 0.4.