#fedora-docs: Fedora Docs Office Hours

Meeting started by randomuser at 19:26:30 UTC (full logs).

Meeting summary

    1. the Fedora Release Notes RPM is build directly from the fedorahosted git repo (randomuser, 19:27:22)
    2. ACTION: randomuser to add RNs building to documentation guide (randomuser, 19:28:20)
    3. First step is to ensure the RNs build, `publican build ` (randomuser, 19:29:10)
    4. next get package sources, `fedpkg clone fedora-release-notes` (randomuser, 19:29:39)
    5. `fedpkg switchbranch f21` or similar to get release branch (randomuser, 19:30:07)
    6. Edit spec file so that %version is higher. %release is for package revisions, bump for spec file changes only (randomuser, 19:31:21)
    7. move back to doc sources repo, and add a tag that matches the %version in the spec (randomuser, 19:33:19)
    8. `git tag -s '21.08' -m 'Many revisions to F21 RNs'` (randomuser, 19:35:08)
    9. `git push --tags` (randomuser, 19:36:05)
    10. https://git.fedorahosted.org/cgit/docs/release-notes.git/tag/?id=21.08 (randomuser, 19:36:58)
    11. move back to package repo, test sources with `spectool -g fedora-release-notes.spec` then build with `fedpkg mockbuild` (randomuser, 19:38:51)
    12. http://www.pivnidenik.cz/data/s/T/T/phpsTTvYt.jpg (jreznik, 19:43:33)
    13. after good mock build, commit to pkg repo and `fedpkg build` (randomuser, 19:49:10)
    14. http://pkgs.fedoraproject.org/cgit/fedora-release-notes.git/commit/?h=f21&id=16e53e96d1c6ac2afcc913853e74b800b429f09d (randomuser, 19:51:10)
    15. http://pkgs.fedoraproject.org/cgit/fedora-release-notes.git/commit/?h=f21&id=16e53e96d1c6ac2afcc913853e74b800b429f09d (randomuser, 19:51:18)
    16. next `fedpkg build;xcowsay "Moooo!! your build is done."` (randomuser, 19:56:41)
    17. any translations you have committed at the tag will also be included in the RPM (randomuser, 19:56:52)
    18. also upload sources.... `fedpkg new-sources $file` (randomuser, 19:58:10)
    19. http://pkgs.fedoraproject.org/cgit/fedora-release-notes.git/commit/?h=f21 (randomuser, 20:02:04)
    20. after good build, `fedpkg update`. Associate any bugs, and add *another* changelog entry. (randomuser, 20:06:14)


Meeting ended at 02:09:25 UTC (full logs).

Action items

  1. randomuser to add RNs building to documentation guide


Action items, by person

  1. randomuser
    1. randomuser to add RNs building to documentation guide


People present (lines said)

  1. randomuser (57)
  2. pbokoc (16)
  3. jreznik (13)
  4. zodbot (6)
  5. zoglesby (2)


Generated by MeetBot 0.1.4.