#fedora-meeting-1: Fedora Packaging Committee

Meeting started by spot at 16:01:19 UTC (full logs).

Meeting summary

  1. Roll Call (spot, 16:01:28)
  2. Follow-up: Software Collections in Fedora - https://fedorahosted.org/fpc/ticket/339 (spot, 16:06:49)
    1. ACTION: Table SC until next week when abadger1999 is around (spot, 16:07:49)

  3. Follow-up: Go Packaging Guidelines Draft - https://fedorahosted.org/fpc/ticket/382 (spot, 16:08:14)
    1. ACTION: Waiting on submitter to reply to last week's comments (spot, 16:09:29)

  4. Exception for bundled library FoX in exciting - https://fedorahosted.org/fpc/ticket/400 (spot, 16:09:53)
    1. ACTION: spot will try to make a FoX package that has both "normal" and "pretty-print" libraries (spot, 16:20:44)

  5. ruby193 in SCL - https://fedorahosted.org/fpc/ticket/419 (spot, 16:21:01)
    1. ACTION: Tabled to be addressed along with other SCL ticket with abadger1999 next week (spot, 16:23:48)

  6. systemd or systemd-units should not be required if a spec file does a %systemd_post command - https://fedorahosted.org/fpc/ticket/425 (spot, 16:24:18)
    1. ACTION: if mattdm confirms that they are working around this issue with a fakesystemd package, spot will close, otherwise, we will revisit. (spot, 16:28:32)

  7. Bundling exception request for nodejs-weak-map - https://fedorahosted.org/fpc/ticket/424 (spot, 16:29:15)
    1. ACTION: Bundling request approved (+1:5, 0:0, -1:0). Must be unbundled when Harmony standard is finalized and code is available in Node.js core. (spot, 16:34:22)

  8. Need policy and macros for binfmt.d file handling - https://fedorahosted.org/fpc/ticket/426 (spot, 16:35:12)
    1. https://fedoraproject.org/wiki/User:Spot/binfmtd-draft (spot, 16:47:19)
    2. ACTION: Spot's draft approved (+1:5, 0:0, -1:0) (spot, 16:50:44)

  9. Bundling exception requests for new julia package - https://fedorahosted.org/fpc/ticket/427 (spot, 16:52:00)
    1. ACTION: Temporary exception for libuv bundling in Julia granted, until system libuv is a practical option. (+1:5, 0:0, -1:0) (spot, 16:58:35)
    2. ACTION: Temporary bundling of Rmath is approved until it is no longer needed by Julia (0.4). (+1:6, 0:0, -1:0) (spot, 17:03:26)
    3. ACTION: SmootherFrOgZ will make a dSFMT package, and Julia can use that. :) (spot, 17:14:50)

  10. Exception for bundling css in infrastructure application - https://fedorahosted.org/fpc/ticket/428 (spot, 17:16:08)
    1. ACTION: Temporary bundling exception granted for bootstrap-fedora css resources until bootstrap-fedora is in Fedora. (+1:6, 0:0, -1:0) (spot, 17:19:37)

  11. Bundling exception request for apitrace: libbacktrace - https://fedorahosted.org/fpc/ticket/429 (spot, 17:20:18)
    1. ACTION: Tabled pending more info from Jakub Jelinek (spot, 17:29:23)

  12. mod_cluster EPEL package conflict with product - https://fedorahosted.org/fpc/ticket/432 (spot, 17:30:47)
    1. ACTION: Rathann will answer with suggestions and close ticket when he has time. (spot, 17:37:29)

  13. Add %{python3_version} and %{python3_version_nodots} to Packaging:Python Macros section - https://fedorahosted.org/fpc/ticket/433 (spot, 17:37:54)
    1. ACTION: new macros approved (+1:5, 0:0, -1:0) (spot, 17:40:28)
    2. ACTION: new macros approved (+1:6, 0:0, -1:0) (spot, 17:40:32)

  14. Open Floor (spot, 17:41:14)
    1. ACTION: Bundling exception for libbacktrace approved, Provides: bundled(libbacktrace). (+1:6, 0:0, -1:0) (spot, 17:45:55)


Meeting ended at 17:46:31 UTC (full logs).

Action items

  1. Table SC until next week when abadger1999 is around
  2. Waiting on submitter to reply to last week's comments
  3. spot will try to make a FoX package that has both "normal" and "pretty-print" libraries
  4. Tabled to be addressed along with other SCL ticket with abadger1999 next week
  5. if mattdm confirms that they are working around this issue with a fakesystemd package, spot will close, otherwise, we will revisit.
  6. Bundling request approved (+1:5, 0:0, -1:0). Must be unbundled when Harmony standard is finalized and code is available in Node.js core.
  7. Spot's draft approved (+1:5, 0:0, -1:0)
  8. Temporary exception for libuv bundling in Julia granted, until system libuv is a practical option. (+1:5, 0:0, -1:0)
  9. Temporary bundling of Rmath is approved until it is no longer needed by Julia (0.4). (+1:6, 0:0, -1:0)
  10. SmootherFrOgZ will make a dSFMT package, and Julia can use that. :)
  11. Temporary bundling exception granted for bootstrap-fedora css resources until bootstrap-fedora is in Fedora. (+1:6, 0:0, -1:0)
  12. Tabled pending more info from Jakub Jelinek
  13. Rathann will answer with suggestions and close ticket when he has time.
  14. new macros approved (+1:5, 0:0, -1:0)
  15. new macros approved (+1:6, 0:0, -1:0)
  16. Bundling exception for libbacktrace approved, Provides: bundled(libbacktrace). (+1:6, 0:0, -1:0)


Action items, by person

  1. Rathann
    1. Rathann will answer with suggestions and close ticket when he has time.
  2. SmootherFrOgZ
    1. SmootherFrOgZ will make a dSFMT package, and Julia can use that. :)
  3. spot
    1. spot will try to make a FoX package that has both "normal" and "pretty-print" libraries
    2. if mattdm confirms that they are working around this issue with a fakesystemd package, spot will close, otherwise, we will revisit.
  4. UNASSIGNED
    1. Table SC until next week when abadger1999 is around
    2. Waiting on submitter to reply to last week's comments
    3. Tabled to be addressed along with other SCL ticket with abadger1999 next week
    4. Bundling request approved (+1:5, 0:0, -1:0). Must be unbundled when Harmony standard is finalized and code is available in Node.js core.
    5. Spot's draft approved (+1:5, 0:0, -1:0)
    6. Temporary exception for libuv bundling in Julia granted, until system libuv is a practical option. (+1:5, 0:0, -1:0)
    7. Temporary bundling of Rmath is approved until it is no longer needed by Julia (0.4). (+1:6, 0:0, -1:0)
    8. Temporary bundling exception granted for bootstrap-fedora css resources until bootstrap-fedora is in Fedora. (+1:6, 0:0, -1:0)
    9. Tabled pending more info from Jakub Jelinek
    10. new macros approved (+1:5, 0:0, -1:0)
    11. new macros approved (+1:6, 0:0, -1:0)
    12. Bundling exception for libbacktrace approved, Provides: bundled(libbacktrace). (+1:6, 0:0, -1:0)


People present (lines said)

  1. spot (158)
  2. geppetto (67)
  3. Rathann (49)
  4. SmootherFrOgZ (22)
  5. RemiFedora (19)
  6. tibbs|w (11)
  7. zodbot (8)


Generated by MeetBot 0.1.4.