#fedora-meeting-1: fpc

Meeting started by geppetto at 17:01:24 UTC (full logs).

Meeting summary

  1. Roll Call (geppetto, 17:01:25)
  2. #484 Minor PHP Guidelines update (for PSR-4) (geppetto, 17:05:52)
    1. https://fedorahosted.org/fpc/ticket/484 (geppetto, 17:05:52)
    2. ACTION: Minor PHP Guidelines update, for PSR-4 (+1:6, 0:1, -1:0) (geppetto, 17:12:35)

  3. #486 help2man (geppetto, 17:13:08)
    1. https://fedorahosted.org/fpc/ticket/486 (geppetto, 17:13:08)
    2. https://fedoraproject.org/wiki/Packaging:Guidelines#Manpages (tibbs|w, 17:25:55)
    3. ACTION: Including help2man reference (+1:6, 0:1, -1:1) (geppetto, 17:30:14)

  4. #488 [RFC] Please update Python_Eggs packaging guidelines (geppetto, 17:30:28)
    1. https://fedorahosted.org/fpc/ticket/488 (geppetto, 17:30:29)
    2. ACTION: Please update Python_Eggs packaging guidelines (+1:8, 0:0, -1:0) (geppetto, 17:34:36)

  5. #489 Ruby guidelines: Updates for Minitest 5 (geppetto, 17:34:46)
    1. https://fedorahosted.org/fpc/ticket/489 (geppetto, 17:34:46)
    2. ACTION: Would be nice if one of the main ruby packagers for Fedora could make a macro for this. (geppetto, 17:40:48)
    3. ACTION: Ruby guidelines: Update guidelines due to lack of testrb (+1:7, 0:0, -1:1) (geppetto, 17:45:30)

  6. #443 Requesting Bundling exception for Love (liblove sub package) (geppetto, 17:45:54)
    1. https://fedorahosted.org/fpc/ticket/443 (geppetto, 17:45:55)
    2. ACTION: Need more information on all 3 bundle requests, how much custom code is there, how much work would it take to unbundle etc. (geppetto, 17:59:57)

  7. #209 Please define policy regarding instantiated application (geppetto, 18:00:10)
    1. https://fedorahosted.org/fpc/ticket/209 (geppetto, 18:00:10)

  8. #208 Please add policy regarding socket activated services (geppetto, 18:02:10)
    1. https://fedorahosted.org/fpc/ticket/208 (geppetto, 18:02:10)
    2. ACTION: Someone needs to write the policy, feel free to try to work with someone experienced with writing policy to help you (geppetto, 18:03:23)

  9. #478 Proposal: Package Guidelines: DevAssistant Assistant packages (DAP) (geppetto, 18:04:03)
    1. https://fedorahosted.org/fpc/ticket/478 (geppetto, 18:04:03)

  10. #481 static uids systemd-network, systemd-timesync, systemd-resolve (geppetto, 18:06:43)
    1. https://fedorahosted.org/fpc/ticket/481 (geppetto, 18:06:43)
    2. ACTION: zbyszek Can you answer: Why can't you chown in the initramfs? What kind of state/data is in the initramsfs, or is it just the uid security? Why do they need to be started before the system has booted? (geppetto, 18:16:33)

  11. #412 Please change the packaging guidelines to include packaging (geppetto, 18:19:10)
    1. https://fedorahosted.org/fpc/ticket/412 (geppetto, 18:19:10)
    2. ACTION: follow vote from 9 months ago, writeup policy in description (geppetto, 18:26:35)

  12. Open Floor (geppetto, 18:27:05)
    1. https://fedorahosted.org/fpc/ticket/490 (tibbs|w, 18:29:04)
    2. https://fedoraproject.org/wiki/Packaging:Guidelines#BuildRequires_2 (tibbs|w, 18:36:49)


Meeting ended at 18:59:46 UTC (full logs).

Action items

  1. Minor PHP Guidelines update, for PSR-4 (+1:6, 0:1, -1:0)
  2. Including help2man reference (+1:6, 0:1, -1:1)
  3. Please update Python_Eggs packaging guidelines (+1:8, 0:0, -1:0)
  4. Would be nice if one of the main ruby packagers for Fedora could make a macro for this.
  5. Ruby guidelines: Update guidelines due to lack of testrb (+1:7, 0:0, -1:1)
  6. Need more information on all 3 bundle requests, how much custom code is there, how much work would it take to unbundle etc.
  7. Someone needs to write the policy, feel free to try to work with someone experienced with writing policy to help you
  8. zbyszek Can you answer: Why can't you chown in the initramfs? What kind of state/data is in the initramsfs, or is it just the uid security? Why do they need to be started before the system has booted?
  9. follow vote from 9 months ago, writeup policy in description


People present (lines said)

  1. geppetto (182)
  2. tibbs|w (122)
  3. limburgher (34)
  4. tomspur (17)
  5. racor (16)
  6. Rathann (13)
  7. SmootherFrOgZ (11)
  8. orionp (11)
  9. zodbot (10)
  10. RemiFedora (7)


Generated by MeetBot 0.1.4.