#fedora-meeting-2: Workstation WG

Meeting started by stickster at 13:01:21 UTC (full logs).

Meeting summary

  1. Roll call (stickster, 13:01:29)
  2. Nautilus add-on by default (stickster, 13:05:09)
    1. https://pagure.io/fedora-workstation/issue/10 (stickster, 13:05:10)
    2. ACTION: kalev_ is adding gnome-terminal-nautilus ASAP, should be in composes soon (no later than right after Beta, possibly for Beta) (stickster, 13:07:45)

  3. Packaging guidelines for app independence (stickster, 13:09:07)
    1. https://pagure.io/fedora-workstation/issue/13 (stickster, 13:09:09)
    2. https://fedoraproject.org/wiki/PackagingDrafts/IndependentApplications (mcatanzaro, 13:10:47)
    3. mcatanzaro presented slightly altered packaging guideline change proposal, based on the concept of GNOME Software gaining ability to show when an app dependency will be installed (stickster, 13:30:17)
    4. Needs sorting out with Software upstream first, though (stickster, 13:30:31)
    5. AGREED: WG members agree with text of proposal, contingent on Software changes (stickster, 13:30:57)
    6. ACTION: mclasen to chat w/ hughsie about changes in Software (stickster, 13:31:12)
    7. ACTION: mcatanzaro move forward with guidelines based on outcome of Software change plan (stickster, 13:31:52)

  4. Repo fixes for default install (stickster, 13:32:21)
    1. https://pagure.io/fedora-workstation/issue/17 (stickster, 13:32:25)
    2. mattdm confirms, need to finish third party repo policy, present to Council for final approval, then the WG should be able to control its own third party repo package without needing to call on rel-eng for changes each time (stickster, 13:41:03)
    3. ACTION: cschalle finish third party repo policy (with contribution from WG as needed) and present to Council (stickster, 13:41:23)

  5. Other biz: Setting meeting agenda (stickster, 13:42:42)
    1. If you want something on the agenda, tag the issue with 'meeting' before the meeting happens. (Also open to last minute changes, we're not automatons after all.) (stickster, 13:44:43)
    2. ACTION: stickster to set meeting reminder to also include issues URL for everyone's reference in advance (stickster, 13:46:05)

  6. Background wallpapers (stickster, 13:46:17)
    1. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f8e0ef2850 (ryanlerch, 13:46:45)
    2. ACTION: ryanlerch and kalev_ coordinate to get gnome-backgrounds and new fedora-workstation-backgrounds pushed at the proper time to include post-Beta (stickster, 13:50:42)

  7. Flatpak example modules (stickster, 13:52:58)


Meeting ended at 13:58:56 UTC (full logs).

Action items

  1. kalev_ is adding gnome-terminal-nautilus ASAP, should be in composes soon (no later than right after Beta, possibly for Beta)
  2. mclasen to chat w/ hughsie about changes in Software
  3. mcatanzaro move forward with guidelines based on outcome of Software change plan
  4. cschalle finish third party repo policy (with contribution from WG as needed) and present to Council
  5. stickster to set meeting reminder to also include issues URL for everyone's reference in advance
  6. ryanlerch and kalev_ coordinate to get gnome-backgrounds and new fedora-workstation-backgrounds pushed at the proper time to include post-Beta


Action items, by person

  1. cschalle
    1. cschalle finish third party repo policy (with contribution from WG as needed) and present to Council
  2. kalev_
    1. kalev_ is adding gnome-terminal-nautilus ASAP, should be in composes soon (no later than right after Beta, possibly for Beta)
    2. ryanlerch and kalev_ coordinate to get gnome-backgrounds and new fedora-workstation-backgrounds pushed at the proper time to include post-Beta
  3. mcatanzaro
    1. mcatanzaro move forward with guidelines based on outcome of Software change plan
  4. mclasen
    1. mclasen to chat w/ hughsie about changes in Software
  5. ryanlerch
    1. ryanlerch and kalev_ coordinate to get gnome-backgrounds and new fedora-workstation-backgrounds pushed at the proper time to include post-Beta
  6. stickster
    1. stickster to set meeting reminder to also include issues URL for everyone's reference in advance


People present (lines said)

  1. stickster (95)
  2. mcatanzaro (20)
  3. ryanlerch (19)
  4. otaylor (19)
  5. kalev_ (14)
  6. zodbot (14)
  7. mattdm (6)
  8. mclasen (6)
  9. mboddu (3)
  10. rdieter (1)
  11. cschalle (0)


Generated by MeetBot 0.1.4.