#fedora-commops: Fedora CommOps (2017-12-11)

Meeting started by jwf at 15:29:27 UTC (full logs).

Meeting summary

  1. Agenda (jwf, 15:29:46)
    1. https://infinote.fedoraproject.org/cgit/infinote/tree/meeting-templates/fedora-commops-meeting-next (jwf, 15:29:52)
    2. (1) Roll call / Q&A (jwf, 15:29:52)
    3. (2) Announcements (jwf, 15:29:52)
    4. (3) Action items from last meeting (jwf, 15:29:52)
    5. (4) Tickets (jwf, 15:29:52)
    6. (5) Open floor (jwf, 15:29:53)

  2. Roll call / Q&A (jwf, 15:30:26)
    1. Name; Timezone; Sub-projects/Interest Areas (jwf, 15:30:36)
    2. ACTION: commops New members, make sure you introduce yourself on the CommOps mailing list [ https://fedoraproject.org/wiki/CommOps/Join ] (jwf, 15:30:36)
    3. Justin W. Flory; UTC-5; CommOps, Diversity, Ambassadors, sysadmin-badges (jwf, 15:30:56)
    4. Radka Janek; UTC+1; .NET SIG, CommOps, Diversity, Ambassadors, Bunnehs, Cookiemonsters (Rhea, 15:31:50)
    5. Alberto Rodriguez, UTC-6, CommOps, Marketing,DonNet SIG, infra (bt0, 15:32:01)
    6. Eduard Lucena; UTC-3; CommOps, Ambassadors, Marketing, Cheat-Cubes (x3mboy, 15:32:18)

  3. Announcements (jwf, 15:35:56)
  4. Announcements (jwf, 15:36:02)
    1. === CommOps FAD proposal: First draft complete === (jwf, 15:36:09)
    2. https://fedoraproject.org/wiki/FAD_CommOps_2018 (jwf, 15:36:09)
    3. A first draft of our FAD proposal is complete. The goals for the event are outlined. We'll cover this more in-depth later in the meeting. (jwf, 15:36:30)
    4. === "Heroes of Fedora (HoF) – F27 Final" === (jwf, 15:36:45)
    5. https://communityblog.fedoraproject.org/heroes-of-fedora-f27-final/ (jwf, 15:36:48)
    6. Huzzah to the QA heroes of Fedora! This article gives shout-outs to all the people who helped test, break, and improve Fedora before the general public had their hands on it. Thank you to our heroes! coremodule++ (jwf, 15:36:55)
    7. === "Holiday Reminder" from Fedora Infrastructure team === (jwf, 15:37:10)
    8. https://lists.fedoraproject.org/archives/list/infrastructure@lists.fedoraproject.org/thread/AKOJYPA2O4GVGHTY6JJJQP3O4GCT33YX/ (jwf, 15:37:15)
    9. Many people won't be around as often in the next few weeks. If you need help from the Infra team, the best bet is to file a ticket this month. (jwf, 15:37:19)

  5. Action items from last meeting (jwf, 15:38:47)
    1. https://meetbot.fedoraproject.org/fedora-meeting-2/2017-12-04/commops.2017-12-04-15.29.html (jwf, 15:38:51)
    2. How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action if needed. If no status, we'll try to get a quick update and move forward. (jwf, 15:38:58)
    3. === [MOSTLY COMPELTE] "jwf With FAD proposal, create a proposal draft and logic model flowchart, create new sub-tasks to divide and conquer FAD planning" === (jwf, 15:39:08)
    4. https://fedoraproject.org/wiki/FAD_CommOps_2018 (jwf, 15:39:12)
    5. Draft is done, but logic model flowchart is pending. We'll figure out the rest during the meeting (jwf, 15:39:16)
    6. === "skamath Add comment to ticket #114 (Grimoire ticket) that estimates a timeline for the Perceval fedmsg plugin development. What is required? About how much work is involved? Do you foresee any possible blockers?" === (jwf, 15:39:49)
    7. === [COMPLETE] "Rhea Create the wiki page for the CommOps FAD, using the 2017 Diversity FAD page as a base" === (jwf, 15:41:02)
    8. https://fedoraproject.org/wiki/FAD_CommOps_2018 (jwf, 15:41:07)
    9. === [COMPLETE] "jwf Reach out to CommOps members and confirm participants, add to wiki page" === (jwf, 15:41:11)
    10. === [COMPLETE] "Rhea Research hotel costs in Brno for the duration of the FAD (preferably near DevConf venue, but not required)" === (jwf, 15:41:16)
    11. Rhea put a hold on two rooms in one hotel already ($30/night); will revisit later in meeting (jwf, 15:41:20)
    12. === "bt0 For 50% of all drafts in CommBlog, reach out to authors and confirm if they want their articles published or discarded (due: 2017-12-11)" === (jwf, 15:41:27)
    13. Complete! bt0 emailed draft authors and I emailed mattdm on one, so all articles were covered. (jwf, 15:43:51)
    14. https://pagure.io/fedora-commops/issue/121#comment-483942 (jwf, 15:43:53)

  6. Tickets (jwf, 15:44:37)
    1. https://pagure.io/fedora-commops/issues?tags=meeting (jwf, 15:44:44)
    2. === Ticket #125: "[TRACKER TICKET] Organize a CommOps FAD" === (jwf, 15:45:26)
    3. https://pagure.io/fedora-commops/issue/125 (jwf, 15:45:30)
    4. https://fedoraproject.org/wiki/FAD_CommOps_2018 (jwf, 15:45:33)
    5. The purpose of the CommOps FAD is to… (jwf, 15:46:24)
    6. 1. Pursue plan of deploying a GrimoireLabs dashboard, visualizing fedmsg data (jwf, 15:46:33)
    7. 2. Launch Fedora Appreciation Day in 2018 (jwf, 15:46:42)
    8. 3. (secondary) Analyze Fedora Elections and develop year-long plan to improve community engagement in elections (jwf, 15:46:55)
    9. 4. (secondary) Evaluate critical areas of Fedora that fedmsg integration would be helpful; create development plan for them (e.g. Fedora Magazine / Community Blog) (jwf, 15:47:06)
    10. The purpose of the FAD objectives is to take advantage of our time together for collaborative discussion and planning. We should avoid individual-type of work like research and programming, unless really necessary. We want to take advantage of our time together to the fullest! (jwf, 15:50:46)
    11. IDEA: Emphasize how the community could utilize metrics in a Grimoire dashboard. Why is it relevant? How could the community benefit? We should try to give a concrete example of our vision. (jwf, 15:58:00)
    12. What problem does visualizing fedmsg data solve? (jwf, 16:00:42)
    13. Visualizing fedmsg data in a dashboard allows us to create charts, tables, and other visual aids to understand the data in fedmsg. Right now, to use it, you have to write code / scripts to interact with the data. The dashboard lets anyone, regardless of tech knowledge, see easy-to-understand visualizations about the health of their project / sub-project in Fedor. (jwf, 16:01:55)
    14. For example, a maintainer of a large project (say, Pagure) might see the number of commits over time, the number of new contributors in a month, etc. The localization team may have a geographic chart for languages, so if a new language suddenly starts receiving translations, the community could reach out and support the new translators in their efforts. (jwf, 16:03:01)
    15. IDEA: Figuring out what times/days/months people contribute the most with bar graphs (jwf, 16:04:06)
    16. IDEA: Seeing if new contributors enter the community after an event is organized / executed (jwf, 16:04:43)
    17. IDEA: Planning internal Fedora team sprints when more people are contributing (jwf, 16:05:20)
    18. IDEA: Understand new contributors better and where they snap off (if they do) (skamath, 16:05:21)
    19. https://fedoraproject.org/membership-map/ambassadors.html (skamath, 16:07:19)
    20. IDEA: The Epic Journey of the New Fedora Contributor (i.e. using the visualizations to see pathways / successes / failures of new contributors entering the community for the first time) (jwf, 16:09:45)
    21. NOTE: The Hubs team did a lot of research into the pathways of new contributors with almost a full-year of research. Make sure we don't duplicate work that's already done and lightyears ahead of us already! (jwf, 16:11:42)
    22. ACTION: commops FAD attendees, please research your travel costs and add them to the wiki as soon as possible! (jwf, 16:13:52)
    23. ACTION: jwf Create a logic model based on the current FAD template (jwf, 16:14:18)
    24. ACTION: jwf Submit FAD proposal to Council by Tuesday evening, US EST (jwf, 16:14:32)
    25. === Ticket #114: "Use metrics dashboard to visualize fedmsg data" === (jwf, 16:15:01)
    26. https://pagure.io/fedora-commops/issue/114 (jwf, 16:15:04)
    27. ACTION: skamath Add comment to ticket #114 (Grimoire ticket) that estimates a timeline for the Perceval fedmsg plugin development. What is required? About how much work is involved? Do you foresee any possible blockers? (jwf, 16:18:19)
    28. === Ticket #121: "Follow up with authors of CommBlog drafts" === (jwf, 16:20:11)
    29. https://pagure.io/fedora-commops/issue/121 (jwf, 16:20:17)
    30. AGREED: Will mark ticket as blocked for now, pending feedback from all authors. Once we receive an answer from all authors, we can close the ticket. Articles that are given a +1 will make it onto the publishing schedule. (jwf, 16:25:25)

  7. Open floor (jwf, 16:26:31)
    1. HELP: FAD attendees, make sure to get your travel estimates into the FAD wiki page as soon as possible! (jwf, 16:29:32)
    2. https://www.carbonitex.net/discord/server?s=232740312194351106 (Rhea, 16:31:59)
    3. ACTION: dhanesh95 Reach out to Fedora Magazine team to get feedback on helpful data to incorporate into fedmsg via WordPress's REST API (note limitations of REST API too – what's helpful for what we can extract?) (jwf, 16:33:47)


Meeting ended at 16:36:24 UTC (full logs).

Action items

  1. commops New members, make sure you introduce yourself on the CommOps mailing list [ https://fedoraproject.org/wiki/CommOps/Join ]
  2. commops FAD attendees, please research your travel costs and add them to the wiki as soon as possible!
  3. jwf Create a logic model based on the current FAD template
  4. jwf Submit FAD proposal to Council by Tuesday evening, US EST
  5. skamath Add comment to ticket #114 (Grimoire ticket) that estimates a timeline for the Perceval fedmsg plugin development. What is required? About how much work is involved? Do you foresee any possible blockers?
  6. dhanesh95 Reach out to Fedora Magazine team to get feedback on helpful data to incorporate into fedmsg via WordPress's REST API (note limitations of REST API too – what's helpful for what we can extract?)


Action items, by person

  1. commops
    1. commops New members, make sure you introduce yourself on the CommOps mailing list [ https://fedoraproject.org/wiki/CommOps/Join ]
    2. commops FAD attendees, please research your travel costs and add them to the wiki as soon as possible!
  2. dhanesh95
    1. dhanesh95 Reach out to Fedora Magazine team to get feedback on helpful data to incorporate into fedmsg via WordPress's REST API (note limitations of REST API too – what's helpful for what we can extract?)
  3. jwf
    1. jwf Create a logic model based on the current FAD template
    2. jwf Submit FAD proposal to Council by Tuesday evening, US EST
  4. skamath
    1. skamath Add comment to ticket #114 (Grimoire ticket) that estimates a timeline for the Perceval fedmsg plugin development. What is required? About how much work is involved? Do you foresee any possible blockers?


People present (lines said)

  1. jwf (238)
  2. skamath (73)
  3. Rhea (52)
  4. nauticalnexus (50)
  5. zodbot (21)
  6. bt0 (20)
  7. dhanesh95 (20)
  8. commopstg (19)
  9. meskarune (17)
  10. x3mboy (17)
  11. nb (3)
  12. commopsbot (1)
  13. commopswatch (1)
  14. bee2502 (0)
  15. commops (0)


Generated by MeetBot 0.1.4.