#ansible-meeting: Contributors Summit

Meeting started by gundalow at 16:14:25 UTC (full logs).

Meeting summary

    1. https://public.etherpad-mozilla.org/p/ansible-summit-september-2017-core (rbergeron, 16:14:38)

  1. Intro (gundalow, 16:16:03)
  2. Playbook bundle installer (gundalow, 16:19:36)
    1. Big ask for "Minimal installer", ability to distributes only certain modules (gundalow, 16:20:47)
    2. We want this for Ansible 2.5 (gundalow, 16:21:03)
    3. ACTION: thaumos to create proposal and add link to etherpad (gundalow, 16:22:03)
    4. https://public.etherpad-mozilla.org/p/ansible-summit-september-2017-core (jlk, 16:22:38)
    5. https://public.etherpad-mozilla.org/p/ansible-summit-september-2017-agenda is the main one maxamillion (jlk, 16:23:25)
    6. Other notes are in https://public.etherpad-mozilla.org/p/ansible-summit-september-2017-core (gundalow, 16:25:41)
    7. https://github.com/ansible/ansible/pull/22159 bindep task for ansible, mordred wrote (pabelanger, 16:42:18)
    8. https://public.etherpad-mozilla.org/p/ansible-summit-september-2017-core around line 33ish (rbergeron, 16:45:00)

  3. Core: 2.5 Roadmap (gundalow, 16:52:33)
    1. 2.5 roadmap notes is been added to https://public.etherpad-mozilla.org/p/ansible-summit-september-2017-core see "Core 2.5 roadmap" section (gundalow, 16:53:47)
    2. Network 2.5 roadmap https://github.com/ansible/community/wiki/Network%3ACore-roadmap-2.5 (feedback welcome in #ansible-network) (gundalow, 16:57:46)

  4. Core: Finishing Config (gundalow, 16:59:36)
    1. https://public.etherpad-mozilla.org/p/ansible-summit-september-2017-core heading "finishing config (bcoca)" (gundalow, 16:59:50)

  5. Core: How to get community features on 2.5 roadmap (gundalow, 17:05:10)
    1. BOTMETA https://github.com/ansible/ansible/blob/devel/.github/BOTMETA.yml (gundalow, 17:15:17)

  6. Core: New module utils API (gundalow, 17:41:21)
    1. module_utils/basic.py is huge and needed to be copied to every machine on run. We now have the technology (thanks to ansiball-Z) to split this into smaller files (gundalow, 17:42:25)
    2. Notes so far https://gist.github.com/abadger/3edc108f5a5b88c1a9a46c4869d778fd (gundalow, 17:43:00)
    3. ACTION: abadger1999 to write up proposal (gundalow, 17:43:13)

  7. Core: Holistic view on facts (gundalow, 17:43:48)
  8. Core: How to handle encoding for file contents (gundalow, 17:44:46)
    1. ACTION: abadger1999 to write up proposal for How to handle encoding for file contents (gundalow, 17:45:05)

  9. Community Working Group (gundalow, 18:09:52)
    1. https://public.etherpad-mozilla.org/p/ansible-summit-september-2017-cwg (gundalow, 18:10:05)

  10. Community: Documentation (gundalow, 18:10:55)
    1. We are in the process of moving documentation around (gundalow, 18:11:07)
    2. Issue was that we had lots of documentation in different locations all slihgtly different (gundalow, 18:11:25)
    3. https://public.etherpad-mozilla.org/p/ansible-summit-september-2017-cwg (gregdek, 18:12:05)
    4. http://docs.ansible.com/ansible/latest/community/ (gregdek, 18:12:35)
    5. http://docs.ansible.com/ansible/latest/ - stable-2.3 (gundalow, 18:19:39)
    6. http://docs.ansible.com/ansible/devel/ - devel (gundalow, 18:19:48)

  11. Community: Working Groups (gundalow, 18:27:12)
    1. https://github.com/ansible/community/wiki/VMware%3A-community-plan#major-problems (jtanner, 18:27:21)
    2. Community main page https://github.com/ansible/community/ (gundalow, 18:29:54)
    3. Community Wiki https://github.com/ansible/community/wiki (gundalow, 18:30:09)
    4. ACTION: gundalow to get IRCBot ops set correctly on every Working Group IRC channel (gundalow, 18:31:00)

  12. Community: Ansibot (gundalow, 18:44:11)


Meeting ended at 20:03:18 UTC (full logs).

Action items

  1. thaumos to create proposal and add link to etherpad
  2. abadger1999 to write up proposal
  3. abadger1999 to write up proposal for How to handle encoding for file contents
  4. gundalow to get IRCBot ops set correctly on every Working Group IRC channel


Action items, by person

  1. abadger1999
    1. abadger1999 to write up proposal
    2. abadger1999 to write up proposal for How to handle encoding for file contents
  2. gundalow
    1. gundalow to get IRCBot ops set correctly on every Working Group IRC channel
  3. thaumos
    1. thaumos to create proposal and add link to etherpad


People present (lines said)

  1. jlk (72)
  2. gundalow (65)
  3. jimi|ansible (57)
  4. bcoca (53)
  5. abadger1999 (30)
  6. jtanner (24)
  7. ericsysmin (20)
  8. zodbot (14)
  9. maxamillion (14)
  10. rbergeron (12)
  11. mikedlr (10)
  12. willthames (9)
  13. alikins (8)
  14. resmo (7)
  15. mordred (6)
  16. Pilou (5)
  17. stickster (5)
  18. pabelanger (3)
  19. jhawkesworth_ (3)
  20. gregdek (3)
  21. sdoran (2)
  22. dmsimard (2)
  23. matrix30001 (2)
  24. ryansb (2)
  25. thaumos (2)
  26. caphrim007 (1)
  27. mattclay (1)
  28. rcarrillocruz (1)
  29. Qalthos (0)
  30. ShaneF (0)
  31. itdependsnetwork (0)
  32. zerocoolback (0)
  33. chouseknecht (0)
  34. grastogi (0)
  35. dag (0)
  36. shertel (0)
  37. kedarX (0)
  38. stacywsmith (0)
  39. privateip (0)
  40. nitzmahone (0)


Generated by MeetBot 0.1.4.