#fedora-blocker-review: F21-blocker-review

Meeting started by pschindl at 16:03:55 UTC (full logs).

Meeting summary

  1. Roll Call (pschindl, 16:04:10)
  2. Introduction (pschindl, 16:08:01)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (pschindl, 16:08:06)
    2. We'll be following the process outlined at: (pschindl, 16:08:08)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (pschindl, 16:08:10)
    4. The bugs up for review today are available at: (pschindl, 16:08:12)
    5. http://qa.fedoraproject.org/blockerbugs/current (pschindl, 16:08:14)
    6. The criteria for release blocking bugs can be found at: (pschindl, 16:08:16)
    7. https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria (pschindl, 16:08:18)
    8. https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria (pschindl, 16:08:20)
    9. https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria (pschindl, 16:08:22)
    10. 9 Proposed Blockers (pschindl, 16:08:28)
    11. 6 Accepted Blockers (pschindl, 16:08:31)
    12. 11 Proposed Freeze Exceptions (pschindl, 16:08:33)
    13. 3 Accepted Freeze Exceptions (pschindl, 16:08:35)

  3. (1162856) Missing high contrast icon (pschindl, 16:09:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1162856 (pschindl, 16:09:32)
    2. Proposed Blocker, fedora-logos, NEW (pschindl, 16:09:34)
    3. AGREED: - 1162856 - AcceptedBlocker - This bug is a clear violation of the Final criterion: All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy. (pschindl, 16:16:14)

  4. (1165430) Fedora-repos needs updating for f21 final (pschindl, 16:16:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1165430 (pschindl, 16:16:40)
    2. Proposed Blocker, fedora-repos, ON_QA (pschindl, 16:16:42)
    3. AGREED: - 1165430 - AcceptedBlocker - This bug violates the final criterion: A fedora-release package containing the correct names, information and repository configuration for a final Fedora release must be present on release-blocking images and the appropriately versioned generic-release package must be available in the release repository. (pschindl, 16:20:19)

  5. (1165261) ipa-server-install fails when restarting named (pschindl, 16:20:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1165261 (pschindl, 16:20:35)
    2. Proposed Blocker, freeipa, POST (pschindl, 16:20:37)
    3. AGREED: - 1165261 - AcceptedBlocker - This bug violates the beta roles criteria: Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully started, stopped, brought to a working configuration, and queried. (pschindl, 16:35:16)

  6. (1164492) Please drop libvirt 'default' network dependency for F21 GA (pschindl, 16:35:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1164492 (pschindl, 16:35:30)
    2. Proposed Blocker, gnome-boxes, NEW (pschindl, 16:35:32)
    3. AGREED: - 1164492 - RejectedBlocker - This bug tryes to solve the same issue as bug 1146232 which is already blocker. (pschindl, 16:48:46)

  7. (1165425) bcl accidentally pushed a diagnostic 'bcl was here' test for product.img (pschindl, 16:49:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1165425 (pschindl, 16:49:15)
    2. Proposed Blocker, lorax, MODIFIED (pschindl, 16:49:17)
    3. AGREED: - 1165425 - RejectedBlocker AcceptedFreezeException - Since this doesn't violate a specific criterion it can't block, but we accept it as a freeze exception. (pschindl, 16:57:08)

  8. (1164889) support TLS 1.1 and later (pschindl, 16:57:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1164889 (pschindl, 16:57:28)
    2. Proposed Blocker, openldap, NEW (pschindl, 16:57:30)
    3. AGREED: - 1164889 - AcceptedBlocker - This bug violates the final creterion for fedora server: "The Domain Controller must be capable of serving LDAPS (LDAP encrypted with SSL) over port 636. This should be validated by the use of the ldapsearch tool." (pschindl, 17:04:40)

  9. (1163694) ValueError: new size will not yield an aligned partition (pschindl, 17:04:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1163694 (pschindl, 17:05:01)
    2. Proposed Blocker, python-blivet, NEW (pschindl, 17:05:03)
    3. AGREED: - 1165714 - AcceptedBlocker - This violates the final criterion: Any installer mechanism for resizing storage volumes must correctly attempt the requested operation. (pschindl, 17:15:39)

  10. (1163660) Unable to create OpenSSH Key with seahorse (pschindl, 17:15:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1163660 (pschindl, 17:15:56)
    2. Proposed Blocker, seahorse, POST (pschindl, 17:15:58)
    3. AGREED: - 1163660 - AcceptedBlocker - Ability to create OpenSSH Key is considered as basic functionality of seahorse. So this violates the final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. *Basic functionality means that the app must at least (pschindl, 17:26:33)

  11. (1162068) High Xorg cpu usage during F21 beta install prevents installation (pschindl, 17:26:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1162068 (pschindl, 17:26:55)
    2. Proposed Blocker, xorg-x11, NEW (pschindl, 17:26:57)
    3. AGREED: - 1162068 - Punt - It is possible that this bug was already resolved. We will wait for more information again. (pschindl, 17:34:01)

  12. (1161775) No Fedora branding for Cockpit in Fedora 21 Server (pschindl, 17:35:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1161775 (pschindl, 17:35:49)
    2. Proposed Freeze Exceptions, cockpit, NEW (pschindl, 17:35:51)
    3. AGREED: - 1161775 - AcceptedFreezeException - Branding shouldn't bring any problems. (pschindl, 17:42:45)

  13. (1165674) getkeytab control implementation uses incorrect asn1 encoding (pschindl, 17:43:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1165674 (pschindl, 17:43:26)
    2. Proposed Freeze Exceptions, freeipa, NEW (pschindl, 17:43:28)
    3. AGREED: - 1165674 - AcceptedFreezeException - We will consider a fix for this if the updated package is available by Monday 2014-11-24. If not, we can revisit at the next meeting. (pschindl, 18:01:22)

  14. (1143981) artifacts on two background sizes (kparal, 18:05:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1143981 (kparal, 18:05:01)
    2. Proposed Freeze Exceptions, f21-backgrounds, NEW (kparal, 18:05:01)
    3. AGREED: - 1143981 - AcceptedFreezeException - This is a low risk change. (kparal, 18:09:35)

  15. (1155228) put variant-specific gfx in img dirs for correct product (kparal, 18:09:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1155228 (kparal, 18:09:44)
    2. Proposed Freeze Exceptions, fedora-logos, NEW (kparal, 18:09:44)
    3. AGREED: - 1155228 - AcceptedFreezeException - This is accepted if the updated package is available soon enough, before TC3 compose request. (kparal, 18:27:15)

  16. (1145264) F21 desktop livecd ISO volume ID is truncated, doesn't fit version number (kparal, 18:27:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1145264 (kparal, 18:27:32)
    2. Proposed Freeze Exceptions, koji, NEW (kparal, 18:27:32)
    3. AGREED: - 1145264 - AcceptedFreezeException - Breaking virt tools is very inconvenient, accepted. Please provide the fix as soon as possible, ideally before TC3 compose request. (kparal, 18:33:38)

  17. (1161637) Review Request: gnome-shell-extension-background-logo - Background logo extension for GNOME Shell (kparal, 18:33:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1161637 (kparal, 18:33:52)
    2. Proposed Freeze Exceptions, Package Review, NEW (kparal, 18:33:52)
    3. AGREED: - 1161637 - AcceptedFreezeException - This seems low risk and adjusts branding. (kparal, 18:42:16)

  18. (1161883) Headphones not detected by pulseaudio (kparal, 18:43:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1161883 (kparal, 18:43:04)
    2. Proposed Freeze Exceptions, pulseaudio, ON_QA (kparal, 18:43:04)
    3. https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria#Working_sound (kparal, 18:45:10)
    4. AGREED: - 1161883 - AcceptedBlocker - This violates Beta criterion "The installed system must be able to play back sound with gstreamer-based applications." (kparal, 18:54:49)

  19. (1135720) sugar-runner fails to start sugar-desktop in installed x86_64 Workstation f21 Alpha TC5 (kparal, 18:55:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1135720 (kparal, 18:55:00)
    2. Proposed Freeze Exceptions, sugar-runner, NEW (kparal, 18:55:00)
    3. AGREED: - 1135720 - AcceptedFreezeException - As long as this is just a simple desktop file change, it's not risky for Fedora products, and thus accepted. (kparal, 19:00:07)

  20. (1145281) collaboration does not work in f21-Alpha-RC1 in SoaS spin (kparal, 19:00:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1145281 (kparal, 19:00:15)
    2. Proposed Freeze Exceptions, telepathy-salut, NEW (kparal, 19:00:16)
    3. FE proposal removed from 1145281 (kparal, 19:04:37)

  21. (1135546) [abrt] virt-manager: g_socket_constructed(): python2.7 killed by SIGTRAP (kparal, 19:05:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1135546 (kparal, 19:05:13)
    2. Proposed Freeze Exceptions, virt-manager, ON_QA (kparal, 19:05:13)
    3. AGREED: - 1135546 - AcceptedFreezeException - virt-manager is a part of Server DVD, and it would great to have this crash fixed. It's not installed by default, so the change should be quite safe. (kparal, 19:16:58)


Meeting ended at 19:18:19 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. kparal (245)
  2. pschindl (145)
  3. sgallagh (134)
  4. roshi (125)
  5. jskladan (14)
  6. mattdm (14)
  7. jreznik_2nd (11)
  8. oddshocks (10)
  9. danofsatx-work (10)
  10. simo (9)
  11. zodbot (8)
  12. satellit_e (8)
  13. dlehman (3)
  14. mkolman (2)


Generated by MeetBot 0.1.4.