#fedora-blocker-review: F21-blocker-review

Meeting started by adamw at 16:03:15 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:03:26)
  2. The weather (adamw, 16:08:21)
    1. in weather news, it is cold enough in Brno that people enjoy being at a blocker meeting as long as it's inside, polar-bear-in-corridor cold in Canada, an 'oddball' 57F (whatever those weird made-up American numbers mean) in Westford, and 20F in whichever bit of the middle of America it is Roshi lives in (adamw, 16:09:24)
    2. and 49F for danofsatx, which is what people in Texas think is cold. (adamw, 16:10:01)

  3. Introduction (adamw, 16:10:17)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:10:17)
    2. We'll be following the process outlined at: (adamw, 16:10:17)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:10:17)
    4. The bugs up for review today are available at: (adamw, 16:10:19)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:10:21)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:10:23)
    7. https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria (adamw, 16:10:25)
    8. https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria (adamw, 16:10:29)
    9. https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria (adamw, 16:10:31)
    10. 4 Proposed Blockers (adamw, 16:12:33)
    11. 5 Accepted Blockers (adamw, 16:12:34)
    12. 7 Proposed Freeze Exceptions (adamw, 16:12:34)
    13. 17 Accepted Freeze Exceptions (adamw, 16:12:34)

  4. (1169019) UnicodeDecodeError: 'ascii' codec can't decode byte 0xe4 in position 11: ordinal not in range(128) (adamw, 16:13:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1169019 (adamw, 16:13:34)
    2. Proposed Blocker, anaconda, MODIFIED (adamw, 16:13:34)
    3. AGREED: - 1169019 - AcceptedBlocker - any language with translated size units is likely to crash all over the place in live installs, this violates any 'successful installation' criterion (adamw, 16:18:17)
    4. roshi will secretarialize (adamw, 16:21:10)

  5. (1169023) Many translations missing from anaconda 21.48.18 and 21.48.19 (adamw, 16:21:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1169023 (adamw, 16:21:17)
    2. Proposed Blocker, anaconda, MODIFIED (adamw, 16:21:17)
    3. AGREED: - 1169023 - AcceptedBlocker - this is a clear violation of the criterion requiring translations be present (adamw, 16:24:20)

  6. (1167965) logvol swap --recommended fails (adamw, 16:24:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1167965 (adamw, 16:24:53)
    2. Proposed Blocker, python-blivet, VERIFIED (adamw, 16:24:53)
    3. AGREED: this was fixed and the fix tested in RC1, so we decided to drop it from blocker consideration as the question is mostly moot (adamw, 16:27:19)

  7. (1168748) Need final Fedora 21 build of spin-kickstarts (adamw, 16:27:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1168748 (adamw, 16:27:32)
    2. Proposed Blocker, spin-kickstarts, ON_QA (adamw, 16:27:32)
    3. AGREED: - 1168748 - this is a clear blocker under the criterion requiring a spin-kickstarts build that matches the release, but note it does not block image compose, as the package does not appear on the images. (adamw, 16:34:28)

  8. (1167658) custom partitioning: after you press Done for the first time, Reset All stops working (adamw, 16:35:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1167658 (adamw, 16:35:15)
    2. Proposed Freeze Exceptions, anaconda, NEW (adamw, 16:35:15)
    3. AGREED: - 1167658 - RejectedFreezeException - this is obviously a bit annoying, but it's too late for speculative FEs now, anaconda team doesn't have a clear fix for it, and it is workaroundable (adamw, 16:38:31)
    4. we will vote only on FEs that look like there's some kind of fix waiting to go, given the point we're at in the c ycle (adamw, 16:39:23)

  9. (1168118) Custom UEFI layout with /boot/efi on second disk fails: is_valid_stage1_device not called on disks after the first (adamw, 16:39:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1168118 (adamw, 16:39:38)
    2. Proposed Freeze Exceptions, anaconda, MODIFIED (adamw, 16:39:38)
    3. anyone who wants to buy rum, don't bother going to look. handsome_pirate drank it all. (adamw, 17:00:34)
    4. AGREED: 1168118 - AcceptedFreezeException - people are understandably worried about tweaking this at this point, but the affected case is clearly bad behaviour and would be good to improve, and there's a reasonable consensus the patch is unlikely to cause bugs or unexpected behaviour changes. (adamw, 17:03:04)

  10. (1168717) Missing python-lxml BuildRequires (adamw, 17:03:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1168717 (adamw, 17:03:29)
    2. Proposed Freeze Exceptions, anaconda, POST (adamw, 17:03:29)
    3. AGREED: 1168717 - RejectedFreezeException - we're still not entirely clear on what this bug is for, but it seems fairly clear that fixing it won't magically make the release images better, so rejected. (adamw, 17:17:08)

  11. (1169332) Widget colors in anaconda totally changed in RC1, some widgets hardly visible (adamw, 17:17:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1169332 (adamw, 17:17:37)
    2. Proposed Freeze Exceptions, fedora-productimg-workstation, ASSIGNED (adamw, 17:17:37)
    3. AGREED: 1169332 - AcceptedFreezeException - the combination of broken elements here leads to a significantly degraded user experience, and is a clear regression from all previous tested composes (adamw, 17:24:00)

  12. (1166607) hawtjni: Spit runtime into subpackage (adamw, 17:24:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1166607 (adamw, 17:24:09)
    2. Proposed Freeze Exceptions, hawtjni, ON_QA (adamw, 17:24:09)
    3. AGREED: 1166607 - RejectedFreezeException - the benefits from this are not worth the risk of taking it at this point (adamw, 17:27:31)

  13. (1150384) unicode_start is not started on boot (adamw, 17:27:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1150384 (adamw, 17:27:44)
    2. Proposed Freeze Exceptions, systemd, ON_QA (adamw, 17:27:44)
    3. http://paste.fedoraproject.org/155540/45518714 (sgallagh, 17:33:42)
    4. AGREED: 1150384 - AcceptedFreezeException - we're obviously reluctant to touch systemd this late, but the change is very limited and the bug seems fairly bad for many non-US users (and even some US users who speak those furrin languages). (adamw, 17:46:57)

  14. (1168404) velocity has a runtime dependency on junit (adamw, 17:47:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1168404 (adamw, 17:47:26)
    2. Proposed Freeze Exceptions, velocity, ON_QA (adamw, 17:47:26)
    3. AGREED: 1168404 - RejectedFreezeException - the benefit of this change is not worth the risk of taking it at this point. (adamw, 17:52:34)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=1150384 (satellit_e, 17:53:41)

  15. (1169440) SoaS anaconda is missing font does not display some language samples on first screen (adamw, 17:55:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1169440 (adamw, 17:55:36)
    2. Proposed Freeze Exceptions, spin-kickstarts, NEW (adamw, 17:55:36)
    3. AGREED: - 1169440 - AcceptedFreezeException - we will accept a fix for SoaS if it is constrained to SoaS. (adamw, 18:19:21)
    4. all open accepted blockers from before this meeting were VERIFIED, do not need to be reviewed (adamw, 18:19:46)

  16. Open floor (adamw, 18:20:07)


Meeting ended at 18:30:37 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (234)
  2. sgallagh (126)
  3. kparal (61)
  4. nirik (59)
  5. roshi (55)
  6. danofsatx-work (47)
  7. handsome_pirate (32)
  8. satellit (17)
  9. vpodzime (15)
  10. jreznik (15)
  11. mkolman (12)
  12. dlehman (10)
  13. pschindl (10)
  14. sbueno (5)
  15. zodbot (4)
  16. brunowolff (4)
  17. satellit_e (1)
  18. smccann (1)
  19. tflink (0)


Generated by MeetBot 0.1.4.