#fedora-blocker-review: F28-blocker-review

Meeting started by adamw at 16:01:32 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:32)
  2. Introduction (adamw, 16:04:40)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:04:41)
    2. We'll be following the process outlined at: (adamw, 16:04:41)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:04:41)
    4. The bugs up for review today are available at: (adamw, 16:04:43)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:04:45)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:04:47)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:04:49)
    8. https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria (adamw, 16:04:51)
    9. https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria (adamw, 16:04:53)
    10. coremodule will secretarialize (adamw, 16:04:55)
    11. 4 Proposed Blockers (adamw, 16:05:57)
    12. 6 Accepted Blockers (adamw, 16:05:57)
    13. 9 Proposed Freeze Exceptions (adamw, 16:06:00)
    14. 1 Accepted Freeze Exceptions (adamw, 16:06:01)

  3. (1553488) 'KickstartSpecificationHandler' object has no attribute 'UserData' (adamw, 16:09:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1553488 (adamw, 16:09:19)
    2. Proposed Blocker, anaconda, POST (adamw, 16:09:19)
    3. AGREED: 1553488 - AcceptedBlocker (Beta) - clearly violates "The scripted installation mechanism must provide a working function for creating local user accounts, including the ability to specify a hashed password, and for specifying a hashed password for the root account." (adamw, 16:16:31)

  4. (1553792) Gnome Software doesn't offer upgrade from F26 to F28 (adamw, 16:16:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1553792 (adamw, 16:16:48)
    2. Proposed Blocker, gnome-software, NEW (adamw, 16:16:48)
    3. AGREED: 1553792 - AcceptedBlocker (Beta) - seems like a clear violation of "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed" for Workstation (where Software is the recommended upgrade mechanism), would be good if others could confirm (adamw, 16:22:10)

  5. (1553646) Upgrading F27 > F28 is not possible because of nss-pem (adamw, 16:22:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1553646 (adamw, 16:22:23)
    2. Proposed Blocker, nss-pem, MODIFIED (adamw, 16:22:23)
    3. AGREED: 1553646 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - this does not affect any default package sets so far as we know, so not a blocker, but is likely to affect many folks with wine installed, so we think it's worth a freeze exception (adamw, 16:30:03)

  6. (1552910) Upgrading F27 > F28 is not possible because of shim (adamw, 16:30:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1552910 (adamw, 16:30:13)
    2. Proposed Blocker, shim, MODIFIED (adamw, 16:30:13)
    3. AGREED: 1552910 - punt (delay decision) - seems a tagging error has been fixed and current composes get a random selection of shim packages that at least doesn't block gnome-software; we will follow up with pjones to see if there are any other problems here and then make a decision (adamw, 16:40:43)

  7. (1552130) Intermittent boot issues on the rpi3 with uboot-tools-2018.03-0.8.rc3 (adamw, 16:41:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1552130 (adamw, 16:41:09)
    2. Proposed Blocker, uboot-tools, ON_QA (adamw, 16:41:09)
    3. https://fedoraproject.org/wiki/Architectures/ARM#Supported_Hardware_and_Devices (puiterwijk, 16:47:27)
    4. https://fedoraproject.org/wiki/Architectures/ARM/Supported_Platforms (kparal, 16:47:32)
    5. AGREED: 1552130 - AcceptedBlocker (Beta) - this is accepted as a violation of "All release-blocking images must boot in their supported configurations" for the release-blocking ARM minimal and Xfce disk images, on Raspberry Pi 3, which is a supported ARM platform per https://fedoraproject.org/wiki/Architectures/ARM/Supported_Platforms (adamw, 17:00:12)
    6. moving onto the proposed freeze exceptions (adamw, 17:00:46)

  8. (1418336) Anaconda won't accept /boot on btrfs subvol, installation is impossible on my machine (adamw, 17:02:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1418336 (adamw, 17:02:29)
    2. Proposed Freeze Exceptions, anaconda, NEW (adamw, 17:02:29)
    3. https://github.com/rhboot/grubby/pull/32 (Kellin, 17:06:45)
    4. https://github.com/rhboot/grubby/pull/32 needs marked as merged then - that's the source of mboddu's confusion (Kellin, 17:16:09)
    5. AGREED: 1418336 - AcceptedFreezeException (Beta) - we're a bit unhappy about touching bootloader stuff during a chaotic freeze, but this is a feature people have been asking for for a long time that'd add significant value to F28, and if we want it in, we'd better test it in Beta (adamw, 17:20:14)

  9. (1553935) Installer auto-quits after Workstation live install (as no spokes are on the install hub) (adamw, 17:21:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1553935 (adamw, 17:21:49)
    2. Proposed Freeze Exceptions, anaconda, NEW (adamw, 17:21:49)
    3. AGREED: 1553935 - AcceptedFreezeException (Beta) - this could clearly confuse/concern users installing Workstation live in the Beta, and cannot be fixed with an update (adamw, 17:30:32)

  10. (1552045) Include bolt 0.2 release (adamw, 17:30:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1552045 (adamw, 17:30:44)
    2. Proposed Freeze Exceptions, bolt, MODIFIED (adamw, 17:30:44)
    3. AGREED: 1552045 - AcceptedFreezeException (Beta) - this is part of an accepted Change for F28, it'd be good to have it in Beta for testing, and it should not endanger any release-blocking path (adamw, 17:35:23)

  11. (1552814) Need builds for F28 and F29 that reflect the Modularity changes (adamw, 17:35:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1552814 (adamw, 17:35:41)
    2. Proposed Freeze Exceptions, fedora-repos, ASSIGNED (adamw, 17:35:41)
    3. AGREED: 1552814 - AcceptedFreezeException (Beta) - the new files are necessary for Modularity enablement, which is a major Change for Fedora 28 and definitely needs to land in Beta (adamw, 17:44:28)

  12. (1552923) Revert inadvertently bumped soname (adamw, 17:44:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1552923 (adamw, 17:44:39)
    2. Proposed Freeze Exceptions, ghc-conduit-extra, ON_QA (adamw, 17:44:39)
    3. AGREED: 1552923 - AcceptedFreezeException (Beta) - it would be good to get these dependencies in line for the Beta, it may affect the compose of some images (adamw, 17:52:15)

  13. (1094489) add support for btrfs in grub2 on /boot (adamw, 17:52:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1094489 (adamw, 17:52:23)
    2. Proposed Freeze Exceptions, grubby, ON_QA (adamw, 17:52:23)
    3. AGREED: 1094489 - AcceptedFreezeException (Beta) - this part of the same feature enablement as 1418336, so our decision is the same (adamw, 17:55:41)

  14. (1552913) Several packages still need rebuilds against OpenCV 3.4 (adamw, 17:55:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1552913 (adamw, 17:55:55)
    2. Proposed Freeze Exceptions, opencv, ON_QA (adamw, 17:55:55)
    3. AGREED: 1552913 - AcceptedFreezeException (Beta) - again, fixing up dependencies is a good thing to do for the compose, can avoid packages missing from composes and fix upgrade issues (adamw, 18:02:22)

  15. (1549686) Review Request: f28-backgrounds - Fedora 28 default desktop background (adamw, 18:02:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1549686 (adamw, 18:02:32)
    2. Proposed Freeze Exceptions, Package Review, ON_QA (adamw, 18:02:32)
    3. https://openqa.fedoraproject.org/tests/200929#step/_do_install_and_reboot/31 (adamw, 18:04:13)
    4. AGREED: 1549686 - AcceptedBlocker (Beta) - we are accepting this as a blocker (not just FE) as the background in current F28 composes is the same as the F27 background, which violates "The default desktop background must be different from that of the last two stable releases" (adamw, 18:09:53)

  16. (1552318) Re-base Dogtag 10.5 to Dogtag 10.6 (adamw, 18:10:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1552318 (adamw, 18:10:35)
    2. Proposed Freeze Exceptions, pki-core, NEW (adamw, 18:10:35)
    3. AGREED: 1552318 - AcceptedFreezeException (Beta) - we're not super happy about major version bumps this late, but it seems this is the only way we are likely to get a working FreeIPA. we would like to ask the FreeIPA-related teams to co-ordinate to get appropriate, interoperable versions landed *before* Beta freeze in future cycles. (adamw, 18:16:56)

  17. (1554453) "exported surface had an invalid role" protocol errors from xdg_exporter when opening files (adamw, 18:18:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1554453 (adamw, 18:18:14)
    2. Proposed Freeze Exceptions, mutter, NEW (adamw, 18:18:15)
    3. AGREED: 1552318 - AcceptedFreezeException (Beta), AcceptedBlocker (Final) - we accept this as an FE (it's an obvious major bug in a core Workstation component that will affect live experience) and a Final blocker (as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must...withstand a basic functionality test") (adamw, 18:29:08)

  18. (1554464) Rebuilds for GCC 8 ABI change miscompilation issue (adamw, 18:29:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1554464 (adamw, 18:29:31)
    2. Proposed Freeze Exceptions, distribution, MODIFIED (adamw, 18:29:31)
    3. AGREED: 1554464 - AcceptedFreezeException (Beta) - when the gcc maintainers tell us their compiler miscompiled some stuff and it should be recompiled, recompiling it seems like a good plan. (adamw, 18:33:55)
    4. that's all the proposals (adamw, 18:34:20)
    5. quick check-in on accepted blockers (adamw, 18:34:47)

  19. (1496562) freeipa tests in Fedora28+ shouldn't test for specific NSS database filenames, but should be flexible (adamw, 18:34:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1496562 (adamw, 18:34:53)
    2. Accepted Blocker, pki-core, ASSIGNED (adamw, 18:34:53)
    3. freeipa is still broken and has been for months, freeipa folks intend to fix it by landing new versions of several things; adamw will check in with them on precise plan (adamw, 18:35:59)
    4. ACTION: adamw to check with freeipa folks on plan and schedule for landing working freeipa bits (adamw, 18:36:13)

  20. (1520580) Unable to log in on arm disk images (adamw, 18:39:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1520580 (adamw, 18:39:25)
    2. Accepted Blocker, selinux-policy, NEW (adamw, 18:39:25)
    3. this has been unaddressed for a long time, we need to ping selinux folks about it (adamw, 18:40:04)
    4. ACTION: adamw to ping selinux maintainers re 1520580 (adamw, 18:40:13)

  21. Open floor (adamw, 18:40:51)


Meeting ended at 18:44:33 UTC (full logs).

Action items

  1. adamw to check with freeipa folks on plan and schedule for landing working freeipa bits
  2. adamw to ping selinux maintainers re 1520580


Action items, by person

  1. adamw
    1. adamw to check with freeipa folks on plan and schedule for landing working freeipa bits
    2. adamw to ping selinux maintainers re 1520580


People present (lines said)

  1. adamw (269)
  2. lruzicka (71)
  3. kparal (67)
  4. frantisekz (42)
  5. pwhalen (36)
  6. roca (33)
  7. sumantro (28)
  8. puiterwijk (26)
  9. mboddu (23)
  10. coremodule (15)
  11. lbrabec (15)
  12. pjones (13)
  13. kalev (12)
  14. satellit (11)
  15. zodbot (10)
  16. Kellin (10)
  17. mkolman (4)
  18. sgallagh (3)
  19. nirik (1)
  20. suprith4989 (1)


Generated by MeetBot 0.1.4.