#fedora-blocker-review: F31-blocker-review

Meeting started by adamw at 16:05:45 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:05:45)
  2. Introduction (adamw, 16:09:20)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:09:21)
    2. We'll be following the process outlined at: (adamw, 16:09:21)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:09:21)
    4. The bugs up for review today are available at: (adamw, 16:09:24)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:09:25)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:09:27)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:09:29)
    8. https://fedoraproject.org/wiki/Fedora_31_Beta_Release_Criteria (adamw, 16:09:31)
    9. https://fedoraproject.org/wiki/Fedora_31_Final_Release_Criteria (adamw, 16:09:33)
    10. for Beta, we have: (adamw, 16:09:41)
    11. 7 Proposed Blockers (adamw, 16:09:43)
    12. 1 Accepted Blockers (adamw, 16:09:43)
    13. 1 Proposed Freeze Exceptions (adamw, 16:09:48)
    14. for Final, we have: (adamw, 16:09:52)
    15. 2 Proposed Blockers (adamw, 16:10:03)
    16. coremodule will secretarialize (adamw, 16:10:10)
    17. starting with proposed Beta blockers (adamw, 16:10:39)

  3. (1616167) provide fail-safe mechanisms when repos with modulemd are unavailable/disabled and when repos lose modulemd by accident (adamw, 16:10:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1616167 (adamw, 16:10:55)
    2. Proposed Blocker, dnf, POST (adamw, 16:10:55)
    3. AGREED: 1616167 - RejectedBlocker (Beta) - as we shipped the last two releases without this, it seems arbitrary to start blocking on it now just because it might actually be ready this cycle. Clearly we've established a precedent that it's OK to release Fedora without it. We'd still like to see it done, though (adamw, 16:18:40)

  4. (1717117) Can't install module libgit2:0.28 due to (uninstalled) conflicts (adamw, 16:19:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1717117 (adamw, 16:19:19)
    2. Proposed Blocker, dnf, NEW (adamw, 16:19:19)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1719976 is still NEW (adamw, 16:22:49)
    4. AGREED: 1717117 - RejectedBlocker (Beta) - at the moment nothing about this seems to be violating any release criteria, it only results in an annoying error message showing up all the time, and a non-essential module not being installable. This is acceptable for Beta. We will re-propose it as a Final blocker in case it's not fixed by then (adamw, 16:28:57)

  5. (1723777) gnutls-dane depends on unbound-libs which creates huge bootstrap loop (adamw, 16:29:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1723777 (adamw, 16:29:10)
    2. Proposed Blocker, gnutls, NEW (adamw, 16:29:10)
    3. AGREED: 1723777 - RejectedBlocker (Beta) - our understanding is that the initial problem covered by this bug indeed was a blocker (it would've prevented composes), but that issue was resolved and now the bug has been re-opened for a different and less critical reason (see comment #14). as we understand the current issue, it does not violate any criteria (adamw, 16:40:39)

  6. (1724380) 3DES removal breaks credential acquisition (adamw, 16:40:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1724380 (adamw, 16:40:46)
    2. Proposed Blocker, krb5, POST (adamw, 16:40:46)
    3. AGREED: 1724380 - punt (delay decision) - there is definitely a significant bug here, but as things stand we aren't clear if it breaks the criteria for F31 due to the changes in F30. we will investigate this further and decide blocker status once we have more information (adamw, 16:47:33)

  7. (1727343) [abrt] PackageKit: libdnf::Repo::Impl::detachLibsolvRepo(): packagekitd killed by SIGSEGV (adamw, 16:47:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1727343 (adamw, 16:47:46)
    2. Proposed Blocker, libdnf, ASSIGNED (adamw, 16:47:46)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1727424 (adamw, 16:48:04)
    4. https://openqa.fedoraproject.org/tests/421130#next_previous (adamw, 17:08:13)
    5. https://openqa.fedoraproject.org/tests/421098#next_previous (adamw, 17:08:33)
    6. AGREED: 1727343 and 1727424 - AcceptedBlocker (Beta) - AFAWCS, these two crashes have the same basic cause and break GNOME Software and Cockpit package installation. They do not seem to happen 100% of the time but on current information we think they're significant enough to violate "The installed system must be able appropriately to install software with the default tool for the relevant software type in all release-blocking desktops" (adamw, 17:11:56)

  8. (1657125) group remove: keep mandatory pkgs of other installed groups (adamw, 17:15:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1657125 (adamw, 17:15:49)
    2. Proposed Blocker, spin-kickstarts, ASSIGNED (adamw, 17:15:49)
    3. AGREED: 1657125 - RejectedBlocker (Beta) - this is established behaviour and we don't believe it violates any of the criteria as it stands. (adamw, 17:26:24)

  9. (1715699) LiveOS boot, journalctl is missing many early messages (adamw, 17:26:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1715699 (adamw, 17:26:32)
    2. Proposed Blocker, systemd, NEW (adamw, 17:26:32)
    3. AGREED: 1715699 - RejectedBlocker (Beta) - as this bug is currently understood we do not believe it breaks the release criteria, it's just an unfortunate issue. The system logging function is present and does broadly work. This can be re-considered if further information or a different justification arises (adamw, 17:44:17)

  10. proposed Final blockers (adamw, 17:47:07)
    1. let's skip proposed Beta FE as we're still 6 weeks out from freeze date (adamw, 17:47:15)

  11. (1713485) ext3 partitions get remounted as read-only due to journal error ("journal block not found"..."Detected aborted journal") (adamw, 17:47:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1713485 (adamw, 17:47:45)
    2. Proposed Blocker, kernel, NEW (adamw, 17:47:45)
    3. this appears to have been fixed in May, we will close it (adamw, 17:49:31)

  12. Open floor (adamw, 17:50:58)


Meeting ended at 17:55:08 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (193)
  2. cmurf (83)
  3. lruzicka2 (41)
  4. frantisekz (26)
  5. sgallagh (23)
  6. coremodule (20)
  7. kparal (18)
  8. zodbot (13)
  9. pwhalen (7)
  10. puiterwijk (1)
  11. nb (1)
  12. satellit_ (1)


Generated by MeetBot 0.1.4.