#fedora-blocker-review: F37-blocker-review
Meeting started by adamw at 16:00:54 UTC
(full logs).
Meeting summary
- Roll Call (adamw, 16:00:58)
- Introduction (adamw, 16:09:45)
- Our purpose in this meeting is to review
proposed blocker and nice-to-have bugs and decide whether to accept
them, and to monitor the progress of fixing existing accepted
blocker and nice-to-have bugs. (adamw,
16:09:50)
- We'll be following the process outlined
at: (adamw,
16:09:54)
- https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
(adamw,
16:09:58)
- The bugs up for review today are available
at: (adamw,
16:10:02)
- http://qa.fedoraproject.org/blockerbugs/current
(adamw,
16:10:05)
- The criteria for release blocking bugs can be
found at: (adamw,
16:10:09)
- https://fedoraproject.org/wiki/Basic_Release_Criteria
(adamw,
16:10:12)
- https://fedoraproject.org/wiki/Fedora_37_Beta_Release_Criteria
(adamw,
16:10:15)
- https://fedoraproject.org/wiki/Fedora_37_Final_Release_Criteria
(adamw,
16:10:19)
- for Final, we have: (adamw,
16:10:29)
- 3 Proposed Blockers (adamw,
16:10:34)
- 6 Accepted Blockers (adamw,
16:10:38)
- 1 Accepted Previous Release Blockers
(adamw,
16:10:40)
- 6 Proposed Freeze Exceptions (adamw,
16:10:42)
- coremodule will secretarialize (adamw,
16:12:03)
- Proposed Final blockers (adamw, 16:12:14)
- (2125439) screencast doesn't record the top layer (adamw, 16:12:57)
- https://bugzilla.redhat.com/show_bug.cgi?id=2125439
(adamw,
16:12:58)
- https://pagure.io/fedora-qa/blocker-review/issue/910
(adamw,
16:12:59)
- Proposed Blocker, gnome-shell, NEW (adamw,
16:13:01)
- Ticket vote: FinalFreezeException (+1,0,-0)
(+nielsenb) (adamw,
16:13:05)
- this bug was fixed by
https://bodhi.fedoraproject.org/updates/FEDORA-2022-def12b4f54
according to the comments, we will close it (adamw,
16:17:49)
- (2127192) Update gnome-shell-extension-background-logo to 43.0 (adamw, 16:18:14)
- https://bugzilla.redhat.com/show_bug.cgi?id=2127192
(adamw,
16:18:21)
- https://pagure.io/fedora-qa/blocker-review/issue/914
(adamw,
16:18:22)
- Proposed Blocker,
gnome-shell-extension-background-logo, NEW (adamw,
16:18:24)
- Ticket vote: FinalBlocker (+2,0,-0)
(+asciiwolf, +nielsenb) (adamw,
16:18:25)
- Ticket vote: FinalFreezeException (+2,0,-0)
(+asciiwolf, +nielsenb) (adamw,
16:18:27)
- AGREED: 2127192 -
punt (delay decision) on blocker status, AcceptedFreezeException -
we agreed the justification for taking this as a blocker is quite
weak, and it shouldn't be necessary to consider it as the fix is
already prepared. We grant it a freeze exception just in case the
update doesn't make it stable before Final freeze (adamw,
16:28:12)
- (2121106) Czech qwerty layout configured in anaconda, but qwertz layout used in disk unlock and in VT console (adamw, 16:28:38)
- https://bugzilla.redhat.com/show_bug.cgi?id=2121106
(adamw,
16:28:42)
- https://pagure.io/fedora-qa/blocker-review/issue/867
(adamw,
16:28:46)
- Proposed Blocker, systemd, NEW (adamw,
16:28:49)
- Ticket vote: FinalBlocker (+0,0,-1)
(-nielsenb) (adamw,
16:28:59)
- Ticket vote: FinalFreezeException (+0,0,-1)
(-nielsenb) (adamw,
16:29:00)
- AGREED: 2121106 -
RejectedBlocker AcceptedFreezeException - with the new details about
how specific this bug is (you have to manually choose this exact
combination of X layouts to trigger it), and the difficulty of
fixing it fully, we agreed this is too conditional of a violation to
count as a blocker. However, we grant it a freeze exception so we
have time to land at least the moderate improvement that should be
possible (adamw,
16:40:45)
- Proposed Final freeze exceptions (adamw, 16:41:01)
- (2124830) geo location not working: Anaconda didn't set default local locale (adamw, 16:41:31)
- https://bugzilla.redhat.com/show_bug.cgi?id=2124830
(adamw,
16:41:34)
- https://pagure.io/fedora-qa/blocker-review/issue/908
(adamw,
16:41:45)
- Proposed Freeze Exceptions, anaconda,
POST (adamw,
16:41:46)
- AGREED: 2124830 -
AcceptedFreezeException (Final) - this is accepted as an FE as a
broken feature in the installer that can't be fixed with an
update. (adamw,
16:47:35)
- (2117256) Obsolete packages that used to require Python 3.10 but are gone in Fedora 37 (adamw, 16:47:47)
- https://bugzilla.redhat.com/show_bug.cgi?id=2117256
(adamw,
16:47:49)
- https://pagure.io/fedora-qa/blocker-review/issue/847
(adamw,
16:47:53)
- Proposed Freeze Exceptions,
fedora-obsolete-packages, ASSIGNED (adamw,
16:47:54)
- AGREED: 2117256 -
AcceptedFreezeException (Final) - this is a regularly-scheduled
clean up, and it helps with upgrade tests during the freeze
period (adamw,
16:52:40)
- we already approved 2127192 (adamw,
16:52:58)
- (2125426) some vpn tunnels aren't shown (adamw, 16:53:03)
- https://bugzilla.redhat.com/show_bug.cgi?id=2125426
(adamw,
16:53:15)
- https://pagure.io/fedora-qa/blocker-review/issue/911
(adamw,
16:53:17)
- Proposed Freeze Exceptions,
NetworkManager-openvpn, NEW (adamw,
16:53:17)
- https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/5845
is the upstream issue (adamw,
16:56:34)
- AGREED: 2125426 -
AcceptedFreezeException (Final) - this is annoying for users with
lots of VPNs, and would be present in the Workstation live so cannot
be fully addressed with an update (for people who like to configure
8+ VPNs in a live environment, at least) (adamw,
17:03:01)
- (2003425) python-jep-4.0.3 is available (adamw, 17:03:15)
- https://bugzilla.redhat.com/show_bug.cgi?id=2003425
(adamw,
17:03:19)
- https://pagure.io/fedora-qa/blocker-review/issue/912
(adamw,
17:03:23)
- Proposed Freeze Exceptions, python-jep,
NEW (adamw,
17:03:32)
- AGREED: 2003425 -
AcceptedFreezeException - this is accepted because the package
currently fails to install (that'll be the next proposed FE we vote
on) and we're fine with a minor version upgrade being done while
fixing the package to be installable (adamw,
17:09:24)
- (2098978) F37FailsToInstall: python3-jep (adamw, 17:09:26)
- https://bugzilla.redhat.com/show_bug.cgi?id=2098978
(adamw,
17:09:29)
- https://pagure.io/fedora-qa/blocker-review/issue/913
(adamw,
17:09:32)
- Proposed Freeze Exceptions, python-jep,
NEW (adamw,
17:09:38)
- AGREED: 2098978 -
AcceptedFreezeException (Final) - we generally approve
fails-to-install bugs, so the final frozen package set is as sane as
possible and to smooth the upgrade path during the freeze
(adamw,
17:14:26)
- Accepted Final blockers (adamw, 17:14:43)
- as a reminder, we are not re-voting these, we
are checking progress on fixing them (adamw,
17:14:54)
- 2088113 is ON_QA, just needs testing of the
fix (adamw,
17:15:13)
- (2123494) Unable to set up enterprise account with gnome-initial-setup, clicking continue does not join the domain (adamw, 17:15:23)
- https://bugzilla.redhat.com/show_bug.cgi?id=2123494
(adamw,
17:15:26)
- Accepted Blocker, gnome-initial-setup,
ASSIGNED (adamw,
17:15:28)
- current status on this one is that there's a
test scratch build which may fix the remaining issues, it needs
testing (adamw,
17:17:26)
- ACTION: adamw to try
and bodge up an openQA test at least far enough to test the scratch
build (adamw,
17:18:27)
- (2121110) GNOME Initial Setup uses the English keyboard, instead of the default keyboard (adamw, 17:22:58)
- https://bugzilla.redhat.com/show_bug.cgi?id=2121110
(adamw,
17:23:01)
- Accepted Blocker, gnome-shell, ASSIGNED
(adamw,
17:23:03)
- a fix was attempted for this, but per kparal,
didn't work. we are now waiting for devs to try another fix
(adamw,
17:27:40)
- (2121944) greenboot-grub2-set-counter.service fails on 38 IoT with "cannot open `/boot/grub2/grubenv.new`: No such file or directory." (adamw, 17:27:45)
- https://bugzilla.redhat.com/show_bug.cgi?id=2121944
(adamw,
17:27:47)
- Accepted Blocker, greenboot, NEW (adamw,
17:27:49)
- this is just sitting waiting for a dev to fix
it (adamw,
17:28:54)
- ACTION: adamw to poke
pbrobinson and see if he can provoke any movement on this
(adamw,
17:29:05)
- (2049849) Windows with bitlocker enabled can't be booted, needs to use bootnext instead of chainloader (adamw, 17:31:49)
- https://bugzilla.redhat.com/show_bug.cgi?id=2049849
(adamw,
17:31:52)
- https://pagure.io/fedora-qa/blocker-review/issue/695
(adamw,
17:31:54)
- Accepted Blocker, grub2, NEW (adamw,
17:31:58)
- https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2022-03-28/f36-blocker-review.2022-03-28-16.00.log.html#l-226
(bcotton,
17:33:57)
- ACTION: adamw to
propose changing the criteria to except the case we are not
currently able to support (adamw,
17:35:40)
- (2123274) [abrt] totem: nouveau_pushbuf_data(): totem killed by SIGABRT (adamw, 17:36:11)
- https://bugzilla.redhat.com/show_bug.cgi?id=2123274
(adamw,
17:36:13)
- Accepted Blocker, mesa, NEW (adamw,
17:36:17)
- we are waiting for maintainers to backport the
proposed fix for this, adamw has added a comment (adamw,
17:39:37)
- Open floor (adamw, 17:42:31)
- bcotton poked Fedora CoreOS folks about
addition to blocking images. waiting for them to figure it
out (bcotton,
17:43:30)
Meeting ended at 17:47:55 UTC
(full logs).
Action items
- adamw to try and bodge up an openQA test at least far enough to test the scratch build
- adamw to poke pbrobinson and see if he can provoke any movement on this
- adamw to propose changing the criteria to except the case we are not currently able to support
Action items, by person
- adamw
- adamw to try and bodge up an openQA test at least far enough to test the scratch build
- adamw to poke pbrobinson and see if he can provoke any movement on this
- adamw to propose changing the criteria to except the case we are not currently able to support
People present (lines said)
- adamw (187)
- bcotton (41)
- Penguinpee (24)
- geraldosimiao (20)
- zodbot (18)
- lruzicka (16)
- coremodule (10)
- frantisekz (7)
- TheExorcist[m] (3)
- lruzicka_ (3)
- Southern_Gentlem (2)
Generated by MeetBot 0.4.