#fedora-meeting: FESCo (2011-07-25)

Meeting started by notting at 17:01:40 UTC (full logs).

Meeting summary

  1. init process (notting, 17:02:29)
  2. #563 suggested policy: all daemons must set RELRO and PIE flags (notting, 17:05:18)
    1. ACTION: ajax will create standard macros for enabling full RELRO/PIE (notting, 17:09:01)
    2. AGREED: draft proposal at https://fedoraproject.org/wiki/User:Kevin/DRAFT_When_to_use_PIE_compiler_flags is approved (notting, 17:13:51)
    3. ACTION: nirik will take draft proposal to FPC (notting, 17:14:41)
    4. AGREED: no mass rebuild at this time for this feature (notting, 17:24:55)

  3. #615 Strategy for services that do not have systemd native unit files (notting, 17:25:28)
    1. need to get audidt #617321 iscsi #714688 NFS-Utils #699040 Tigervnc #717227 dnsmasq #694932 openvpn #714710 speech-dispatcherd #697600 smolt #697612 wpa_supplicant #661230 done before next tuesday if at all possible. (nirik, 17:33:05)
    2. AGREED: continue working on conversion, prioritizing services on livecd/livedvd, and services that start by default. Viking-Ice will organize activity days around conversion. revisit status next week (notting, 17:57:02)
    3. current status at https://fedoraproject.org/wiki/User:Johannbg/Features/SysVtoSystemd (notting, 17:57:18)
    4. ACTION: Viking-Ice will organize activity day around service conversion (notting, 17:57:37)

  4. #650 May DBUS autostart? (notting, 17:57:50)
    1. AGREED: DBUS may start by default (notting, 17:59:48)

  5. #651 Updated installation/live image needed (notting, 17:59:59)
    1. AGREED: ask PK maintainers to try and push out a fix, confirm PK updates itself first (notting, 18:03:35)
    2. AGREED: no respin at this time (notting, 18:03:41)
    3. ACTION: notting to contact PK maintainers (notting, 18:04:07)

  6. #652 Extension for the F-16 Aeolus Conductor feature (notting, 18:05:55)
    1. AGREED: extension granted (notting, 18:06:53)

  7. Next meeting (notting, 18:07:23)
    1. ACTION: mmaslano to chair next FESCo meeting (notting, 18:08:05)

  8. Fedora Engineering Services tickets - https://fedorahosted.org/fedora-engineering-services/report/6 (notting, 18:08:38)
    1. no new news (notting, 18:09:46)

  9. Open Floor (notting, 18:10:10)
    1. retiring of orphan packages will take place later today (notting, 18:10:50)
    2. have noticed request for Java 7 feature on list. waiting on any possible exception request from Java SIG (notting, 18:15:47)


Meeting ended at 18:20:24 UTC (full logs).

Action items

  1. ajax will create standard macros for enabling full RELRO/PIE
  2. nirik will take draft proposal to FPC
  3. Viking-Ice will organize activity day around service conversion
  4. notting to contact PK maintainers
  5. mmaslano to chair next FESCo meeting


Action items, by person

  1. ajax
    1. ajax will create standard macros for enabling full RELRO/PIE
  2. mmaslano
    1. mmaslano to chair next FESCo meeting
  3. nirik
    1. nirik will take draft proposal to FPC
  4. notting
    1. notting to contact PK maintainers
  5. Viking-Ice
    1. Viking-Ice will organize activity day around service conversion


People present (lines said)

  1. notting (105)
  2. nirik (59)
  3. sgallagh (52)
  4. Viking-Ice (35)
  5. t8m (27)
  6. pjones (19)
  7. mmaslano (16)
  8. ajax (16)
  9. zodbot (10)
  10. mjg59 (7)
  11. nim-nim (1)
  12. cwickert (0)


Generated by MeetBot 0.1.4.