#fedora-neuro: NeuroFedora - 2023-06-19

Meeting started by FranciscoD_ at 13:00:34 UTC (full logs).

Meeting summary

    1. Agenda is on the blog: https://neuroblog.fedoraproject.org/2023/06/19/next-open-neurofedora-meeting-19-June-1300-utc.html (FranciscoD_, 13:00:49)
    2. bot commands: https://fedoraproject.org/wiki/Meeting:Guide#MeetBot_Commands (FranciscoD_, 13:00:56)

  1. Introductions and roll call (FranciscoD_, 13:01:01)
  2. Tasks from last meeting (FranciscoD_, 13:06:44)
    1. last meeting logs are here: https://meetbot.fedoraproject.org/latest/neurofedora (FranciscoD_, 13:06:52)
    2. FranciscoD_ open issue/PR in package maintainer docs about re-triggering CI on PRs: PENDING (FranciscoD_, 13:07:23)
    3. ACTION: FranciscoD_ open issue/PR in package maintainer docs about re-triggering CI on PRs (FranciscoD_, 13:07:33)
    4. FranciscoD_ start non-responsive maintainer checks for Ilya: PENDING (FranciscoD_, 13:07:47)
    5. ACTION: FranciscoD_ start non-responsive maintainer checks for Ilya (FranciscoD_, 13:07:51)
    6. Penguinpee ask around if Koschei can be made to send notifications to the ML or automatically file bugs: PENDING (since Penguinpee has been on vacation since last meeting from what I know) (FranciscoD_, 13:08:18)
    7. ACTION: Penguinpee ask around if Koschei can be made to send notifications to the ML or automatically file bugs (FranciscoD_, 13:08:19)

  3. Open pagure tickets (FranciscoD_, 13:08:31)
    1. https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting (FranciscoD_, 13:08:35)
    2. https://pagure.io/neuro-sig/NeuroFedora/issue/549 -> NeuroFedora at Flock: we've submitted a CFP (FranciscoD_, 13:09:08)
    3. https://pagure.io/neuro-sig/NeuroFedora/issue/551 -> Discussion on EPEL support: to be discussed in the ticket, please do take a look and comment (FranciscoD_, 13:10:47)
    4. https://pagure.io/neuro-sig/NeuroFedora/issue/552 -> using packit to help with neuro-sig package maintenance: only opened this a few hours ago, so we'll discuss it next meeting when folks have had a chance to look into things (FranciscoD_, 13:13:20)
    5. https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/ZTID6MR7TU2X6ZKDGGH7RR426ODUEENX/ -> python 3.12 rebuild is in progress, please hold off building python and related packages until this is complete (FranciscoD_, 13:17:42)
    6. Python 3.12 side tag on Koji: https://koji.fedoraproject.org/koji/builds?latest=0&tagID=f39-python&order=-build_id&inherited=0 (FranciscoD_, 13:18:33)

  4. Packages health check (FranciscoD_, 13:18:49)
    1. Neuro-sig packager dashboard: https://packager-dashboard.fedoraproject.org/dashboard?groups=neuro-sig (FranciscoD_, 13:19:19)
    2. Please ignore s390x FTBFS reports if the package exludes s390x as a build arch. (FranciscoD_, 13:19:41)
    3. A few python packages have new versions available: we'll wait until the py3.12 rebuild is over to tackle these (FranciscoD_, 13:20:17)
    4. Same applies to ftbfs bugs (FranciscoD_, 13:20:51)
    5. Continue FTBFS investigations on stable branches (since they're unaffected by the re-build) (FranciscoD_, 13:22:26)
    6. FTBFS reports for these packages in stable branches: arbor (f37), genesis-simulator (f38), getdp (f38), highfive (f38), libneurosim (f38), libsbml (f38), libsonata (f37), morphio (f38), python-astor (f37), python-bluepyopt (f37, f38), python-cyiopt (f37), python-dipy (f38), python-mne (f37, f38), python-neatdend (f37), python-neurotune (f38), python-nibabel (f37), python-nilearn (f38), python-nipy (f38, f37), python-pandas (f37), (FranciscoD_, 13:28:41)
    7. Some FTBFS koschei reports could be false positives -> builders ran out of space (FranciscoD_, 13:30:39)

  5. Open package reviews check (FranciscoD_, 13:36:19)
    1. Neuro-sig reviews tracker bug: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro (FranciscoD_, 13:36:28)
    2. Please remember to block this when submitting a new review so that all sig members are notified (FranciscoD_, 13:36:48)
    3. one review ticket open: https://bugzilla.redhat.com/show_bug.cgi?id=2213973 -> should be easy, if someone has the cycles, please take it up (blocks the python-bokeh update) (FranciscoD_, 13:38:16)
    4. ACTION: FranciscoD_ mail -devel about review swap if package not picked up in a few days (FranciscoD_, 13:39:58)

  6. Comp neuro image compose check (FranciscoD_, 13:44:15)
    1. koji task here: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691 (FranciscoD_, 13:44:20)
    2. Green tick, all going along fine here (FranciscoD_, 13:44:34)

  7. Neuro(science) query of the week (FranciscoD_, 13:44:53)
    1. Not neuro related, but one related to all the LLMs: https://venturebeat.com/ai/the-ai-feedback-loop-researchers-warn-of-model-collapse-as-ai-trains-on-ai-generated-content/ (FranciscoD_, 13:45:46)
    2. https://www.sciencenews.org/article/supermassive-black-hole-orbit-blazar (FranciscoD_, 13:48:14)
    3. https://www.sciencenews.org/article/one-photon-photosynthesis-light (FranciscoD_, 13:48:18)
    4. https://blog.arxiv.org/2023/06/12/arxiv-is-hiring-software/ (job opportunity at arxiv) (FranciscoD_, 13:48:54)

  8. next meeting day, chair (FranciscoD_, 13:49:56)
    1. same time (1300 UTC), in 2 weeks (03 July) (FranciscoD_, 13:50:44)
    2. ankursinha will chair (FranciscoD_, 13:50:50)

  9. Open floor (FranciscoD_, 13:50:54)


Meeting ended at 14:01:05 UTC (full logs).

Action items

  1. FranciscoD_ open issue/PR in package maintainer docs about re-triggering CI on PRs
  2. FranciscoD_ start non-responsive maintainer checks for Ilya
  3. Penguinpee ask around if Koschei can be made to send notifications to the ML or automatically file bugs
  4. FranciscoD_ mail -devel about review swap if package not picked up in a few days


Action items, by person

  1. FranciscoD_
    1. FranciscoD_ open issue/PR in package maintainer docs about re-triggering CI on PRs
    2. FranciscoD_ start non-responsive maintainer checks for Ilya
    3. FranciscoD_ mail -devel about review swap if package not picked up in a few days
  2. Penguinpee
    1. Penguinpee ask around if Koschei can be made to send notifications to the ML or automatically file bugs


People present (lines said)

  1. FranciscoD_ (82)
  2. Penguinpee (26)
  3. zodbot (12)


Generated by MeetBot 0.4.