#fedora-meeting-2: Workstation WG (2020-03-10)

Meeting started by aday at 18:24:54 UTC (full logs).

Meeting summary

  1. Rollcall (aday, 18:24:55)
    1. present: cmurf, neal, aday, feborges, langdon, mclasen, petersen, mcatanzaro, kalev (aday, 18:24:55)
    2. regrets: tpopela (aday, 18:24:55)
    3. missing: otaylor (aday, 18:24:57)

  2. Approve minutes from 3 March (aday, 18:25:01)
    1. https://meetbot.fedoraproject.org/fedora-meeting-2/2020-03-10/workstation.2020-03-10-10.50.html (aday, 18:25:03)
    2. AGREED: No objections - approved (aday, 18:25:08)

  3. Announcements (aday, 18:25:10)
    1. Volunteers would be welcome for https://pagure.io/fedora-workstation/issue/135 (F32 issue) (aday, 18:25:12)
    2. F32 beta is scheduled for 17 March. There are blockers so it's 50/50 whether it will go out on time (blocker list: https://qa.fedoraproject.org/blockerbugs/milestone/32/beta/buglist ). (aday, 18:25:14)

  4. enabling earlyoom by default (aday, 18:25:19)
    1. https://pagure.io/fedora-workstation/issue/119#comment-631241 (aday, 18:25:21)
    2. Michael has asked whether we should re-evaluate our decision to enable earlyoom in F32 (aday, 18:25:23)
    3. Benjamin Berg has made progress on using cgroups to protect core desktop processes. We might not need any out of memory killer. In testing the system lags but doesn't hang. (aday, 18:25:25)
    4. AGREED: No consensus on backing earlyoom out, so we'll leave it in for F32. (aday, 18:26:00)

  5. Automatically install the OpenH264 codecs (aday, 18:26:02)
    1. https://pagure.io/fedora-workstation/issue/84 & https://pagure.io/releng/issue/9246 (aday, 18:26:06)
    2. Changes merged. Needs testing. (aday, 18:26:08)
    3. Neal: releng seems confident that these changes will be fine (aday, 18:26:10)

  6. Should we include thermald by default? (aday, 18:26:12)
    1. https://pagure.io/fedora-workstation/issue/71 (aday, 18:26:14)
    2. AGREED: Defer until Benjamin Berg can join us (aday, 18:26:16)

  7. Reconsider updates policy (aday, 18:26:20)
    1. https://pagure.io/fedora-workstation/issue/107 (aday, 18:26:22)
    2. AGREED: We'll move forward with the proposal in the ticket, and discuss further with Matthew Miller. (aday, 18:26:41)
    3. ACTION: Chris will reach out to Matthew (aday, 18:26:44)

  8. Review installation-related issues (aday, 18:26:46)
    1. Our list of installation-related issues is https://pagure.io/fedora-workstation/issues?status=Open&tags=installation&close_status= (aday, 18:26:48)
    2. Allan has organised the installer issues into categories based on what stage they are at (see the appendix below). (aday, 18:26:53)
    3. ACTION: Allan to provide designs for a reorganised installer session. (aday, 18:26:59)
    4. ACTION: Michael, Allan and Neal volunteer to meet with the Anaconda team (aday, 18:27:12)

  9. Appendix: installation-related issues (aday, 18:27:14)
    1. 1. Issues with solutions (aday, 18:27:16)
    2. A. Desktop session integration - also discussed in #124 (aday, 18:27:18)
    3. B. Change from hub and spoke to a linear workflow - #124 (aday, 18:27:29)
    4. 2. Issues which need engineering design (aday, 18:27:39)
    5. C. Disk partitioning changes (aday, 18:27:41)
    6. 3. Issues which need UX design recommendations (aday, 18:27:50)
    7. D. Installation progress page (aday, 18:27:52)
    8. E. Simplify installation destination page - #132 (aday, 18:27:56)


Meeting ended at 18:28:06 UTC (full logs).

Action items

  1. Chris will reach out to Matthew
  2. Allan to provide designs for a reorganised installer session.
  3. Michael, Allan and Neal volunteer to meet with the Anaconda team


People present (lines said)

  1. aday (79)
  2. zodbot (7)
  3. cmurf (0)


Generated by MeetBot 0.1.4.