#fedora-meeting-2: Workstation WG (2023-12-05)

Meeting started by brainycmurf at 03:42:07 UTC (full logs).

Meeting summary

    1. Present members: Michael, Owen, Kalev, Allan, Chris (brainycmurf, 03:42:07)
    2. Guests: (brainycmurf, 03:42:07)
    3. Regrets: Tomas, Matthias, Jens (brainycmurf, 03:42:07)
    4. Missing: (brainycmurf, 03:42:09)
    5. Secretary:Owen (brainycmurf, 03:42:11)

  1. Switch from meet.opensuse.org to a different conferencing platform (brainycmurf, 03:42:13)
    1. https://pagure.io/fedora-workstation/issue/403 (brainycmurf, 03:42:15)
    2. new setup (meet-test.opensuse.org) working well for some people, some people seeing video bugs; extensive discussion of alternatives. Will keep meet-test.opensuse.org for now. (brainycmurf, 03:42:17)

  2. Enable full preemption (brainycmurf, 03:42:20)
    1. https://pagure.io/fedora-workstation/issue/228 (brainycmurf, 03:42:22)
    2. Owen with general agreement suggested that doing this by kernel command line is not great - very hard to upgrades, hard to do just for some variants. Chris sent a mail to llkml some time ago about moving switch from debugfs to sysfs, but didn't get a response. (brainycmurf, 03:42:24)
    3. Neal would like to see characterization of this on server workloads so that we could enable across variants (brainycmurf, 03:42:28)
    4. Discussion of whether we *know* this is desktop only, or might make sense for server workloads as well - especially now that serv7ers are often running more complex workloads with cgroups, etc. (brainycmurf, 03:42:31)
    5. Discussion of how to test - what are the (desktop) workloads that we expect this to make a difference - OBS streaming? Audio? (Fedora Jam apparently sets up preempt=full). Is sysprof useful for testing whether preempt=full improves responsiveness/smoothess of GNOME shell under high load (brainycmurf, 03:42:36)
    6. ACTION: Chris and Neal to check in with members of Meta kernel team to see if they have insight about moving the switch out of debugfs - or how to move forward for there. (brainycmurf, 03:42:40)

  3. Announcements and status updates (brainycmurf, 03:42:43)
    1. https://discussion.fedoraproject.org/t/learning-from-the-f40-tuned-replaces-ppd-change-proposal/97786 (brainycmurf, 03:42:45)
    2. discussion of role of working group vs. fesco in change proposal process (brainycmurf, 03:42:48)
    3. Allan change proposals were conceived as "notification" of things coming from upstream (brainycmurf, 03:42:50)
    4. Neal - there's a split between notications of upcoming upstream changes, and change proposals for work that is being done downstream - specific to fedora, and the second set of things is getting larger; policy documents lag behind. (brainycmurf, 03:42:52)
    5. Nobody wanted to copy the releng part where there has to be a ticket filed (brainycmurf, 03:42:56)
    6. Allan felt there isn't enough time between posting and voting - that voting can get in the way of the discussion. (brainycmurf, 03:42:58)
    7. https://meetbot.fedoraproject.org/fedora-meeting-2/2023-11-30/workstation.2023-11-30-01.07.log.html (brainycmurf, 03:43:03)


Meeting ended at 03:43:08 UTC (full logs).

Action items

  1. Chris and Neal to check in with members of Meta kernel team to see if they have insight about moving the switch out of debugfs - or how to move forward for there.


People present (lines said)

  1. brainycmurf (28)
  2. zodbot (7)
  3. Michael (0)


Generated by MeetBot 0.4.